Subject: Closing #90: multipart/byteranges

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Apr 2009 14:56:54 +1000

Haven't seen discussion on this for a while, seems like consensus is  
to drop multipart/byteranges as a delimiter. Any objection to that?

On 12/12/2008, at 4:17 AM, Jamie Lokier wrote:

>
> Henrik Nordstrom wrote:
>>> They aren't used that way.  I don't know of any implementation
>>> that uses the multipart delimiter to find the end of body (they
>>> use CL, chunked, or a closed connection).
>>
>> Hmm.. you may be right. On a closer inspection I see that I misread  
>> some
>> of the data. Sorry for the confusion.
>>
>> So it looks like dropping 4.4 §4 entirely may be an option.
>
> If it's possible to drop support for multipart/byterange delimited
> messages, because it's not used anyway, that would be a really good
> thing imho.  It's an ugly, pointless, unused and probably poorly
> implemented complication in message parsers.
>
> -- Jamie
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Henrik Nordstrom <[email-masked]>
Date: Tue, 07 Apr 2009 08:03:58 +0200

None here.