Subject: Re: case-sensitivity of weakness indicator

From: Julian Reschke <[email-masked]>
Date: Thu, 02 Apr 2009 12:13:57 +0200

Hi,

I recorded this as

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/153>

and added a proposed patch as outlined in my earlier mail:

<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/153/i153.diff>

BR, Julian

Julian Reschke wrote:
> Hi,
> 
> looking at 
> <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p4-conditional-06.html#rfc.section.2>: 
> 
> 
> --- snip ---
>   entity-tag = [ weak ] opaque-tag
>   weak       = "W/"
>   opaque-tag = quoted-string
> 
> ...
> 
> A "weak entity tag," indicated by the "W/" prefix, MAY be shared by two 
> entities of a resource only if the entities are equivalent and could be 
> substituted for each other with no significant change in semantics. A 
> weak entity tag can only be used for weak comparison.
> --- snip ---
> 
> 
> According to the ABNF, "w/" would be allowed as well. However, the prose 
> doesn't mention this.
> 
> It seems this was just an oversight, and the spec should state the 
> weakness indicator *is* case-sensitive, by saying:
> 
>   entity-tag = [ weak ] opaque-tag
>   weak       = %x57.2F ; "W/", case-sensitive
>   opaque-tag = quoted-string
> 
> 
> Feedback appreciated,
> 
> Julian
>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 03 Apr 2009 11:51:00 +0200

> <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/153/i153.diff> 

I have applied the patch (and closed the issue) with

   <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/570>

Best regards, Julian