Subject: Re: Minutes from informal IETF/W3C meeting about HTML5 work

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 01 Apr 2009 16:34:51 +0900

At one point, it definitely was. Many people on the uri list were not
interested in IRI issues, and some i18n experts on the IRI list weren't
interested in URI issues.

Of course, times may have changed, and in case we'd decide to
stuff all the HTML5 bugwards-compatibility stuff for URIs into the
IRI spec because the URI spec is already at Full Standard, things
might change.

Regards,    Martin.

On 2009/03/31 20:10, Mark Nottingham wrote:
> Just thinking out loud -- is it *really* a good idea to have separate
> URI and IRI lists?
>
> Cheers,

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 17 Apr 2009 16:48:58 +0100

Mark Nottingham wrote:

> Various folks from the IETF and W3C's HTML5 WG got together in San  
> Francisco last week to discuss the parts of that work.
>
> Rough minutes are at:
>   http://esw.w3.org/topic/IETF_HTML5_Meeting_March_2009

 From the minutes:

> MIME type registrations for text/html and application/xhtml+xml (note 
> HTML WG issue ISSUE-53 mediatypereg 
> <http://www.w3.org/html/wg/tracker/issues/53>)
>
>     * This item appeared to be routine business as usual. Any issues
>       are internal to the W3C.
>     * Action Item: Sam to work on reconciling the multiple uses of the
>       MIME types
>
W3C can request IESG to update the MIME type registration. I am the AD 
tasked with reviewing MIME type registrations from other SDOs. So people 
can email me if they want early/more informal reviews.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 17 Apr 2009 17:10:25 +0100

From the minutes:

> HTML5's URI section (DanConnolly <http://esw.w3.org/topic/DanConnolly> 
> and Larry Masinter to work on this; e.g. HTML WG action 68 
> <http://www.w3.org/html/wg/tracker/actions/68>)
>
>     * We discussed IDN and URI/IRI (international domain names vs.
>       HTML5/W3C use of IRI). Changes to IRI would impact specs like
>       Atom. Larry advocated revising this spec, others were less
>       enthusiastic. It would be a big undertaking, and it wasn't clear
>       that Martin Dürst was available.
>
I talked to Martin using Skype today and he said he was available. He 
also mentioned that he would like to have a co-editor and mentioned 
Larry and few other names.

>     * Rob Sayre suggested the name "Hypertext References". This was
>       met with wide approval.
>    *
>
>       Action Item <http://www.w3.org/html/wg/tracker/actions/118>: Dan
>       to reformat the document as an Internet Draft
>
Looking forward to reading this.