Subject: PATCH and ETags

From: Pablo Castro <[email-masked]>
Date: Fri, 12 Jun 2009 16:25:22 -0700

At was looking the current draft of PATCH (http://tools.ietf.org/html/draft-dusseault-http-patch-14) and noticed that it currently discusses conflicts only in the context of strong ETags:

"Clients wishing to apply a patch document to a known entity can first acquire the strong ETag of the resource to be modified, and use that Etag in the If-Match header on the PATCH request to verify that the resource is still unchanged.  If a strong ETag is not available for a given resource, the client can use If-Unmodified-Since as a less-reliable safeguard."

Given the update that went into HTTPbis last year around allowing weak ETags on PUT/DELETE [1], shouldn't this spec also allow weak ETags on PATCH? I understand that the sentence above doesn't say that clients MUST use strong ETags, but the way it's spelled out certainly pushes in that direction.

Thanks
-pablo

[1] http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/116/i116.diff

---

From: Julian Reschke <[email-masked]>
Date: Sat, 13 Jun 2009 08:30:15 +0200

Pablo Castro wrote:
> ...

Agreed. We discussed this several times; I think the last thread starts 
with 
<http://lists.w3.org/Archives/Public/ietf-http-wg/2009JanMar/0140.html>.

> Given the update that went into HTTPbis last year around allowing weak ETags on PUT/DELETE [1], shouldn't this spec also allow weak ETags on PATCH? I understand that the sentence above doesn't say…

Actually, the PATCH spec should be silent on that issue.

> [1] http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/116/i116.diff

BTW: this change has been made in draft -03.

BR, Julian