Subject: Issue 166: clarify term "User Agent" and resolve inconsistencies with W3C specs

From: Julian Reschke <[email-masked]>
Date: Mon, 01 Jun 2009 21:59:07 +0200

Hi,

based on an off-list suggestion from Larry, I just added 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/166>.

Larry Masinter wrote:
> Brief summary:
> 
> The HTTP document uses two terms "user agent" and "client",
> and in some cases it is careful to distinguish between them,
> but not always. I would like to see a careful
> review of each appearance of the terms to insure that
> "user agent" is used in situations where there is a user,
> and "client" used in cases where the initiator of the action
> is either a user agent or another agent with no explicit user.
> 
> I think this will help the document, and the task relatively
> limited and editorial.
> 
> Some instances may require discussion.
> 
> Larry
> --
> http://larry.masinter.net

BR, Julian

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 1 Jun 2009 17:50:40 -0700

On Jun 1, 2009, at 12:59 PM, Julian Reschke wrote:

> Hi,
>
> based on an off-list suggestion from Larry, I just added <http:// 
> trac.tools.ietf.org/wg/httpbis/trac/ticket/166>.
>
> Larry Masinter wrote:
>> Brief summary:

As I mentioned on the HTML list, user agent does not mean there
is a user watching the screen.  UA means a client that initiates
requests (as in, decides to start an action based on user controls
or user configuration).

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 2 Jun 2009 11:02:07 +1000

I haven't followed that discussion (indeed, I can't subscribe to the  
HTML-WG mailing list, but that's another topic).

To me, the biggest difference is that a UA is the end node; i.e., it  
is the 'origin client' to compliment the 'origin server.' A proxy is a  
client, not a user-agent.

Gateways make this a bit tricky, just as they do with an origin  
server. E.g., a gateway that implements ESI makes independent  
requests, but doesn't have a user sitting there. However, it pretends  
to be a UA.

On 02/06/2009, at 10:50 AM, Roy T. Fielding wrote:

>> based on an off-list suggestion from Larry, I just added <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/166 
>> >.
>>
>> Larry Masinter wrote:
>>> Brief summary:

--
Mark Nottingham     http://www.mnot.net/

---

From: Daniel Stenberg <[email-masked]>
Date: Tue, 2 Jun 2009 09:14:14 +0200 (CEST)

On Mon, 1 Jun 2009, Julian Reschke wrote:

>> The HTTP document uses two terms "user agent" and "client", and in some 
>> cases it is careful to distinguish between them, but not always.

I think every attempt to separate the two like is futile and doomed to only 
cause further confusion.

Can anyone come up with some proper cases where the distinction between these 
two helps?

-- 

  / daniel.haxx.se

---

From: Daniel Stenberg <[email-masked]>
Date: Tue, 2 Jun 2009 09:16:38 +0200 (CEST)

On Tue, 2 Jun 2009, Mark Nottingham wrote:

> To me, the biggest difference is that a UA is the end node; i.e., it is the 
> 'origin client' to compliment the 'origin server.' A proxy is a client, not 
> a user-agent.

Ah yes. That's a very good point, but isn't it a bit too subtle to name an 
end-point "UA" while an end-point or proxy is called "client" ?

I mean, if the distinction in the docs need to separate an end-point from a 
proxy, won't for example those (more explicit) terms be better to use then?

-- 

  / daniel.haxx.se

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Jun 2009 17:48:58 +1000

I'd agree the chosen terminology isn't great. Not sure that changing  
it wouldn't cause more proplems than it solves.

On 02/06/2009, at 5:16 PM, Daniel Stenberg wrote:

>> To me, the biggest difference is that a UA is the end node; i.e.,  
>> it is the 'origin client' to compliment the 'origin server.' A  
>> proxy is a client, not a user-agent.
>
> Ah yes. That's a very good point, but isn't it a bit too subtle to  
> name an end-point "UA" while an end-point or proxy is called  
> "client" ?
>
> I mean, if the distinction in the docs need to separate an end-point  
> from a proxy, won't for example those (more explicit) terms be  
> better to use then?
>
> -- 
>
> / daniel.haxx.se
>