Subject: Re: [draft-nottingham-http-link-header-06] 4.1 Registered Relation Types

From: Mark Nottingham <[email-masked]>
Date: Fri, 21 Aug 2009 16:41:15 +1000

On 24/07/2009, at 11:55 PM, Anne van Kesteren wrote:

> I think this section should not talk about what implementations are  
> allowed to do internally. The concern of the specification should be  
> what goes in and what goes out. Therefore I think the entire last  
> paragraph should be dropped. We should not give the impression that http://www.iana.org/assignments/relation/stylesheet 
>  will _ever_ work.

I was sorely tempted to do this a little while ago. Unless someone  
objects strongly, I'm going to drop that text (currently a separate  
para).

> Also, can we require that the canonical registration form is  
> lowercase?

That's probably sensible. I'll modify the BNF and prose.

Additionally, any objections to requiring sgml-name (probably needs a  
new name, now that it's going to be all lower) for registered?  
Currently it's SHOULD.

Thanks,

--
Mark Nottingham     http://www.mnot.net/

---

From: "Anne van Kesteren" <[email-masked]>
Date: Tue, 25 Aug 2009 10:00:53 +0200

On Fri, 21 Aug 2009 08:41:15 +0200, Mark Nottingham <[email-masked]> wrote:
>> Also, can we require that the canonical registration form is lowercase?
>
> new name, now that it's going to be all lower) for registered? Currently  
> it's SHOULD.

Personally I do not care much either way, but allowing e.g. names with non-Western characters or characters with accents is fine with me, as long as the matching stays ASCII case-insensitive and the registered form is ASCII lowercase. I think HTML 5 allows any string that does not contain whitespace characters. (But I suppose that clashes with the discussion of what the registry should look like and whether URIs are a good idea here.)

-- 
Anne van Kesteren
http://annevankesteren.nl/