Subject: Re: Update on issue 155 (Content Sniffing)

From: Mark Nottingham <[email-masked]>
Date: Tue, 4 Aug 2009 11:22:05 -0700

Hi Adam,

Actually, there were a number of people arguing in the Stockholm  
meeting that HTTP does indeed define the interpretation of the data  
type of a message, which is why the proposal to delete it was made.

As you point out, this is just a note, and doesn't affect conformance;  
it is still completely conformant to sniff the type of a message  
(because what you *do* with the data type is still up to the  
application).

Cheers,

On 30/07/2009, at 12:50 PM, Adam Barth wrote:

> On Thu, Jul 30, 2009 at 4:34 AM, Anne van Kesteren<[email-masked]>  
> wrote:
>> On Thu, 30 Jul 2009 13:28:37 +0200, Julian Reschke <[email-masked] 
>> > wrote:
>>> we discussed the issue of content sniffing again during the  
>>> HTTPbis WG
>>> meeting and the general feeling was that we were going to far with  
>>> the
>>> statement:
>>>
>>> "Note that neither the interpretation of the data type of a  
>>> message nor
>>> the behaviors caused by it are defined by HTTP; this potentially
>>> includes examination of the content to override any indicated type
>>> ("sniffing")."
>>>
>>> The proposal is to remove this altogether.
>>>
>>> See <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/155#comment: 
>>> 3>
>>>
>>> Feedback appreciated,
>>
>> This would disallow e.g. the behavior of <img src> or <script src>  
>> as exhibited by Web browsers as I understand things. Having said  
>> that, notes are typically non-normative so maybe it does not?
>
> Maybe we ought to say:
>
> "Note that neither the interpretation of the data type of a message
> nor the behaviors caused by it are defined by HTTP."
>
> No one seems to be arguing about this statement, but it's non-obvious
> to folks reading the spec and therefore worth noting,
>
> Adam
>

--
Mark Nottingham     http://www.mnot.net/

---

From: "Anne van Kesteren" <[email-masked]>
Date: Wed, 05 Aug 2009 14:29:14 +0200

> (because what you *do* with the data type is still up to the  

Can we add a note to that effect then?

Proposal:

      Note that the behavior caused by the data type
      is not defined by HTTP; this potentially
      includes examination of the content to override
      any indicated type ("sniffing").

Cheers,

-- 
Anne van Kesteren
http://annevankesteren.nl/

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 5 Aug 2009 07:57:40 -0700

On Aug 5, 2009, at 5:29 AM, Anne van Kesteren wrote:

>> As you point out, this is just a note, and doesn't affect  
>> conformance; it is still completely conformant to sniff the type  
>> of a message (because what you *do* with the data type is still up  
>> to the application).
>

No.  HTTP defines the intended behavior for processing the payload
of a response by the combination of method, status, and media type,
the latter being a reference to a behavior-defining spec via the
media type registry.

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 5 Aug 2009 11:15:39 -0700

Hi Anne,

I think the general feeling here is that by calling out sniffing as a  
possibility, it will encourage it. As it stands, sniffing is not  
prohibited, it just isn't advertised as something that should be done.  
I.e., the content sniffing spec will NOT be in conflict with HTTP.  
Does that work for you?

Cheers,

On 05/08/2009, at 5:29 AM, Anne van Kesteren wrote:

>> conformance; it is still completely conformant to sniff the type of  
>> a message (because what you *do* with the data type is still up to  
>> the application).
>

---

From: "Anne van Kesteren" <[email-masked]>
Date: Wed, 05 Aug 2009 20:59:05 +0200

On Wed, 05 Aug 2009 20:15:39 +0200, Mark Nottingham <[email-masked]> wrote:
> I.e., the content sniffing spec will NOT be in conflict with HTTP. Does  
> that work for you?

Yeah, your message is probably sufficient in case there is/was/will be any doubt. Thanks!

---

From: Julian Reschke <[email-masked]>
Date: Thu, 06 Aug 2009 13:23:06 +0200

Mark Nottingham wrote:
> Hi Adam,
> 
> Actually, there were a number of people arguing in the Stockholm meeting 
> that HTTP does indeed define the interpretation of the data type of a 
> message, which is why the proposal to delete it was made.
> 
> (because what you *do* with the data type is still up to the application).
> 
> Cheers,
> ...

I made the proposed change (taking out that paragraph) with 
<http://trac.tools.ietf.org/wg/httpbis/trac/changeset/663>.

BR, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 10 Aug 2009 14:58:51 +1000

Re-closed.

On 06/08/2009, at 9:23 PM, Julian Reschke wrote:

> I made the proposed change (taking out that paragraph) with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/663 
> >.
>
> BR, Julian
>