Subject: Age response header and HTTP/1.0 requests

From: Adrien de Croy <[email-masked]>
Date: Tue, 06 Apr 2010 13:11:36 +1200

Hi all

I'm finding some odd behaviour with browsers when serving from cache to 
an HTTP/1.0 request.

I'm finding IE8 disconnects after the first buffer if the Age header is 
present (this is the only difference between success and failure scenarios).

So, do we need some text in the http1.1 bis caching document about 
sending cache headers in respect of the version of the request?  E.g. 
safety issues of sending HTTP/1.1 headers back to an HTTP/1.0 response.

Regards

Adrien

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 6 Apr 2010 11:43:37 +1000

HTTP/1.1 caching headers are perfectly valid in HTTP/1.0 responses; e.g., if a 1.0 cache is in front of a 1.1 server, it can't know which headers to strip, and a client has to be able to handle the response (indeed, it will still be interested in these headers, and the 1.1 caching model is designed with this scenerio in mind).

I'm having a bit of trouble reproducing this, however; if I browse with IE8 (cache cleared) behind a HTTP/1.0 proxy (Squid), a 200 response with a non-zero Age header is displayed correctly -- even if it spans multiple packets.

Cheers,

On 06/04/2010, at 11:11 AM, Adrien de Croy wrote:

> 
> Hi all
> 
> I'm finding some odd behaviour with browsers when serving from cache to an HTTP/1.0 request.
> 
> I'm finding IE8 disconnects after the first buffer if the Age header is present (this is the only difference between success and failure scenarios).
> 
> So, do we need some text in the http1.1 bis caching document about sending cache headers in respect of the version of the request?  E.g. safety issues of sending HTTP/1.1 headers back to an HTTP/1.0 response.
> 
> Regards
> 
> Adrien
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: Adrien de Croy <[email-masked]>
Date: Tue, 06 Apr 2010 14:50:13 +1200

sorry to cry wolf... turns out it was another problem in our filtering 
API.  Looks like IE is behaving fine.

apologies again

Adrien