Subject: How many coding registries should we have? (Issue 143), was: Issue 189, Re: Content/Transfer-Codings organization/IANA considerations (issue 143, 188, 189)

From: Julian Reschke <[email-masked]>
Date: Thu, 08 Apr 2010 16:06:12 +0200

On 07.08.2009 18:59, Julian Reschke wrote:
> ...
> So they really should be defined separately from Transfer-Coding and
> Content-Coding, and be collected in the same registry (surprise: IANA
> already has both in "http-parameters").
>
> Feedback appreciated...
> ...

As far as I can tell, this is the one remaining issue related to ticket 
143 (<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/143>).

The current status is:

- IANA has two registries (transfer coding and content coding), which 
*both* are maintained at <http://www.iana.org/assignments/http-parameters>

- Part 1 defines Transfer Codings, the Transfer Coding registry, and 
updates the transfer coding registrations

- Part 3 defines Content Codings (referring to Part 1 for the 
compression codings), the Content Coding registry, and updates the 
content coding registrations

- Both registries have been clarified/modified to require spec & expert 
review

The open question is:

- Do these two registries share the same namespace? That is, is it 
allowed for a coding named X to be both a transfer and a content coding, 
and have incompatible definitions?

I think this would be a very bad idea, so we really should unify the 
registries to a single coding registry, and then have new entries state 
as which type (transfer/content) they can be used. My assumption would 
be that any transfer coding could be a content coding, but that the 
opposite is not true.

Feedback appreciated,

Julain

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Apr 2010 13:10:59 +1000

Personally, I like how IANA has it set up now; a little bit of duplication never hurt anyone, and it avoids the "oh, I didn't notice that column" defence.

Really, though, as long as it's clear where each can be used, I don't have a problem.

On 09/04/2010, at 12:06 AM, Julian Reschke wrote:

> As far as I can tell, this is the one remaining issue related to ticket 143 (<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/143>).
> 
> The current status is:
> 
> - IANA has two registries (transfer coding and content coding), which *both* are maintained at <http://www.iana.org/assignments/http-parameters>
> 
> - Part 1 defines Transfer Codings, the Transfer Coding registry, and updates the transfer coding registrations
> 
> - Part 3 defines Content Codings (referring to Part 1 for the compression codings), the Content Coding registry, and updates the content coding registrations
> 
> - Both registries have been clarified/modified to require spec & expert review
> 
> The open question is:
> 
> - Do these two registries share the same namespace? That is, is it allowed for a coding named X to be both a transfer and a content coding, and have incompatible definitions?
> 
> I think this would be a very bad idea, so we really should unify the registries to a single coding registry, and then have new entries state as which type (transfer/content) they can be used. My assumption would be that any transfer coding could be a content coding, but that the opposite is not true.
> 
> Feedback appreciated,
> 
> Julain
> 
> 
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 09 Apr 2010 09:52:05 +0200

> Really, though, as long as it's clear where each can be used, I don't have a problem.

So how about just stating: "IANA should ensure that content coding and 
transfer coding names may only be the same when the encoding is the same"?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Apr 2010 18:01:00 +1000

If that implies they'll be separate registries (possibly with the same URL, as it is now), works for me.

On 09/04/2010, at 5:52 PM, Julian Reschke wrote:

> So how about just stating: "IANA should ensure that content coding and transfer coding names may only be the same when the encoding is the same"?
> 
> Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 09 Apr 2010 10:04:24 +0200

> If that implies they'll be separate registries (possibly with the same URL, as it is now), works for me.

Ack.

Essentially it'll be an instruction to the Designated Experts.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sat, 10 Apr 2010 13:29:32 +0200

> Essentially it'll be an instruction to the Designated Experts.

Proposed changes (see 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/143/>):

Part 1:

    Names of transfer codings MUST NOT overlap with names of content
    codings (Section 2.2 of [Part3]), unless the encoding transformation
    is indeed identical (as it is the case for the compression codings
    defined in Section 6.2.2).

Part 3:

    Names of content codings MUST NOT overlap with names of transfer
    codings (Section 6.2 of [Part1]), unless the encoding transformation
    is indeed identical (as it is the case for the compression codings
    defined in Section 6.2.2 of [Part1]).

Best regards, Julian