Subject: Re: [#193] Trailers and intermediaries

From: Mark Nottingham <[email-masked]>
Date: Fri, 22 Oct 2010 13:32:49 +1100

Scheduled for -12.

On 14/07/2010, at 9:41 PM, Julian Reschke wrote:

> On 14.07.2010 07:14, Mark Nottingham wrote:
>> Henrik,
>> 
>> I think a bit more of a change is necessary to get this right;
>> 
>>> b) the trailer fields consist entirely of optional metadata, and the recipient could use the message (in a manner acceptable to the server where the field originated) without receiving it. In other words, the server that generated the header (often but not always the origin server) is willing to accept the possibility that the trailer fields might be silently discarded along the path to the client.
>> 
>> Thoughts?
> 
> Sounds good. Proposed patch: <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/193/193.diff>.
> 
> Best regards, Julian
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 22 Oct 2010 11:09:39 +0200

On 22.10.2010 04:32, Mark Nottingham wrote:
>> Sounds good. Proposed patch:<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/193/193.diff>.
>>
>> Best regards, Julian

I just checked, and Henrik initially also proposed:

> And for clarity add the obvious restriction that
>>
>> A proxy server MUST NOT move any existing entity headers to the trailer
>> unless 'a' is fulfilled.

Do we still want it, and where does it need to go?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 22 Oct 2010 20:54:51 +1100

Personally, I'm inclined to leave it out; H?

---

From: Julian Reschke <[email-masked]>
Date: Sat, 23 Oct 2010 09:35:03 +0200

> Personally, I'm inclined to leave it out; H?

-> <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1053>

Best regards, Julian

---

From: Henrik Nordström <[email-masked]>
Date: Sat, 23 Oct 2010 10:10:42 +0200

Looks good.

Regards
Henrik