Subject: Re: issue 226, "proxies not supporting certain methods"

From: Julian Reschke <[email-masked]>
Date: Wed, 27 Oct 2010 15:21:07 +0200

On 23.07.2010 14:53, Julian Reschke wrote:
> Hi,
>
> just raised:
>
> Part 2, 9.1 says:
>
> "A proxy MUST NOT modify the Allow header field even if it does not
> understand all the methods specified, since the user agent might have
> other means of communicating with the origin server." --
> <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-latest.html#rfc.section.9.1>
>
>
> That is *very* misleading as it implies that it's somehow ok for a proxy
> not to implement a method it doesn't know about. However, the
> transmission semantics for methods are generic (see Part 1, except for a
> few well-defined exceptions).
> ...

Proposal:

"A proxy MUST NOT modify the Allow header field -- it doesn't need to 
understand all the methods specified in order to handle them according 
to the generic message handling rules."

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 Oct 2010 10:31:22 +1100

+1

On 28/10/2010, at 12:21 AM, Julian Reschke wrote:

> "A proxy MUST NOT modify the Allow header field -- it doesn't need to understand all the methods specified in order to handle them according to the generic message handling rules."
> 
> Best regards, Julian
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 28 Oct 2010 09:25:26 +0200

Fixed with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1068>.

Best regards, Julian