Subject: Re: CONNECT command with message body

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Oct 2010 15:23:23 +1100

This is now:
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/251
since we've taken on CONNECT from RFC2817.

Cheers,

On 05/05/2009, at 5:21 PM, Adrien de Croy wrote:

> 
> Hi all
> 
> I've come across a problem with an HTTP client which sends message bodies and Content-Length when using the CONNECT method.
> 
> Is it even legal for a CONNECT command to have a body?  If it does, what should the proxy do?  The client (a panasonic blue-ray player) breaks if the body is forwarded, however RFC2817 Sec 5.2 last para implies it is legal to have a body here.
> 
> Does anyone know of any other client that sends a body on CONNECT and relies on it?  It seems very odd to have a body there, since you don't even have a connection necessarily to the end server yet.  I'm loath to break the proxy to support a broken client.
> 
> Regards
> 
> Adrien
> 
> -- 
> Adrien de Croy - WinGate Proxy Server - http://www.wingate.com
> 
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Mon, 18 Oct 2010 06:55:41 +0200

> > Does anyone know of any other client that sends a body on CONNECT and relies on it?  It seems very odd to have a body there, since you don't even have a connection necessarily to the end server y…

FWIW, I think other people have already been experiencing the same issue,
because I remember having seen some software a few years ago explicitly
state "Content-length: 0" in all CONNECT requests.

Regards,
Willy