Subject: #233: Is * usable as a request-uri for new methods?

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Oct 2010 17:21:50 +1100

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/233>

The * URI form is currently specific to OPTIONS, and as discussed has caused a fair amount of pain / confusion.

Does anyone object to disallowing its use with extension methods?

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Oct 2010 15:48:57 +0200

> Does anyone object to disallowing its use with extension methods?

I agree we should disallow it.

BR, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 22 Oct 2010 09:29:21 +1100

OK, marking for incorporation into -12.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 22 Oct 2010 14:46:17 +0200

> OK, marking for incorporation into -12.

So, in P1 we have:

-- snip --
The asterisk "*" ("asterisk form") means that the request does not apply 
to a particular resource, but to the server itself, and is only allowed 
when the method used does not necessarily apply to a resource. One 
example would be

OPTIONS * HTTP/1.1
-- snip --

This would become:
-- snip --
The asterisk "*" ("asterisk form") means that the request does not apply 
to a particular resource, but to the server itself. This is only allowed 
for the OPTIONS method. Thus, the only valid example is

OPTIONS * HTTP/1.1
-- snip --

In P2, we *could* add it to the Considerations for new Methods. Do we 
need to?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 23 Oct 2010 09:47:18 +1100

I think we can leave it out for now; it's pretty obvious to someone looking at the * form, and I imagine we're going to do at least one more sweep through the specs for such considerations before we're done.

Thanks,

On 22/10/2010, at 11:46 PM, Julian Reschke wrote:

> The asterisk "*" ("asterisk form") means that the request does not apply to a particular resource, but to the server itself, and is only allowed when the method used does not necessarily apply to a resource. One example would be
> 
> OPTIONS * HTTP/1.1
> -- snip --
> 
> 
> This would become:
> -- snip --
> The asterisk "*" ("asterisk form") means that the request does not apply to a particular resource, but to the server itself. This is only allowed for the OPTIONS method. Thus, the only valid example is
> 
> OPTIONS * HTTP/1.1
> -- snip --
> 
> In P2, we *could* add it to the Considerations for new Methods. Do we need to?
> 
> Best regards, Julian
>

---

From: Julian Reschke <[email-masked]>
Date: Sat, 23 Oct 2010 10:02:27 +0200

> I think we can leave it out for now; it's pretty obvious to someone looking at the * form, and I imagine we're going to do at least one more sweep through the specs for such considerations before w…

-> <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1054>

Note that I also added

"State that the asterisk form is allowed for the OPTIONS method only."

to "Changes from RFC 2616".

Best regards, Julian