Subject: I-D Action:draft-ietf-httpbis-method-registrations-05.txt

From: [email-masked]
Date: Thu, 06 Jan 2011 10:45:01 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Hypertext Transfer Protocol Bis Working Group of the IETF.

	Title           : Initial Hypertext Transfer Protocol (HTTP) Method Registrations
	Author(s)       : J. Reschke
	Filename        : draft-ietf-httpbis-method-registrations-05.txt
	Pages           : 6
	Date            : 2011-01-06

This document registers those Hypertext Transfer Protocol (HTTP)
methods which have been defined in standards-track RFCs before the
IANA HTTP Method Registry was established.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-httpbis-method-registrations-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: mike amundsen <[email-masked]>
Date: Thu, 6 Jan 2011 14:06:12 -0500

I notice that Appendix A has a column for "Safe", but not
"Idempotent." Also, there is no reference in this table to
cache-ability of each of these methods.

All three of these qualities are mentioned in the spec [1]. I think it
would be valuable to see all these qualities in the I-D Appendix, too.

[1] http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-12#section-2.1.1

mca
http://amundsen.com/blog/
http://twitter.com@mamund
http://mamund.com/foaf.rdf#me

---

From: Julian Reschke <[email-masked]>
Date: Thu, 06 Jan 2011 21:26:48 +0100

> cache-ability of each of these methods.

That's mainly because we haven't decided on whether these are part of 
the IANA registration.

> would be valuable to see all these qualities in the I-D Appendix, too.

I'm not planning to update the definitions of these methods; what the 
spec says when it's published should be considered a guideline for new 
method registrations, or for revisions of the specs defining these methods.

Best regards, Julian

PS: the draft happened to be posted today because it was about to 
expire; that's all.