Subject: Resource states (initial and final)

From: Nathan <[email-masked]>
Date: Thu, 20 Jan 2011 12:34:11 +0000

Hi All,

I'm wondering how one could define the length of time a resource has 
been, or was, in existence.

I can see how a single client or intermediary could figure this out by 
auditing HTTP Messages (from 201 following POST or PUT through to a 
successful DELETE) - but I was looking for a way to indicate this to any 
client. This leads me to two questions:

1: Is there scope for a Created response header?

2: Can/could 410 Gone response include a Last-Modified header?

Cheers,

Nathan

---

From: Michael Hausenblas <[email-masked]>
Date: Thu, 20 Jan 2011 12:41:52 +0000

> been, or was, in existence.

Just a hunch, but wouldn't 'HTTP framework for time-based access to resource
states' [1] be a potential solution for this?

Cheers,
      Michael

[1] http://tools.ietf.org/html/draft-vandesompel-memento

-- 
Dr. Michael Hausenblas, Research Fellow
LiDRC - Linked Data Research Centre
DERI - Digital Enterprise Research Institute
NUIG - National University of Ireland, Galway
Ireland, Europe
Tel. +353 91 495730
http://linkeddata.deri.ie/
http://sw-app.org/about.html

> From: Nathan <[email-masked]>
> Organization: webr3
> Reply-To: Nathan <[email-masked]>
> Date: Thu, 20 Jan 2011 12:34:11 +0000
> To: HTTP Working Group <[email-masked]>
> Subject: Resource states (initial and final)
> Resent-From: <[email-masked]>
> Resent-Date: Thu, 20 Jan 2011 12:37:22 +0000
> 
> Hi All,
>