Subject: #268: Clarify "public"

From: Mark Nottingham <[email-masked]>
Date: Thu, 3 Feb 2011 16:40:59 +1100

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/268>

p6 section 3.2.2 says that "The public response directive indicates that the response MAY be cached, even if it would normally be non-cacheable or cacheable only within a non-shared cache."

This is somewhat open-ended; "normally" covers a lot.

Proposal: 

"""
The public response directive indicates that a response whose associated request contains an 'Authentication' header MAY be stored (see sections 2.2 and 2.6).
"""

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 21 Feb 2011 17:41:50 +1100

Incorporated in <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1129>.