Subject: DOSETA and MIMEAUTH

From: Dave CROCKER <[email-masked]>
Date: Sat, 26 Mar 2011 11:23:25 +0100

Folks,

Dobrý den!

I have gotten some queries about the possibility of applying DKIM to the task of 
validating web content, along the lines of:  draft-burke-content-signature.

In fact, I had already been pursuing specifications that are likely to satisfy 
your requirements.  The basic specification is called DOSETA and the tailored 
use of it is called MIMEAUTH.

DKIM itself has very specific semantics and is tied to email.  On the other 
hand, DKIM has some underlying technical components that do seem amenable to 
re-use for other application services, such as this one.

We've specified this as some generic protocol component, with an example use 
called MIMEAUTH that appears to provide the service you need.

I'll be summarizing the details at the Monday morning IETF AppsArea session.  A 
copy of the slides is attached.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 27 Mar 2011 10:23:12 +0200

Thanks, Dave. I can set aside some time in HTTPbis on Thursday for a HTTP-specific discussion as well, if you'd like

Regards,

On 26/03/2011, at 11:23 AM, Dave CROCKER wrote:

> Folks,
> 
> Dobrý den!
> 
> I have gotten some queries about the possibility of applying DKIM to the task of validating web content, along the lines of:  draft-burke-content-signature.
> 
> In fact, I had already been pursuing specifications that are likely to satisfy your requirements.  The basic specification is called DOSETA and the tailored use of it is called MIMEAUTH.
> 
> DKIM itself has very specific semantics and is tied to email.  On the other hand, DKIM has some underlying technical components that do seem amenable to re-use for other application services, such as this one.
> 
> We've specified this as some generic protocol component, with an example use called MIMEAUTH that appears to provide the service you need.
> 
> I'll be summarizing the details at the Monday morning IETF AppsArea session.  A copy of the slides is attached.
> 
> d/
> -- 
> 
>  Dave Crocker

--
Mark Nottingham   http://www.mnot.net/

---

From: Dave CROCKER <[email-masked]>
Date: Sun, 27 Mar 2011 11:02:40 +0200

> Thanks, Dave. I can set aside some time in HTTPbis on Thursday for a HTTP-specific discussion as well, if you'd like

sure.  thanks!

d/
-- 

   Dave Crocker