Subject: #273: HTTP-Version should be redefined as fixed length pair of DIGIT . DIGIT

From: Mark Nottingham <[email-masked]>
Date: Sun, 27 Mar 2011 10:26:18 +0200

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/273>

Any thoughts / objections to making this change?

--
Mark Nottingham   http://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Sun, 27 Mar 2011 10:34:44 +0200

> Any thoughts / objections to making this change?

I think it's a good idea. Too many implementations I've seen just
check for ver[7] == '1' or just memcmp(ver, "HTTP/1.1", 8). If
we ever decide to use 1.10 as a valid value, we'll get a lot of
trouble due to that.

Willy