Subject: Unclear example for private parameters on Accept headers

From: Karl Dubost <[email-masked]>
Date: Thu, 10 Mar 2011 08:47:01 -0500

Hi,

The prose on "section 6.1" about "Accept" [1] is confusing. There is an example to explain that the "Media ranges can be overridden by more specific media ranges or specific media types." The example is:

    If more than one media range applies to a given 
    type, the most specific reference has precedence.  
    For example,

        Accept: text/*, text/html, text/html;level=1, */*

The parameter "level" is being introduced without saying that it is a private parameter (aka not defined anywhere). It is confusing. The reader is suddenly looking for the definition of this parameter. I would add in the prose something along. 

    If more than one media range applies to a given 
    type, the most specific reference has precedence.  
    For example, with a private parameter "level", 

        Accept: text/*, text/html, text/html;level=1, */*

[1]: http://tools.ietf.org/html/draft-ietf-httpbis-p3-payload-12#section-6.1

-- 
Karl Dubost - http://dev.opera.com/
Developer Relations & Tools, Opera Software

---

From: Julian Reschke <[email-masked]>
Date: Thu, 10 Mar 2011 15:28:38 +0100

> [1]: http://tools.ietf.org/html/draft-ietf-httpbis-p3-payload-12#section-6.1

Agreed. Entered as <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/281>.

An alternative would be to use an example media type, instead of 
text/html...

BR, Julian