Subject: Re: API Rate Limits and HTTP Code [#255]

From: Karl Dubost <[email-masked]>
Date: Tue, 5 Apr 2011 14:58:25 -0400

Le 27 mars 2011 à 10:16, Mark Nottingham a écrit :
> I think it's a bit too detailed. How about just changing the first sentence to:
> 
> The server is currently unable or unwilling to handle the request due to a temporary overloading, maintenance of the server, or rate limiting of the client.

fine for me. 

-- 
Karl Dubost - http://dev.opera.com/
Developer Relations & Tools, Opera Software

---

From: Adrien de Croy <[email-masked]>
Date: Wed, 06 Apr 2011 09:35:27 +1200

Why not just say something like

"The server is currently unable or unwilling to handle the request."

Then give some explanatory text such as:

"The server may be prepared to handle the request if resubmitted after a 
delay.  This is intended to be used for conditions including:

* temporary overloading
* server maintenance
* client rate limiting
* any case where service is temporarily unavailable.
"

the point I'm trying to make is if we define too narrowly the reasons 
why the code should be used, it will just invite issues later on when 
people search for an appropriate code to use for their new application 
which we didn't think about. where really the code just means "not right 
now".

-- 
Adrien de Croy - WinGate Proxy Server - http://www.wingate.com

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 6 Apr 2011 08:10:06 +1000

OK. I think we're getting into wordsmithing here; I'll include this as editorial input and see where they take it.

Cheers,

On 06/04/2011, at 7:35 AM, Adrien de Croy wrote:

> "The server may be prepared to handle the request if resubmitted after a delay.  This is intended to be used for conditions including:
> 
> * temporary overloading
> * server maintenance
> * client rate limiting
> the point I'm trying to make is if we define too narrowly the reasons why the code should be used, it will just invite issues later on when people search for an appropriate code to use for their new application which we didn't think about. where really the code just means "not right now".
> 
> 
> 
> 
> 

--
Mark Nottingham   http://www.mnot.net/