Subject: #291: Cache Extensions can override no-store, etc.

From: Mark Nottingham <[email-masked]>
Date: Fri, 20 May 2011 12:59:06 +1000

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/291>

A simple way to deal with this is to add a note at the end of both 2.1 and 2.2 with a reference to the cache-control extensions section, e.g.,

"Note that any of the listed requirements above can be overridden by the presence of a cache-control extension; see [ref]."

However, this would have a few interesting side effects;

1) It would allow Cache-Control extensions to override the "core" cacheability requirements, e.g., matching the request-URI, status code cacheability.

2) It would potentially allow Cache-Control request extensions to override "hard" requirements (e.g., no-store, no-cache) from the server, if implemented.

Personally -- I don't see much harm (and perhaps some interesting use cases) in #1, at least for response cache-control.

I'm less sure about #2, but we've had a note in the spec that we don't specify how request and response CC interact for a while, so I'll just open that as a separate issue (#293).

Thoughts?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 May 2011 14:43:24 +1000

Incorporated in <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1291>.