Subject: Clarifying Pragma's introduction

From: Mark Nottingham <[email-masked]>
Date: Wed, 4 May 2011 20:27:15 +1000

<http://tools.ietf.org/html/draft-ietf-httpbis-p6-cache-14#section-3.4>

The intro for Pragma currently says:

   The "Pragma" header field is used to include
   implementation-specific directives that might apply to any recipient along
   the request/response chain. All pragma directives specify optional behavior
   from the viewpoint of the protocol; however, some systems &MAY; require
   that behavior be consistent with the directives.

Since adding new pragma directives is deprecated, this doesn't make much sense any more.

Any objection to rewriting the paragraph above as:

  The "Pragma" header field allows backwards compatibility with HTTP/1.0
  caches, so that clients can specify a "no-cache" request that they will understand
  (as Cache-Control was not defined until HTTP/1.1). 

  In HTTP/1.0, it was defined as an extensible field for implementation-specified directives
  for recipients. This specification deprecates such extensions to improve interoperability.

?

--
Mark Nottingham   http://www.mnot.net/

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 4 May 2011 16:15:18 -0700

>  for recipients. This specification deprecates such extensions to improve interoperability.

+1 if s/it/Pragma/;

....Roy