Subject: #283: Set expectations around buffering

From: Mark Nottingham <[email-masked]>
Date: Wed, 22 Jun 2011 11:35:45 +1000

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/283>

Proposal for a new section after 2.1 Client/Server? Messaging

2.2 Message Orientation and Buffering

Fundamentally, HTTP is a message-based protocol. Although message bodies can be chunked [ref to chunked encoding] and implementations often make parts of a message available progressively, this is not required, and some widely-used implementations only make a message available when it is complete. Furthermore, while most proxies will progressively stream messages, some amount of buffering will take place, and some proxies might buffer messages to perform transformations, check content or provide other services.

Therefore, extensions to and uses of HTTP cannot rely on the availability of a partial message, or assume that messages will not be buffered. There are strategies that can be used to test for buffering in a given connection, but it should be understood that behaviours can differ across connections, and between requests and responses.

... with a reference to the new section somewhere in 7.2. Message Transmission Requirements.

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 28 Jun 2011 15:09:19 +1000

I haven't heard any issues with this text, so I'm setting the milestone for -15.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 28 Jun 2011 14:50:34 +0200

On 2011-06-28 07:09, Mark Nottingham wrote:
 > ...

The text itself sounds good to me; proposed patch at 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/283/283.diff>.

 >>> ... with a reference to the new section somewhere in 7.2. Message 
Transmission Requirements.

Note of the subsections of 7.2 seems to be a good candidate for this...

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 29 Jun 2011 09:59:56 +1000

On 28/06/2011, at 10:50 PM, Julian Reschke wrote:

> The text itself sounds good to me; proposed patch at <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/283/283.diff>.
> 

Had another look, I tend to agree; not sure what I was thinking. Never mind, then.

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Wed, 29 Jun 2011 11:16:04 +0200

On 2011-06-29 01:59, Mark Nottingham wrote:
>> The text itself sounds good to me; proposed patch at<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/283/283.diff>.
>>

OK, done with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1316>.

Best regards, Julian