Subject: #308: need to reserve "negotiate" as auth scheme name

From: Julian Reschke <[email-masked]>
Date: Thu, 28 Jul 2011 16:34:13 +0200

Hi,

I've got a TODO to mark the authentication scheme name "negotiate" as 
reserved (in draft-ietf-httpbis-authscheme-registrations); see 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/308>.

Thoughts:

- the registry doesn't have a "status" entry; should we add that (with 
what values)?

- if we keep the registry simple, what's the reference we would put in? 
A pointer to a new appendix in 
draft-ietf-httpbis-authscheme-registrations, noting that "negotiate" is 
reserved as a scheme name, but it's not a valid scheme as per our 
requirements?

- that being said, should there be an erratum on RFC 4559 pointing out 
the problems?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 Jul 2011 08:16:16 -0700

On 28/07/2011, at 7:34 AM, Julian Reschke wrote:

> Hi,
> 
> I've got a TODO to mark the authentication scheme name "negotiate" as reserved (in draft-ietf-httpbis-authscheme-registrations); see <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/308>.
> 
> Thoughts:
> 
> - the registry doesn't have a "status" entry; should we add that (with what values)?

There's other discussion afoot about Web-related registries, if we wait a bit this should become apparent.

> - if we keep the registry simple, what's the reference we would put in? A pointer to a new appendix in draft-ietf-httpbis-authscheme-registrations, noting that "negotiate" is reserved as a scheme name, but it's not a valid scheme as per our requirements?

RFC4559 isn't adequate?

> - that being said, should there be an erratum on RFC 4559 pointing out the problems?

Yes.

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 29 Jul 2011 13:43:54 -0700

I'm changing this ticket to editorial.