Subject: Content-Range on responses other than 206

From: Mark Nottingham <[email-masked]>
Date: Fri, 15 Jul 2011 23:19:21 +1000

Anyone object to stating that Content-Range has no meaning on responses that aren't 206's? 

Right now we don't say that, and it causes problems; see
  http://gnats.netbsd.org/cgi-bin/query-pr-single.pl?number=45116

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Fri, 15 Jul 2011 15:37:30 +0200

>   http://gnats.netbsd.org/cgi-bin/query-pr-single.pl?number=45116

I agree that such issues could be avoided by a minor clarification.

Willy

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 17 Jul 2011 10:39:01 +1000

Now <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/301>.

Unless someone speaks against this soon, I'll assign for -16.

---

From: Yves Lafon <[email-masked]>
Date: Mon, 25 Jul 2011 22:38:49 -0400 (EDT)

>  http://gnats.netbsd.org/cgi-bin/query-pr-single.pl?number=45116

The issue here is the presense of a Content-Range header that identifies 
the whole representation, if the Content-Range header was identifying a 
sub-part it would be even more problematic, as the MUST-level requirement 
on C-R matching the payload bytes is in the definition of 206.

Proposal:
In Part5, section 5.2:

Old:
<<
The "Content-Range" header field is sent with a partial
representation to specify where in the full representation the
payload body is intended to be applied.

New:
<<
The "Content-Range" header field is sent with a partial
representation to specify where in the full representation the
payload body is intended to be applied.

It MUST be ignored when present in responses with other response code than 
206 Partial Content [3.1].

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Jul 2011 15:47:01 -0400

On 25/07/2011, at 10:38 PM, Yves Lafon wrote:

> It MUST be ignored when present in responses with other response code than 206 Partial Content [3.1].

This might be a bit too strong; I prefer saying that it doesn't have any meaning on other messages by default, so that if someone wants to specify a new status code where it does make sense, they can do so without revising HTTP (not that this is terribly likely, I know).

---

From: Julian Reschke <[email-masked]>
Date: Wed, 27 Jul 2011 16:17:14 +0200

> This might be a bit too strong; I prefer saying that it doesn't have any meaning on other messages by default, so that if someone wants to specify a new status code where it does make sense, they c…

Sounds good.