Subject: Re: #295: Applying original fragment to "plain" redirected URI (also #43)

From: Julian Reschke <[email-masked]>
Date: Fri, 01 Jul 2011 19:36:31 +0200

On 2011-05-28 03:07, Mark Nottingham wrote:
> Thanks, Eric -- that's very helpful.
>
> Speaking just about #295 for the moment, does anyone have a concern about defining the behaviour as in draft-bos-http-redirect?
> ...

My concern is similar to what was brought up in the context of issue 43 
-- it's not entirely clear whether HTTPbis has any business in defining 
this (that is; is this an aspect of media types or of redirects?).

I don't think we ever came to a conclusion about this in the context of 
#43, as, in the end, we didn't define the behavior.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 2 Jul 2011 17:04:30 +1000

On 02/07/2011, at 3:36 AM, Julian Reschke wrote:

> My concern is similar to what was brought up in the context of issue 43 -- it's not entirely clear whether HTTPbis has any business in defining this (that is; is this an aspect of media types or of redirects?).
> 
> I don't think we ever came to a conclusion about this in the context of #43, as, in the end, we didn't define the behavior.

My recollection was that we didn't have interop in browsers, and we didn't have an indication of a strong desire from them one way or the other. I'd say we have both now.

Perhaps we should ping the TAG to get their thoughts? Absent strong objection, it seems like we can have an easy interop win here.

--
Mark Nottingham   http://www.mnot.net/