Subject: The use of HTTP 501

From: Matthew Seaborn <[email-masked]>
Date: Fri, 26 Aug 2011 07:34:32 +0000

The RFC has the following specification for 501: "The server does not support the functionality required to fulfil the request. This is the appropriate response when the server does not recognize the request method and is not capable of supporting it for any resource."

However the recent specification for API for Media Resources 1.0 ( http://www.w3.org/TR/2011/WD-mediaont-api-1.0-20110712/#api-status-codes )  uses it in the case when "only a subset of GET methods for properties implemented".

What is the modern accepted usage of this response code?  Will the use specified in Media Resources spec confuse any clients if they return a 501 for some GET requests but not others?

---

From: Julian Reschke <[email-masked]>
Date: Fri, 26 Aug 2011 09:47:20 +0200

On 2011-08-26 09:34, Matthew Seaborn wrote:
> The RFC has the following specification for 501: “The server does not
> support the functionality required to fulfil the request. This is the
> appropriate response when the server does not recognize the request
> method and is not capable of supporting it for any resource.”
>
> However the recent specification for API for Media Resources 1.0 (
> http://www.w3.org/TR/2011/WD-mediaont-api-1.0-20110712/#api-status-codes) uses
> it in the case when*“*only a subset of GET methods for properties
> implemented*”. *
>
> **
>
> What is the modern accepted usage of this response code? Will the use
> specified in Media Resources spec confuse any clients if they return a
> 501 for some GET requests but not others?
> ...

Potentially. I consider this a bug in WD-mediaont-api.

Best regards, Julian