Subject: Status code for enforcing conditional requests

From: Jan Algermissen <[email-masked]>
Date: Tue, 27 Sep 2011 00:36:38 +0200

Is HTTPbis going to say anything about what response code to use when an unconditional PUT/POST/DELETE request is made but the server requires conditional requests and would like to inform the client about it?

I am asking because it keeps popping up occasionally and I frankly don't know the answer.

Julian suggested 403 some time ago (28-8-2009) but I think the spec is too credentials-focussed in this regard.

Jan

---

From: Jan Algermissen <[email-masked]>
Date: Tue, 27 Sep 2011 07:25:01 +0200

On Sep 27, 2011, at 12:36 AM, Jan Algermissen wrote:

> 
> Julian suggested 403 some time ago (28-8-2009)

Sorry, forgot to mention the list for that date: http://tech.groups.yahoo.com/group/rest-discuss/

Jan

> but I think the spec is too credentials-focussed in this regard.
> 
> Jan