Subject: #312: should there be a permanent variant of 307?

From: Julian Reschke <[email-masked]>
Date: Thu, 27 Oct 2011 22:50:12 +0200

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/312>

So now that we have allowed UAs to rewrite a 301 POST to GET (see 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/160>), the spec 
doesn't have a permanent redirect that always preserves the method.

(We *do* have the equivalent for temporary redirects: 307).

So...:

1) Is this a problem?

2) If yes, how can we fix it?

2a) Define a new code (in a separate spec)?

2b) Explain that a 307 can be made permanent by adding Cache-Control magic.

My 17 cents:

2a) This might be hard to deploy, but maybe that's not a problem for 
those applications that want to use it. If we do that, it needs a 
separate spec (or it could go into Mark's new-status-codes thingy).

2b) This probably could be smuggled into HTTPbis, but in this case I'd 
*really* like to see us adding a concrete example.

Best regards, Julian

---

From: Yves Lafon <[email-masked]>
Date: Fri, 28 Oct 2011 11:35:24 -0400 (EDT)

On Thu, 27 Oct 2011, Julian Reschke wrote:

> <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/160>), the spec doesn't 
> have a permanent redirect that always preserves the method.
>

First thing is... was 301 ever used to change entries in a bookmark or a 
link in a page? If not, then it's not a problem worth adding a new status 
code. A 307 with a long enough cache time should be enough to redirect 
people.
If it is, then 2a would be the best option (in another doc)

> 2a) This might be hard to deploy, but maybe that's not a problem for those 
> applications that want to use it. If we do that, it needs a separate spec (or 
> it could go into Mark's new-status-codes thingy).
>

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 29 Oct 2011 10:12:42 +1100

On 29/10/2011, at 2:35 AM, Yves Lafon wrote:

>> So now that we have allowed UAs to rewrite a 301 POST to GET (see <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/160>), the spec doesn't have a permanent redirect that always preserves the method.
>> 
> First thing is... was 301 ever used to change entries in a bookmark or a link in a page? If not, then it's not a problem worth adding a new status code.

+1

> A 307 with a long enough cache time should be enough to redirect people.

But then you have a deployment problem; it won't be backwards-compatible with most existing browsers (i.e., the redirect won't work), so it'll never get out there.

AFAICT the only way to deploy would be to mint a new CC directive that means "forever" -- and we've already discussed that and decided not to go that way, IIRC.

My personal .02 - I think this is close with no action, or at most a bit of prose in 307.

Cheers,

>> 2a) This might be hard to deploy, but maybe that's not a problem for those applications that want to use it. If we do that, it needs a separate spec (or it could go into Mark's new-status-codes thingy).
>> 
>> 2b) This probably could be smuggled into HTTPbis, but in this case I'd *really* like to see us adding a concrete example.
>> 
>> Best regards, Julian
>> 
>> 
> 
> -- 

Mark Nottingham
http://www.mnot.net/

---

From: Mark Baker <[email-masked]>
Date: Fri, 28 Oct 2011 21:29:52 -0400

On Fri, Oct 28, 2011 at 11:35 AM, Yves Lafon <[email-masked]> wrote:
> link in a page?

It's been discussed for ages, but I'm not aware of any user agent which does it.

e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=8648

Mark.

---

From: Adrien de Croy <[email-masked]>
Date: Sat, 29 Oct 2011 17:12:31 +1300

I've seen chrome behave differently for 301 than 302, e.g. not even do 
the original request, but straight to the previously diverted one.  E.g. 
a permanent redirect.

On 29/10/2011 2:29 p.m., Mark Baker wrote:
> On Fri, Oct 28, 2011 at 11:35 AM, Yves Lafon<[email-masked]>  wrote:

-- 
Adrien de Croy - WinGate Proxy Server - http://www.wingate.com