Subject: Fwd: I-D Action: draft-nottingham-http-new-status-02.txt

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 Oct 2011 10:57:11 +1100

FYI. Some adjustment of the status codes in -01, and one new one (thanks to Jan for the idea).

Begin forwarded message:

> From: [email-masked]
> Subject: I-D Action: draft-nottingham-http-new-status-02.txt
> Date: 19 October 2011 10:40:05 AM AEDT
> To: [email-masked]
> Reply-To: [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Additional HTTP Status Codes
> 	Author(s)       : Mark Nottingham
>                          Roy T. Fielding
> 	Filename        : draft-nottingham-http-new-status-02.txt
> 	Pages           : 9
> 	Date            : 2011-10-18
> 
>   This document specifies additional HyperText Transfer Protocol (HTTP)
>   status codes for a variety of common situations.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-http-new-status-02.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-nottingham-http-new-status-02.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

--
Mark Nottingham   http://www.mnot.net/

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Wed, 19 Oct 2011 12:06:30 +0300

Hello Mark,

Have you considered incorporating any of my proposals
(http://lists.w3.org/Archives/Public/ietf-http-wg/2011JulSep/0359.html
and folow-ups)?

Moreover, will you ask APPSAWG to adopt the draft as WG item on this
meeting (I personally am in favor of such action)?

Mykyta Yevstifeyev

2011/10/19, Mark Nottingham <[email-masked]>:
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 Oct 2011 20:26:56 +1100

Personally - I don't see a real use case for 444 (it doesn't add any information over just closing the connection), and don't think 509 is a good thing to standardise. YMMV, of course.

Yes, the APPSAWG is the next port of call.

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Sat, 22 Oct 2011 09:53:43 +0200

On 2011-10-19 01:57, Mark Nottingham wrote:
> ...

Looks good. Let's finish this.

One concern, one nit:

- it's suboptimal that we have an example of a Refresh header field with 
no spec for it (that could be worked around by making it a META tag in 
the response body)

- in appendix B, s/network filesystem access/remote authoring/.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 23 Oct 2011 15:44:49 +1100

Thanks; updated on github.

On 22/10/2011, at 6:53 PM, Julian Reschke wrote:

> - it's suboptimal that we have an example of a Refresh header field with no spec for it (that could be worked around by making it a META tag in the response body)
>