Subject: Re: #300: Define non-final responses

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Oct 2011 18:41:50 +0200

On 2011-07-18 08:05, Mark Nottingham wrote:
> I think we're hitting diminishing returns here, and possibly approaching the angels dancing on the pins.
>
> If someone has a proposal for a text change that they think will represent consensus, great.
>
> In the meantime, I don't see any pushback on the proposed resolution, as it affects p1.
> ...

So what is the proposed resolution?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 26 Oct 2011 10:52:33 +1100

The original e-mail said:

> 1xx responses are non-final; i.e., the underlying model is that for each request, there are 0 to many non-final responses, and exactly one final response.
> 
> This should be made explicit at a high level; it's implied by the definition of 1xx, but never really spelled out anywhere.

... so it needs some text, probably somewhere in or around p1 2.1 "Client/Server Messaging".

Do you want to take a stab at it, or would you like a textual proposal?

--
Mark Nottingham   http://www.mnot.net/