Subject: Cache-Control directive case sensitivity

From: Mark Nottingham <[email-masked]>
Date: Mon, 17 Oct 2011 22:11:32 +1100

Currently, all of the cache-control directives (e.g., max-age) are defined as BNF strings, which means that they're case-insensitive.

However, theoretically someone could define a directive without using a string (as we do for some other constructs, e.g., the HTTP version identifier), which means that it'd be case-sensitive.

It seems that having such exceptions would be surprising, and that the most straightforward thing to do would be to define CC directive names as case-insensitive.

Any thoughts? A quick check of squid2 shows it case-normalising them before comparison.

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 17 Oct 2011 13:15:41 +0200

> Any thoughts? A quick check of squid2 shows it case-normalising them before comparison.

+1, and we probably should mention that as part of #231 for parameter names.

Best regards, Julian

---

From: Sam Johnston <[email-masked]>
Date: Mon, 17 Oct 2011 13:15:58 +0200

SGTM.

On Mon, Oct 17, 2011 at 1:11 PM, Mark Nottingham <[email-masked]> wrote:

> Currently, all of the cache-control directives (e.g., max-age) are defined
> as BNF strings, which means that they're case-insensitive.
>
> However, theoretically someone could define a directive without using a
> string (as we do for some other constructs, e.g., the HTTP version
> identifier), which means that it'd be case-sensitive.
>
> It seems that having such exceptions would be surprising, and that the most
> straightforward thing to do would be to define CC directive names as
> case-insensitive.
>

---

From: David Morris <[email-masked]>
Date: Mon, 17 Oct 2011 08:44:33 -0700 (PDT)

> +1, and we probably should mention that as part of #231 for parameter names.

++1 ... I prefer to avoid case sensitivity whenever possible in computer
handled data.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Oct 2011 09:59:28 +1100

Logged as:
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/317

Incorporated in:
  http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1449

---

From: Yves Lafon <[email-masked]>
Date: Thu, 27 Oct 2011 13:11:07 -0400 (EDT)

On Tue, 18 Oct 2011, Mark Nottingham wrote:

As a followup, the same clarification has been added for rules based on 
token or string (range-unit and acceptable-ranges).

ticket at
http://trac.tools.ietf.org/wg/httpbis/trac/ticket/319
changeset at
http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1456

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves