Subject: Re: #300: Define non-final responses

From: Julian Reschke <[email-masked]>
Date: Fri, 04 Nov 2011 10:50:10 +0100

On 2011-10-26 01:52, Mark Nottingham wrote:
>
> On 25/10/2011, at 3:41 AM, Julian Reschke wrote:
>
>> On 2011-07-18 08:05, Mark Nottingham wrote:
>>> I think we're hitting diminishing returns here, and possibly approaching the angels dancing on the pins.
>>>
>>> If someone has a proposal for a text change that they think will represent consensus, great.
>>>
>>> In the meantime, I don't see any pushback on the proposed resolution, as it affects p1.
>>> ...
>>
>> So what is the proposed resolution?
>
> The original e-mail said:
>
>> 1xx responses are non-final; i.e., the underlying model is that for each request, there are 0 to many non-final responses, and exactly one final response.
>>
>> This should be made explicit at a high level; it's implied by the definition of 1xx, but never really spelled out anywhere.
>
>
> ... so it needs some text, probably somewhere in or around p1 2.1 "Client/Server Messaging".
>
> Do you want to take a stab at it, or would you like a textual proposal?
> ...

Mark made a proposal in 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/300#comment:6>. I 
rephrased it minimally, and the new paragraph would then read:

    Note that 1xx responses (Section 7.1 of [Part2]) are not final;
    therefore, a server can send zero or more 1xx responses, followed by
    exactly one final response (with any other status code).

(see 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/300/300.diff>).

Feedback appreciated, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 5 Nov 2011 12:08:01 +1100

WFM. 

On 04/11/2011, at 8:50 PM, Julian Reschke wrote:

> Mark made a proposal in <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/300#comment:6>. I rephrased it minimally, and the new paragraph would then read:
> 
> (see <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/300/300.diff>).
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Sat, 05 Nov 2011 10:54:58 +0100

> WFM.

Applied with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1471>.

Best regards, Julian