Subject: Re: #306: does etag value really use quoted-string

From: Mark Nottingham <[email-masked]>
Date: Wed, 2 Nov 2011 17:22:33 +1100

On 29/10/2011, at 8:55 PM, Julian Reschke wrote:

> On 2011-10-24 20:13, Julian Reschke wrote:
>> ...
> 
> Trying to summarize where we are:
> 
> 1) Yves did dome tests on servers: <http://lists.w3.org/Archives/Public/ietf-http-wg/2011JulSep/0266.html> -> the servers being tested didn't seem to unescape
> 
> 2) Amos Jeffries reports that recent Squids actually *do* handle them as quoted-strings: <http://lists.w3.org/Archives/Public/ietf-http-wg/2011JulSep/0470.html>
> 
> 3) I tested various browsers, and they do not unescape: <http://lists.w3.org/Archives/Public/ietf-http-wg/2011OctDec/0087.html>
> 
> So what do we do?
> 
> Claiming that etags use quoted-strings when almost nobody does seems to be a bad thing. For instance, apparently it has caused the Squid developers to make a change that in the best case is harmless, and in the worst case will break things.

I'm +1 on your proposal <http://www.w3.org/mid/[email-masked]>. 

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 02 Nov 2011 13:35:38 +0100

On 2011-11-02 07:22, Mark Nottingham wrote:
>> 1) Yves did dome tests on servers:<http://lists.w3.org/Archives/Public/ietf-http-wg/2011JulSep/0266.html>  ->  the servers being tested didn't seem to unescape
>>
>> 2) Amos Jeffries reports that recent Squids actually *do* handle them as quoted-strings:<http://lists.w3.org/Archives/Public/ietf-http-wg/2011JulSep/0470.html>
>>
>> 3) I tested various browsers, and they do not unescape:<http://lists.w3.org/Archives/Public/ietf-http-wg/2011OctDec/0087.html>
>>
>> So what do we do?
>>
> I'm +1 on your proposal<http://www.w3.org/mid/[email-masked]>.
> ...

OK, applied with 
<http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1470>.

Best regards, Julian