Subject: Fwd: Re: Restoring PUT and DELETE

From: Julian Reschke <[email-masked]>
Date: Thu, 01 Dec 2011 13:09:58 +0100

FYI -- see attached chart about browser behavior vs status codes...

-------- Original Message --------
Subject: 	Re: Restoring PUT and DELETE
Date: 	Thu, 1 Dec 2011 11:03:37 +0000
From: 	Cameron Heavon-Jones <[email-masked]>
To: 	mike amundsen <[email-masked]>
CC: 	Julian Reschke <[email-masked]>, Yehuda Katz
<[email-masked]>, HTML WG <[email-masked]>

Hi Yehuda\Mike\Juilan,

Its good to get back to this issue, hope it keeps the traction this time :)

Without going into too much detail yet, there were two points from the
last discussions to be highlighted at this point.

The first is with regards to browser handling of responses. I did some
thorough testing of the current state of play of browser behaviour in
this area and found that browsers are on the whole up to spec with their
behaviour and that the default for content responses is to render
whatever payload is returned. I have a matrix of these responses which
can be added to any docs [attached].

While performing the browser tests however, i started to doubt the
necessity of such tests - perhaps this is a more methodological
question, but is the html specification the place for defining http
behaviour?

The other issue is that specifications for PUT and DELETE are not too
held back with conformance for current server implementations. As new
functionality to html and hence requiring to be explicitly added by
authors there should not be any backward compatibility to break.

MIke, look forward to the updated docs.

Thanks,
Cameron Jones

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 2 Dec 2011 07:55:16 +1100

Was he testing how browsers handled the indicated code in response to a GET here?

If so, what do the 3xx results he shows mean? Without the methodology, this raises more questions than it answers.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: mike amundsen <[email-masked]>
Date: Thu, 1 Dec 2011 15:58:55 -0500

from the top of Cameron's doc:
"All tests performed using form POST to request test response"

mca
http://amundsen.com/blog/
http://twitter.com@mamund
http://mamund.com/foaf.rdf#me

On Thu, Dec 1, 2011 at 15:55, Mark Nottingham <[email-masked]> wrote:

> If so, what do the 3xx results he shows mean? Without the methodology,
> this raises more questions than it answers.
>
> Cheers,
>
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 01 Dec 2011 21:59:26 +0100

> If so, what do the 3xx results he shows mean? Without the methodology, this raises more questions than it answers.

It's all from a HTML form POST, AFAIU.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 2 Dec 2011 08:03:59 +1100

Ah, OK, missed that. Thanks. Still would be nice to have more details.

---

From: Cameron Heavon-Jones <[email-masked]>
Date: Fri, 2 Dec 2011 13:53:44 +0000

> Ah, OK, missed that. Thanks. Still would be nice to have more details.

i performed the tests manually using a html form which captured a status code to return and whether to include a payload or not. this was sent to a simple web server with POST and the server setup to create a response with the relevant status and content. the behaviour was observed and recored in the browser and using available debug tools.

i used http POST to try and gather the behaviour which may be seen with the addition of new methods, testing over GET seemed a bit irrespective as it's only the browser's handling of retrieving a URL.

the 3xx results are the most interesting as this is the area where there is the most room for interpretation on what an agent should do for the user. 

i'm updating it with as new status code tests and will split the table out, let me know if i can provide any more details.

thanks,
cam

---

From: mike amundsen <[email-masked]>
Date: Fri, 2 Dec 2011 08:57:56 -0500

Cameron:

once you complete the changes, send me a link and i'll replace that local
file i am using now to your  link. that way any future changes will be
automatically reflected from my page.

mca

On Fri, Dec 2, 2011 at 08:53, Cameron Heavon-Jones <[email-masked]>wrote:

> i performed the tests manually using a html form which captured a status
> code to return and whether to include a payload or not. this was sent to a
> simple web server with POST and the server setup to create a response with
> the relevant status and content. the behaviour was observed and recored in
> the browser and using available debug tools.
>
> i used http POST to try and gather the behaviour which may be seen with
> the addition of new methods, testing over GET seemed a bit irrespective as
> it's only the browser's handling of retrieving a URL.
>
> the 3xx results are the most interesting as this is the area where there
> is the most room for interpretation on what an agent should do for the user.
>
> i'm updating it with as new status code tests and will split the table
> out, let me know if i can provide any more details.
>
> thanks,
> cam
>
> >

---

From: Cameron Heavon-Jones <[email-masked]>
Date: Wed, 7 Dec 2011 15:38:53 +0000

I've updated the browser tests for default handling of new status codes and some updated behaviour added to chrome since i last performed the tests. the results are split into two tables based on if a content payload is provided in the response. i've also condensed the tables so that only deviations from the default handling are recorded.

http://www.cmhjones.com/browser-http-test-matrix.html

thanks,
cameron

On 02/12/2011, at 1:57 PM, mike amundsen wrote:

> Cameron:
> 
> once you complete the changes, send me a link and i'll replace that local file i am using now to your  link. that way any future changes will be automatically reflected from my page.
> 
> mca
> On Fri, Dec 2, 2011 at 08:53, Cameron Heavon-Jones <[email-masked]> wrote:
>

---

From: mike amundsen <[email-masked]>
Date: Wed, 07 Dec 2011 09:08:32 -0800 (PST)

thanks.

i'll update the link on my web page.

mca

On Wed, Dec 7, 2011 at 10:38, Cameron Heavon-Jones <[email-masked]>wrote:

> I've updated the browser tests for default handling of new status codes 
> and some updated behaviour added to chrome since i last performed the 
> tests. the results are split into two tables based on if a content payload 
> is provided in the response. i've also condensed the tables so that only 
> deviations from the default handling are recorded.
>
>> >>> If so, what do the 3xx results he shows mean? Without the 
>> methodology, this raises more questions than it answers.
>> >>>
>> >>> Cheers,
>> >>