Subject: #185: Location header payload handling

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Dec 2011 21:47:09 +1100

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/185>

We've already agreed to allow relative URIs in the Location header.

The remainder of this ticket -- handling invalid input -- has been on hold, while we waited for the IRI WG to come up with a spec.

AIUI that work now looks like it'll be going to the W3C, and may take some time. Given that, I propose we mention that some implementations might do error handling / processing on the Location payload, and leave it at that; if a spec does pop up before we finish, we can revisit.

Thoughts?

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 15 Dec 2011 12:01:26 +1100

Proposal:

In p2 Section 9.5, add a paragraph after the examples (before "There are circumstances..."):

"""
Some recipients attempt to recover from Location fields that are not valid URI references. This specification does not mandate or define such processing, but does allow it (see Section 1.1).
"""

---

From: Julian Reschke <[email-masked]>
Date: Fri, 16 Dec 2011 22:28:57 +0100

On 2011-12-15 02:01, Mark Nottingham wrote:
> ...

Works for me.

Proposed patch: 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/185/185.diff>

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 20 Dec 2011 11:41:12 +0100

On 2011-12-16 22:28, Julian Reschke wrote:
>> Some recipients attempt to recover from Location fields that are not
>> valid URI references. This specification does not mandate or define
>> such processing, but does allow it (see Section 1.1).
>> """
>> ...
>
> Works for me.
>
> Proposed patch:

Applied with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1496>.