Subject: Re: status code for header fields to big

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 02 Dec 2011 14:36:13 -0700

I notice that 413 didn't end up in draft-nottingham-http-new-status
(although it does have "431 Request Header Fields Too Large"). Where did
we end up on this one?

On 6/30/11 9:52 PM, Mark Nottingham wrote:
> Personally - I think 413 is good for this; the response body and/or headers can fine-tune as to why it was rejected (as with any other error response).
> 
> Recall that we've already tuned the definition of 413 to say 
> 
>    The server is refusing to process a request because the request
>    representation is larger than the server is willing or able to
>    process.
> 
> note 'representation' -- which includes headers.
> 
> Cheers,
> 
> 
> On 30/06/2011, at 10:46 PM, Julian Reschke wrote:
> 
>> Hi,
>>
>> I quickly ran some tests, and the results are (with what I suppose are the default settings):
>>
>> Apache-Coyote/1.1 (Tomcat):
>>
>> Limit for a single header field: ~8000
>> Limit for all fields: ~8000
>> Status Code: 400
>>
>> Apache/2.2.14:
>>
>> Limit for a single header field: ~8180
>> Limit for all fields: > 16000
>> Status Code: 400
>>
>> microsoft.com:
>>
>> Limit for a single header field: ~16000
>> Limit for all fields: ~16000
>> Status Code: 400
>>
>> google.com:
>>
>> Limit for a single header field: ~15400
>> Limit for all fields: > 15400
>> Status Code: 400 (413 for the larger values)
>>
>>
>> So 413 doesn't seem to be used in general for this case.
>>
>> Should it? In that case we should clarify the spec...
>>
>>
>>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 02 Dec 2011 23:06:46 +0100

> I notice that 413 didn't end up in draft-nottingham-http-new-status

413 already exists ("Request Entity Too Large"); we thought about 
extending it to cover this case (and did with 
http://trac.tools.ietf.org/wg/httpbis/trac/ticket/255) but then decided 
that a new code makes more sense. (So the change for ticket #255 will be 
backed out once we know 431 goes ahead).

Any while I type this I see you updated the ticket :-)

> ...

The definition of 413 will be reverted back to what it said before 
change <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1310>.

Best regards, Julian

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 02 Dec 2011 15:08:41 -0700

> change <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1310>.

Thanks for the clarifications.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 02 Dec 2011 23:21:03 +0100

> change <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1310>.

Sorry, me confused about two different headers.

We did not change 413, as 431 was on the table.

We *did* extend 503, and this can be backed out if we get 429.

Best regards, Julian

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 02 Dec 2011 15:26:41 -0700

> We *did* extend 503, and this can be backed out if we get 429.

You'll get it. I plan to start the IETF Last Call in the next few days.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Julian Reschke <[email-masked]>
Date: Sat, 03 Dec 2011 10:08:02 +0100

> We *did* extend 503, and this can be backed out if we get 429.

Proposed change: 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/255/255.diff>

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 5 Dec 2011 12:02:36 +1100

Can we leave the reference to the retry-after header def (line 2282)?

Cheers,

On 03/12/2011, at 8:08 PM, Julian Reschke wrote:

> Proposed change: <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/255/255.diff>

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 05 Dec 2011 10:50:33 +0100

> Can we leave the reference to the retry-after header def (line 2282)?

Done. See <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1486>.

Best regards, Julian