Subject: #346: Registry policies

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Mar 2012 13:27:49 +0200

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/346>

At yesterday's meeting, there was some pushback on defining our registry policies as IETF Review for "consistency."

Given that there is a larger discussion about registry policy definition taking place, and I *think* we've agreed that we shouldn't block HTTPbis on that discussion (since it's likely to take some time), it seems that we should take the attitude of installing (relatively) temporary registration policies; i.e., we should make them reasonable, but not try to solve all of the problems we perceive with them, in the belief / hope that a more general effort will help later.

In #346, we changed the following registries to "IETF Review":

* Upgrade Tokens (previously First Come First Served)
* Transfer-Codings (previously Specification Required)
* Content-Codings (previously Specification Required)

I'm re-opening this ticket based upon discussion in the meeting yesterday. 

My take - 

I believe we should leave Transfer-Codings and Content-Codings as IETF Review, because otherwise we will need to establish expert review procedures and guidelines for them, as well as identify experts. These are very low-throughput registries, and will benefit from IETF review (as there's a cost to adding new schemes to negotiation).

I think we should discuss Upgrade Tokens; first-come-first-served may make sense here. However, I'd note it'd be a shame if we spent too much time on it. 

Thoughts?

--
Mark Nottingham
http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Mar 2012 13:33:54 +0200

On 2012-03-28 13:27, Mark Nottingham wrote:
> ...
> ...

+1

Let's not waste time on a discussing a registry which has only been used 
twice in 12 years.

Best regards, Julian

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 28 Mar 2012 14:14:44 +0200

> I believe we should leave Transfer-Codings and Content-Codings as IETF Review, because otherwise we will need to establish expert review procedures and guidelines for them, as well as identify expe…

Why do we care?  FCFS is fine provided that reservations for deployed names
can be overtaken by the controllers of those names.  What I'd like to see in
a registry is a status section that is subject to expert review, so that I
can mark registered names as "standard" / "experiment" / "deprecated" / "idiotic".

> I think we should discuss Upgrade Tokens; first-come-first-served may make sense here. However, I'd note it'd be a shame if we spent too much time on it.

FCFS is fine provided that reservations for deployed names can be overtaken
by the controllers of those names.

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Mar 2012 17:15:28 +0200

> can mark registered names as "standard" / "experiment" / "deprecated" / "idiotic".

RIght; I want to get there too, but I don't think we should block on figuring that out. See other message.

--
Mark Nottingham
http://www.mnot.net/