Subject: httpbis -19 drafts

From: Julian Reschke <[email-masked]>
Date: Tue, 13 Mar 2012 07:53:37 +0100

Hi there,

we just published the -19 drafts of Part 1 through 7 which reflect the
progress we made since early January.

Overviews are in the appendices:

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p1-messaging-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p3-payload-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p4-conditional-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p5-range-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p6-cache-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p7-auth-19.html#changes.since.18>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-method-registrations-07.html#changes.since.06> 
(no changes)

Diffs:

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p1-messaging/draft-ietf-httpbis-p1-messaging-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p2-semantics/draft-ietf-httpbis-p2-semantics-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p3-payload/draft-ietf-httpbis-p3-payload-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p4-conditional/draft-ietf-httpbis-p4-conditional-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p5-range/draft-ietf-httpbis-p5-range-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p6-cache/draft-ietf-httpbis-p6-cache-19-from-18.diff.html>

<http://tools.ietf.org/wg/httpbis/draft-ietf-httpbis-p7-auth/draft-ietf-httpbis-p7-auth-19-from-18.diff.html>

Note that the HTML versions:

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p1-messaging.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p2-semantics.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p3-payload.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p4-conditional.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p5-range.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p6-cache.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p7-auth.html

come with feedback links that should make it really simple to provide 
quick comments.

Mark Nottingham, our WG chair, will follow up with a list of tickets
we'd like to close as fixed soonish.

Feedback appreciated, Julian

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 13 Mar 2012 08:20:50 +0100

Hi Julian,

> <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p1-messaging-19.html#changes.since.18>

Just noticed this after a quick glance over the diff :

3.1.1. Request Line
  A server that receives a method longer than any that it implements
  SHOULD respond with either a 404 (Not Allowed),

=> "Not Allowed" is 405, not 404.

Regards,
Willy

---

From: Amos Jeffries <[email-masked]>
Date: Tue, 13 Mar 2012 23:02:04 +1300

> => "Not Allowed" is 405, not 404.

Sort of in line with this.

Maybe I missed it but is there any limit to the length of request 
methods?

AYJ

---

From: Julian Reschke <[email-masked]>
Date: Tue, 13 Mar 2012 17:11:02 +0100

On 2012-03-13 08:20, Willy Tarreau wrote:
> ...

Indeed, thanks (fixed).

---

From: Zhong Yu <[email-masked]>
Date: Tue, 13 Mar 2012 23:42:12 -0500

I don't see anything wrong if the spec sets a max length for method
token. 64 bytes ought to be enough for anybody.

If the method token does not terminate before server's limit is
reached, the integrity of the request is extremely suspicious, I think
a generic 400 is probably more suitable than 405/501.

Zhong Yu

On Tue, Mar 13, 2012 at 5:02 AM, Amos Jeffries <[email-masked]> wrote:
> Maybe I missed it but is there any limit to the length of request methods?
>
> AYJ
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 14 Mar 2012 07:49:49 +0100

> Maybe I missed it but is there any limit to the length of request methods?

No. We also don't have limits for the length of the header field names.

Why is that a problem?

Best regards, Julian