Subject: draft-kucherawy-httpbis-summary

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 27 Mar 2012 23:01:41 +0000

As promised in today's meeting.  Let me know what needs changing, expanding, rearranging, etc.

http://datatracker.ietf.org/doc/draft-kucherawy-httpbis-summary/

-MSK

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Mar 2012 01:24:57 +0200

On 3/28/12 1:01 AM, Murray S. Kucherawy wrote:
> As promised in today’s meeting.  Let me know what needs changing,
> expanding, rearranging, etc.
> 

Wow, that was fast. Thanks, Murray!

I'd include a sentence requesting that those wanting to reference
"HTTP/1.1" do so by pointing to this document alone, not the entire
series. In which case this document probably needs to be standards track.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Mar 2012 05:15:29 +0200

Awesome.

I find the fact that the document is documented by lists entitled
"IANA Actions include" (capitalization?) to be a little strange, but
also surprisingly useful.  Being able to see where "X" is defined is a
useful property.  If you could find a way to label these differently,
that would be awesome.  Sorry, but I'm not sure that I have a good
suggestion.

> series. In which case this document probably needs to be standards track.

We should celebrate and embrace our downref rules.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 28 Mar 2012 04:15:12 +0000

> -----Original Message-----
> From: Martin Thomson [mailto:[email-masked]]
> Sent: Tuesday, March 27, 2012 8:15 PM
> To: Peter Saint-Andre
> Cc: Murray S. Kucherawy; [email-masked]
> Subject: Re: draft-kucherawy-httpbis-summary
> 
> Awesome.
> 
> I find the fact that the document is documented by lists entitled "IANA
> Actions include" (capitalization?) to be a little strange, but also
> surprisingly useful.  Being able to see where "X" is defined is a

How about "IANA actions in this document"?

I didn't list all the registrations for all the registries because in at least one case the full bulleted list of them would take an entire page.  Instead it's more of a "If you don't find the one you want in the other documents, it's in the first one."  But if you wanted me to be complete, I could.

> We should celebrate and embrace our downref rules.

I'm sure you're kidding about that... right?  :-)

I'll switch it to PS.  A missed downref in a Last Call announcement only causes delays.

At last report the WG draft pre-approval tool is busted, but let me know if and when I should rename this to draft-ietf-httpbis-something and resubmit it.

-MSK

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Mar 2012 06:27:17 +0200

> How about "IANA actions in this document"?

I think that the concern is that you focus on IANA, when what your
users really care about is what _pieces_ of HTTP can be found in the
part in question.  Maybe something more like:

"[http-p1] describes these components/pieces/bits/things/stuff of HTTP:"

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 28 Mar 2012 04:31:33 +0000

> Sent: Tuesday, March 27, 2012 9:27 PM
> To: Murray S. Kucherawy
> Cc: [email-masked]

Essentially what I've indexed ends up being the same thing.  If you find the IANA action for registering X, then you will also find either the very definition of X, or at least specific reference to its definition.

I could change it to "The following major HTTP components are defined" in each document section, and then include a paragraph in the Introduction that says that the IANA actions in each document can be gleaned from that summary.  Good enough?

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 28 Mar 2012 04:34:37 +0000

> part in question.  Maybe something more like:

Like so (pardon the XML):

                <t> This document summarizes the series of documents comprising
                    the definition of HTTP/1.1.  A synopsis of each document
                    is provided, as well as an enumeration of the key
                    definitions (and, thus, their corresponding IANA actions)
                    and security topics each one contains.  This is intended
                    to serve as a super table of contents for the series. </t>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Mar 2012 06:49:48 +0200

>                    to serve as a super table of contents for the series. </t>

Great!  Ship it.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Mar 2012 07:00:18 +0200

Another observation, sorry about the piecemeal responses:

   This document neither introduces nor modifies any protocol and as
   such has no security implications.

Could be more explicit:

   This introductory part has no security implications.  Refer to the security
   considerations section of each part for discussion of relevant concerns.

Or something like that.

What you have might be a little wrong too, depending on which
definition of "introduces" you use.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 28 Mar 2012 05:03:35 +0000

> Sent: Tuesday, March 27, 2012 9:50 PM
> To: Murray S. Kucherawy
> Cc: [email-masked]

Done, though now that I see your other message: D'oh!

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Mar 2012 07:13:35 +0200

> Done, though now that I see your other message: D'oh!

No biggie.  I'm sure that you'll get other comments when other people
awake and prime the brain engine with their morning stimulants.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Mar 2012 10:05:11 +0200

> At last report the WG draft pre-approval tool is busted, but let me know if and when I should rename this to draft-ietf-httpbis-something and resubmit it.

Not yet, thanks. We're still thinking about the organisation, and if we do decide to do a p0, it's likely to be done directly from the current sources (there are a lot of advantages to keeping it within the tool chain).

Cheers,

--
Mark Nottingham
http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Mar 2012 13:00:03 +0200

> Not yet, thanks. We're still thinking about the organisation, and if we do decide to do a p0, it's likely to be done directly from the current sources (there are a lot of advantages to keeping it w…

In particular, I'll automate any generation of reference tables, 
indices, etc.

Best regards, Julian