Subject: Working Group Last Call: httpbis p4 / p5 / p6 / p7

From: Mark Nottingham <[email-masked]>
Date: Thu, 15 Mar 2012 18:20:50 +1100

After discussion with the editors and ADs, I believe the following documents are ready for Working Group Last Call (WGLC):

HTTP/1.1, part 4: Conditional Requests
 http://tools.ietf.org/html/draft-ietf-httpbis-p4-conditional-19

HTTP/1.1, part 5: Range Requests and Partial Responses
 http://tools.ietf.org/html/draft-ietf-httpbis-p5-range-19

HTTP/1.1, part 6: Caching
 http://tools.ietf.org/html/draft-ietf-httpbis-p6-cache-19

HTTP/1.1, part 7: Authentication
 http://tools.ietf.org/html/draft-ietf-httpbis-p7-auth-19

To encourage implementers to review and provide feedback on the documents, we're doing a four-week WGLC, ending on April 12, 2012. However, early reviews are appreciated, as that will give us the opportunity to discuss potential changes at our Paris meeting.

*** Providing Feedback

Your input should be sent to this mailing list, clearly marked with "WGLC" and the appropriate part. E.g., with Subject lines such as:

 Subject: WGLC review of p4-conditional
 Subject: WGLC issue: "foo" in p5

Issues that you believe to be editorial in nature (e.g., typos, suggested re-phrasing) can be grouped together in a single e-mail. Substantive issues (what we call "design" issues) that may need discussion should be sent one per e-mail, with a descriptive subject.

If you disagree with the resolution of a previously discussed issue, you're encouraged to note that at this time.

*** What's Next

The Working Group will discuss these issues, re-issuing drafts as necessary. Tickets raised on these drafts will have a severity of "In WG Last Call" , and once they are disposed of, we'll see if there's consensus on going to IETF Last Call on them (as Chair, I'll judge this for each document except p6, where I'll defer to Mark Baker, the document shepherd, since I've edited a substantial part of that specification).

p1, p2 and p3 should join them in WGLC at or shortly after our Paris meeting. We anticipate sending all of the documents to IETF LC together.

Thanks to the editors for their hard work in getting to this point.

--
Mark Nottingham
http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 15 Mar 2012 09:23:00 +0100

Hi there,

please also note that we have HTML versions at

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p4-conditional.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p5-range.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p6-cache.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/19/p7-auth.html

which come with feedback links that should make it really simple to 
provide quick comments.

Also, we'll continue to work on the drafts as comments come in; you can 
always find the latest and greatest at

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p4-conditional.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p5-range.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p6-cache.html

https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p7-auth.html

For trivial corrections, if you suspect that somebody else might already 
have reported the bug, you may want to check here whether it's fixed 
already.

Looking forward to review comments.

Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 22 Mar 2012 11:23:05 +1100

FYI, WGLC tickets are captured here:
  http://trac.tools.ietf.org/wg/httpbis/trac/report/20

--
Mark Nottingham   http://www.mnot.net/