Subject: Re: Make HTTP 2.0 message/transport format agnostic

From: "Poul-Henning Kamp" <[email-masked]>
Date: Sun, 01 Apr 2012 07:21:04 +0000

In message <CAHBU6ivKQypwvHPf09FjENm57DsPnH=[email-masked]>
, Tim Bray writes:

>Funny you should mention that.  ASN.1 has historically been a
>miserable failure;

About the only place ASN.1 survives, are in contexts where the OSI
protocols was an inspiration or basis for the work:  SNMP and X.50[0-9]

For SNMP, ASN.1 was a political trick to make SNMP acceptable as a
"gateway drug" to CMIP.

For X.50[0-9] I don't know the story.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: "Adrien W. de Croy" <[email-masked]>
Date: Sun, 01 Apr 2012 11:22:36 +0000

The one time I had to look at it was for H.323, which I believe is 
still quite prevalent, although possibly losing ground to SIP?
  
according to the ITU, LDAP even uses it?
  
http://www.itu.int/ITU-T/asn1/uses/index.htm
  
Looks like it is used in some applications that take some fairly 
serious heat (e.g. WiMAX, UMTS and LTE).
  
Still not suggesting it for HTTP tho :)

------ Original Message ------
From: "Poul-Henning Kamp" <[email-masked]>
To: "Tim Bray" <[email-masked]>
Cc: "Adrien W. de Croy" <[email-masked]>;"Mark Nottingham" 
<[email-masked]>;"Kevin Cathcart" 
<[email-masked]>;"[email-masked]" <[email-masked]>
Sent: 1/04/2012 7:21:04 p.m.
Subject: Re: Make HTTP 2.0 message/transport format agnostic