Subject: Re: SPDY = HTTP/2.0 or not ?

From: Karl Dubost <[email-masked]>
Date: Tue, 3 Apr 2012 16:33:41 -0400

Le 26 mars 2012 à 04:34, Mike Belshe a écrit :
> I don't know of any examples where users want unsecured products or protocols, actually.

In addition to that, most people (even with all the recent press) have no idea that their online activities (web, mail, etc) are readable on the wire. 

-- 
Karl Dubost - http://dev.opera.com/
Developer Relations, Opera Software

---

From: Christopher Müller <[email-masked]>
Date: Wed, 4 Apr 2012 08:36:06 +0200

> Von: Karl Dubost [mailto:[email-masked]]
> Gesendet: Dienstag, 03. April 2012 22:34
> An: Mike Belshe
> Cc: HTTP Working Group
> Betreff: Re: SPDY = HTTP/2.0 or not ?
> 
> 

All free HTTP video streams or streams where the content is already DRM
encrypted. Automatic SSL encryption would be an overkill for the content
providers so I really hope that the SSL encryption will be optional in
HTTP/2.0.

Best Regards
Christopher Mueller

---

From: Karl Dubost <[email-masked]>
Date: Wed, 4 Apr 2012 04:25:58 -0400

> providers so I really hope that the SSL encryption will be optional in

It is a different layer of the social interaction using HTTP.
DRM == protect the producer
SSL == protect the user

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Wed, 04 Apr 2012 08:32:18 +0000

In message <[email-masked]>, Karl Dubost writes

>DRM == protect the producer

They both pay for their own computer and bandwidth, no matter how
misguided we think their preferences might be, we should not
discriminate.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Alexandre Morgaut <[email-masked]>
Date: Wed, 4 Apr 2012 10:37:59 +0200

> DRM == protect the producer

with client certificates, SSL can somehow also protect the producer ;-)

Alexandre Morgaut
Product Manager

4D SAS
60, rue d'Alsace
92110 Clichy
France

Standard : +33 1 40 87 92 00
Email :    [email-masked]
Web :      www.4D.com

---

From: "Stefan Lederer" <[email-masked]>
Date: Wed, 4 Apr 2012 10:50:15 +0200

> with client certificates, SSL can somehow also protect the producer ;-)

Another problem when using SSL for HTTP video streams is that caches cannot
be used very efficiently. This would introduce problems/higher costs in
content distribution, etc. 

Best Regards
Stefan Lederer

---

From: Ray <[email-masked]>
Date: Wed, 4 Apr 2012 05:26:46 -0600

<conspiracyTheory>
...and give a huge speed advantage to a company wealthy enough to configure their own edge caching infrastructure?  thus massively increasing barrier to entry for upstart competition?
</conspiracyTheory>  :o 

*spins his rolodex to anti-trust lawyers*

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 4 Apr 2012 10:47:22 -0500

Ray,

We're not here to propagate conspiracy theories. Bringing up anti-trust concerns this early in the process is not helping.

Can everyone please reign in the discussion and keep it on the technology, please.

Thanks,

--
Mark Nottingham
http://www.mnot.net/