Subject: Proposal to make draft-kucherawy-httpbis-summary a WG document

From: Paul Hoffman <[email-masked]>
Date: Sun, 1 Apr 2012 20:34:56 -0700

This seems like a great candidate for a WG document that would
progress with the draft-ietf-httpbis-px-topic drafts. Having it become
an RFC at the same time would make referring to the whole shebang much
easier for the IETF.

--Paul Hoffman

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 2 Apr 2012 04:21:56 +0000

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Sunday, April 01, 2012 8:35 PM
> To: [email-masked]
> Subject: Proposal to make draft-kucherawy-httpbis-summary a WG document
> 
> This seems like a great candidate for a WG document that would progress
> with the draft-ietf-httpbis-px-topic drafts. Having it become an RFC at
> the same time would make referring to the whole shebang much easier for
> the IETF.

It sounds to me like they're planning to add this to the auto-generation output that's currently managing the draft-ietf-httpbis-px-* drafts, so there's no need for mine.  I thought it would be beneficial to have p0 generated by someone outside of the current author set in the checks-and-balances sense, but I see the advantage of what they're doing as well.  So, whatever works for the WG is fine with me.

-MSK

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 2 Apr 2012 06:55:38 -0700

Adding this to the auto-generate output loses one important feature:
future RFCs could point to the set with a single RFC reference, not a
gigantic pile of them. Or did I miss something and there is an
intention to pull all the parts together at the end?

--Paul Hoffman

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 2 Apr 2012 19:40:16 +0100

Paul,

> intention to pull all the parts together at the end?

The editor's can probably reply more authoritatively than I but my interpretation of "adding to the auto-generate output" was that the httpbis editors would take Murray's text and input it to their toolchain so that all 8 parts would be generated using the same toolchain. Murray's text wouldn't be lost and so there would be a p0 that could be used as a single reference point but p0 would be generated consistently with the other 7 parts.

That's predicated with consensus being called that the approach the WG will take is the final "deliverable" will be an 8 part spec. I don't think that consensus has been called yet.

HTH
Ben

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 3 Apr 2012 07:26:26 -0700

Ah, great. +1 to making this "-p0".