Subject: WGLC issue: P6 - Multiple values in Cache-Control headers

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 23 Apr 2012 18:51:32 +0100

Hi,

Apologies that this mail misses the WG LC deadline, in Velocix we're reviewing all the HTTPBIS documents but we're a little behind, hence the late comments, sorry. (we're still reviewing so might have more comments as we work through the documents)

In the HTTPBIS documents there are now specific directions for dealing with multiple values within Host or Content-Length headers.

However, there doesn't appear to be a general conflict resolution
strategy.

For example, if there are multiple Expires headers, valid or invalid (but
assuming at least one valid one), matching or different, which takes precedence? Or must the set be treated invalid? Always?

If "Cache-Control: max-age=5, max-age=10" is received, what is the expected behaviour?

Similar concerns apply to other sections: what do multiple ETag or Last-Modified headers mean? Or multiple Content-Range headers (the same as multiple Content-Length headers one would assume).

Thanks
Ben

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Apr 2012 14:38:56 +1000

No worries, Ben; raised as <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/353>.

--
Mark Nottingham   http://www.mnot.net/