Subject: Advice to define where new status codes can be generated

From: Mark Nottingham <[email-masked]>
Date: Mon, 25 Jun 2012 13:44:02 +1000

Just a quick thought: in <https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p2-semantics.html#considerations.for.new.status.codes>, we talk about guidelines for new status codes. It might be worth advising people to explicitly say whether intermediaries can generate the status code, in addition to (or instead of) the origin.

Make sense?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 25 Jun 2012 08:56:55 +0200

> Just a quick thought: in <https://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p2-semantics.html#considerations.for.new.status.codes>, we talk about guidelines for new status codes.…

Probably yes. Is there a default though?

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Jun 2012 10:39:14 +1000

> Probably yes. Is there a default though?

Probably "unspecified." Which implies "both."

---

From: Julian Reschke <[email-masked]>
Date: Tue, 26 Jun 2012 09:13:05 +0200

> Probably "unspecified." Which implies "both."

I believe in dog food. So if we ask for this for the codes, we should 
state it for existing ones as well. In which case having a default would 
reduce verbosity...

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Jun 2012 17:14:19 +1000

That's what I was thinking. Will start a proposal. 

Sent from my iPhone

On 26/06/2012, at 5:13 PM, Julian Reschke <[email-masked]> wrote:

> I believe in dog food. So if we ask for this for the codes, we should state it for existing ones as well. In which case having a default would reduce verbosity...
> 
> Best regards, Julian