Subject: Re: #346: Registry policies

From: Mark Nottingham <[email-masked]>
Date: Fri, 8 Jun 2012 17:40:11 +1000

I haven't seen much response to this, except a +1 from Julian.

So, the proposed resolution is: to keep Transfer-Codings and Content-Codings at IETF Review, and return Upgrade Tokens First-Come-First-Served.

Any further comments? If not, we'll close and incorporate.

Regards,

On 28/03/2012, at 10:27 PM, Mark Nottingham wrote:

> <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/346>
> 
> At yesterday's meeting, there was some pushback on defining our registry policies as IETF Review for "consistency."
> 
> Given that there is a larger discussion about registry policy definition taking place, and I *think* we've agreed that we shouldn't block HTTPbis on that discussion (since it's likely to take some time), it seems that we should take the attitude of installing (relatively) temporary registration policies; i.e., we should make them reasonable, but not try to solve all of the problems we perceive with them, in the belief / hope that a more general effort will help later.
> 
> In #346, we changed the following registries to "IETF Review":
> 
> * Upgrade Tokens (previously First Come First Served)
> * Transfer-Codings (previously Specification Required)
> * Content-Codings (previously Specification Required)
> 
> I'm re-opening this ticket based upon discussion in the meeting yesterday. 
> 
> My take - 
> 
> I believe we should leave Transfer-Codings and Content-Codings as IETF Review, because otherwise we will need to establish expert review procedures and guidelines for them, as well as identify experts. These are very low-throughput registries, and will benefit from IETF review (as there's a cost to adding new schemes to negotiation).
> 
> I think we should discuss Upgrade Tokens; first-come-first-served may make sense here. However, I'd note it'd be a shame if we spent too much time on it. 

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 08 Jun 2012 12:13:24 +0200

On 2012-06-08 09:40, Mark Nottingham wrote:
> ...

Proposed change: 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/346/346.2.diff>

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sun, 10 Jun 2012 16:07:12 +0200

On 2012-06-08 12:13, Julian Reschke wrote:
>> So, the proposed resolution is: to keep Transfer-Codings and
>> Content-Codings at IETF Review, and return Upgrade Tokens
>> First-Come-First-Served.
>>

Hearing no objections -> 
<http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1674>

Best regards, Julian