Subject: inv-maxage Cache-Control directive syntax, was: Fwd: I-D Action: draft-nottingham-linked-cache-inv-00.txt

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 14:12:02 +0200

On 2011-05-28 02:56, Mark Nottingham wrote:
> FYI. This is an individual draft, not a WG effort. Nevertheless, feedback welcome.
>
> Regards,
> ...

In 
<http://tools.ietf.org/html/draft-nottingham-linked-cache-inv-02#section-5>, 
it would be good to define the edge parsing edge cases, such as:

- multiple instances of the directive,

- missing argument,

- use of quoted-string.

I would propose to say that:

- the parameter value needs to follow the delta-seconds ABNF after 
applying generic C-D parsing,

- that a missing argument is to be treated as empty string (thus 
invalid), and

- that specifying multiple instances makes the Cache-Control header 
invalid with respect to this directive (thus the header field should be 
processed as if inv-maxage wasn't specified at all).

Optimally, including examples :-)

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 15 Jun 2012 09:11:48 +1000

On 14/06/2012, at 10:12 PM, Julian Reschke wrote:

> In <http://tools.ietf.org/html/draft-nottingham-linked-cache-inv-02#section-5>, it would be good to define the edge parsing edge cases, such as:
> 

Agreed.

> - the parameter value needs to follow the delta-seconds ABNF after applying generic C-D parsing,

C-D?

> - that a missing argument is to be treated as empty string (thus invalid), and

Yes

> - that specifying multiple instances makes the Cache-Control header invalid with respect to this directive (thus the header field should be processed as if inv-maxage wasn't specified at all).

yes

> Optimally, including examples :-)

As always

Thanks,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 15 Jun 2012 08:50:24 +0200

>> - the parameter value needs to follow the delta-seconds ABNF after applying generic C-D parsing,

Sry. Cache-Control!

Best regards, Julian