Subject: RFC6585+HTTP/2.0 := 101

From: Jonathan Ballard <[email-masked]>
Date: Thu, 26 Jul 2012 17:31:00 -0700

In Re: http://tools.ietf.org/html/rfc6585 (page ~2)

I looked at this RFC as if I wanted to derive it into the revision for 2.0:

"""
   HTTP/1.1 428 Precondition Required
   Content-Type: text/html   <html>

      <head>
         <title>Precondition Required</title>
      </head>
      <body>
         <h1>Precondition Required</h1>
         <p>This request is required to be conditional;
         try using "If-Match".</p>
      </body>
   </html>

"""

(instead of from scratch)

"""
   HTTP/2.0 428 Precondition Required

 <head id=428>

       Date: <time>&xhtml.now;</time>

       <meta>

         Content-Type: text/html+xml

         Title: Precondition Required

       </meta>

 </head>

 <body itemscope itemtype="urn:http:status">
       <h1  itemprop=name>Precondition Required</h1>
       <p   itemprop=description>This request is required

                                 to be conditional;
                                 try using "If-Match".</p>

       <img itemprop=image />

       <a   itemprop=url />
 </body>"""

I exhausted myself, today, over the idea of the calendar application
integration with blogger. What I had on mind was how do we describe: POST
/.well-known/509 HTTP/2.0, especially for cloud-containers that do not have
nested directories. This is how far I got. I figured GET /.well-known/428
HTTP/2.0 would display the above.

Enjoy the Olympics...

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 Jul 2012 15:53:50 +1000

Jonathan / Dzonatas,

This is off-topic for this working group.

You've been warned privately on several occasions. Consider this a public warning, as per BCP94. If you continue to disrupt the work, your posting privileges will be suspended.

On 27/07/2012, at 10:31 AM, Jonathan Ballard <[email-masked]> wrote:

>    Content-Type: text/html
>    <html>
> I exhausted myself, today, over the idea of the calendar application integration with blogger. What I had on mind was how do we describe: POST /.well-known/509 HTTP/2.0, especially for cloud-containers that do not have nested directories. This is how far I got. I figured GET /.well-known/428 HTTP/2.0 would display the above.
> 
> 
> Enjoy the  Olympics...
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Amos Jeffries <[email-masked]>
Date: Fri, 27 Jul 2012 17:54:12 +1200

>                                   try using "If-Match".</p>

I think the thing to notice here is the 295% *increase* in bandwidth 
consumption for content meta data. After removing the unnecessary 
whitespace.

AYJ

---

From: Jonathan Ballard <[email-masked]>
Date: Fri, 27 Jul 2012 07:40:09 -0700

Thanks for the notice.

My intent is to stay on-topic, and my post appeared like it leaped. We
already argued canonicalization, and its process modes, around ~1990, so I
thought there was no issue about that. I haven't been bound by BSD
given prevalent authority since then, so sorry.