Subject: #359 clarify connection header field values are case-insensitive

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Jul 2012 10:04:21 +0200

(Origin: 
<http://stackoverflow.com/questions/10953635/are-the-http-connection-header-values-case-sensitive>)

This ought to be non-controversial; I'd propose to simply state

"Connection options are compared case-insensitively."

below the ABNF (and also rename the ABNF production "connection-token" 
to "connection-option" to remove any confusion).

Proposed patch: 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/359/359.diff>

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 3 Jul 2012 18:17:00 +1000

+1
s
On 03/07/2012, at 6:04 PM, Julian Reschke wrote:

> (Origin: <http://stackoverflow.com/questions/10953635/are-the-http-connection-header-values-case-sensitive>)
> 
> below the ABNF (and also rename the ABNF production "connection-token" to "connection-option" to remove any confusion).
> 
> Proposed patch: <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/359/359.diff>
> 
> Best regards, Julian
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Jul 2012 11:30:16 +0200

-> <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1706>

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 3 Jul 2012 20:00:00 +0200

Hi Julian,

> "Connection options are compared case-insensitively."

Indeed, if people still have issues with this (and I used to years ago), better
clarify it.

Willy

---

From: Amos Jeffries <[email-masked]>
Date: Wed, 04 Jul 2012 19:27:50 +1200

> Indeed, if people still have issues with this (and I used to years ago), better

+1.

AYJ