Subject: #371: If-Modified-Since lacks definition for method != GET

From: Julian Reschke <[email-masked]>
Date: Wed, 11 Jul 2012 15:07:18 +0200

From an off-list WGLC comment:

>     3.3. If-Modified-Since
>
>         The "If-Modified-Since" header field MAY be used to make a request method conditional by modification date: if the selected representation has not been modified since the time specified in this field, then do not perform the request method; instead, respond as detailed below.
>
> This section doesn't seem to say anything about methods other than GET, yet the text seems to imply that a more general case is also covered below.

-> <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/371>

Indeed, the spec doesn't really say; is it (a) undefined, (b) 304, or 
(c) 412?

Feedback appreciated,

Julian Reschke

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Jul 2012 14:12:59 +1000

On 11/07/2012, at 11:07 PM, Julian Reschke wrote:

> Indeed, the spec doesn't really say; is it (a) undefined, (b) 304, or (c) 412?

My .02 - 304 is clearly not correct.

I'd be inclined to say undefined, as I don't think we want to promote IMS in these uses.

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 12 Jul 2012 09:04:08 +0200

> I'd be inclined to say undefined, as I don't think we want to promote IMS in these uses.

Well, "defining" is not the same thing as "promoting" :-)

Once we properly resolve the evaluation order issue 
(<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/241>), the answer to 
this one probably will become more obvious.

Best regards, Julian