Subject: Re: Re[2]: Straw-man for our next charter

From: Larry Masinter <[email-masked]>
Date: Mon, 30 Jul 2012 06:36:04 -0700

oddly, the subject of this thread is "our next charter" and my discussion is about what the next charter should say. So I'm bewildered by your repeating that you think my comment is out of order,

The use case given for limiting semantics changes  is to enable 1.1 <--> 2:0 gateways.  Adaptations which can be handled in gateways should be in scope for consideration, if they meet other HTTP/2 goals.

-----Original message-----
From: Adam Barth <[email-masked]>
To: Larry Masinter <[email-masked]>
Cc: "Adrien W. de Croy" <[email-masked]>, "[email-masked]" <[email-masked]>
Sent: Mon, Jul 30, 2012 07:58:59 GMT+00:00
Subject: Re: Re[2]: Straw-man for our next charter

On Sun, Jul 29, 2012 at 8:24 PM, Larry Masinter <[email-masked]> wrote:
> HTTP 2.0 can tighten requirements where loose interpretation in HTTP 1.x leads to performance, reliability, security problems.

Where does the charter say that?  My reading of the charter is that
"changes to the existing semantics of HTTP are out of scope."

Adam

---

From: Jonathan Ballard <[email-masked]>
Date: Mon, 30 Jul 2012 07:58:05 -0700

Right. If we make sure the semantics are consistent and the same between
connections of interest then, that allows us to verify them (each one of
them). We shouldn't have to always do that verification step or consistency
check so manually, especially when there is less costly automation. The
implementation or, more on overall topic, brief specifications of such
automation is not change in said semantics even if it implies change to
their perceivable weight.

On Monday, July 30, 2012, Larry Masinter wrote:

> oddly, the subject of this thread is "our next charter" and my discussion
> is about what the next charter should say. So I'm bewildered by your
> repeating that you think my comment is out of order,
>
> The use case given for limiting semantics changes  is to enable 1.1 <-->
> 2:0 gateways.  Adaptations which can be handled in gateways should be in
> scope for consideration, if they meet other HTTP/2 goals.
>
> *From: *Adam Barth <[email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>>*
> To: *Larry Masinter <[email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>>*
> Cc: *"Adrien W. de Croy" <[email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>>, "[email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>" <[email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>>*
> Sent: *Mon, Jul 30, 2012 07:58:59 GMT+00:00*
> Subject: *Re: Re[2]: Straw-man for our next charter
>
>  On Sun, Jul 29, 2012 at 8:24 PM, Larry Masinter <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>>
> wrote:
> > HTTP 2.0 can tighten requirements where loose interpretation in HTTP 1.x
> leads to performance, reliability, security problems.
>

---

From: Adam Barth <[email-masked]>
Date: Mon, 30 Jul 2012 09:10:07 -0700

Ah, I didn't understand the context.

In that case, I don't think we should expand our charter to include
changing the semantics of HTTP.  That's a can of worms that will
derail the HTTP/2.0 effort.  It's going to be hard enough to keep the
working group productive with the limited scope we have already.

Adam

On Mon, Jul 30, 2012 at 6:36 AM, Larry Masinter <[email-masked]> wrote:
> oddly, the subject of this thread is "our next charter" and my discussion is
> about what the next charter should say. So I'm bewildered by your repeating
> that you think my comment is out of order,
>
> The use case given for limiting semantics changes  is to enable 1.1 <--> 2:0
> gateways.  Adaptations which can be handled in gateways should be in scope
> for consideration, if they meet other HTTP/2 goals.
>