Subject: Re: Call for Expressions of Interest in Proposals for HTTP/2.0 and New HTTP Authentication Schemes

From: Mark Nottingham <[email-masked]>
Date: Tue, 3 Jul 2012 12:12:01 +1000

Please submit feedback to this from your implementation or deployment ASAP; without this information, I'll be forced to rely on my own impressions more heavily when judging consensus (which means less grounds for complaining if it doesn't go your way). 

Note that one of the options on the table for the protocol, by default, is to do nothing -- i.e., continue to develop HTTP/1.1 pipelining to address performance concerns (which quite a few implementations have been doing recently).

Likewise, no expressions of interest in implementing or using the proposed authentication schemes is hard to misinterpret.

Finally, I've added a new authentication scheme proposal, so if you've already started, please re-check the list on the CfI.

Thanks,

On 21/06/2012, at 11:51 AM, Mark Nottingham wrote:

> In Paris, we set a deadline for proposals for further work around HTTP/2.0 at June 15.
> 
> The proposals we've received are listed here:
>  http://trac.tools.ietf.org/wg/httpbis/trac/wiki/Http2Proposals
>  http://trac.tools.ietf.org/wg/httpbis/trac/wiki/HttpAuthProposals
> 
> Note that a few are not fully-formed proposals in their own right, and therefore they're not really appropriate to consider as starting points for further work, but instead as input documents that can inform further discussion once we choose a starting point.
> 
> My goal is to be able to request a re-charter -- provided we agree that this is necessary -- soon after the Vancouver meeting.
> 
> To help gather information about this, we're making a Call for Expressions of Interest in the various proposals from implementers and deployers of HTTP. Please have a look at
> 
>  http://trac.tools.ietf.org/wg/httpbis/trac/wiki/Http2CfI
> 
> send your own feedback, and circulate that link among the folks who you know work on or use HTTP.
> 
> Regards,
> 
> --
> Mark Nottingham   http://www.mnot.net/
> 
> 
> 
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 03 Jul 2012 10:10:57 +0100

> Likewise, no expressions of interest in implementing or using the proposed authentication schemes is hard to misinterpret.

Not sure I agree that the interpretation of silence is that
clear. It could mean they've just not read 'em, or are on
vacation, or think someone else will do it, or would like
all this security muck to just go away.

I would hope that people take the WG charter seriously
enough to at least read and comment on the proposals, be
that positively or negatively.

S.

---

From: Jan Engelhardt <[email-masked]>
Date: Tue, 3 Jul 2012 14:18:41 +0200 (CEST)

On Tuesday 2012-07-03 04:12, Mark Nottingham wrote:

>Please submit feedback to this from your implementation or
>deployment ASAP; without this information, I'll be forced to rely on
>my own impressions more heavily when judging consensus (which means
>less grounds for complaining if it doesn't go your way).
>
>Note that one of the options on the table for the protocol, by
>default, is to do nothing -- i.e., continue to develop HTTP/1.1
>pipelining to address performance concerns (which quite a few
>implementations have been doing recently).
>
>Likewise, no expressions of interest in implementing or using the
>proposed authentication schemes is hard to misinterpret.

Rather than reinventing extra framing atop of TCP, the use of SCTP for 
multiple concurrent HTTP streams should be considered. I wouldn't let 
"SCTP is not deployed" count as an argument. IPv6 was/is not deployed 
either (depending on who you ask). New protocols hardly ever are.

Server pushes: One of the big strengths of HTTP has been that the user 
agent chooses which URLs to download data from. Other voices on the 
Internet point out that server-side pushes look like an attempt to 
counter adblockers; while adblockers will likely continue to do their 
job (after all, all data has some location), server side pushes can 
actually clog the pipe if they can send arbitrary documents anytime - 
and make it anything but spdy.

Let the client choose the modus operandi. Require that a HTTP/2.x server 
supports traditional pushless operation.

>> Note that a few are not fully-formed proposals in their own right, 
>>and therefore they're not really appropriate to consider as starting 
>>points for further work, but instead as input documents that can 
>>inform further discussion once we choose a starting point.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Jul 2012 14:31:39 +0200

On 2012-07-03 14:18, Jan Engelhardt wrote:
> ...
> ...

Please see 
<http://lists.w3.org/Archives/Public/ietf-http-wg/2012AprJun/0343.html> 
and <http://datatracker.ietf.org/wg/httpbis/charter/> -- if you want to 
make a concrete proposal, you should write it down in the form of an 
internet draft. Also note HTTP-over-SCTP has been considered before, so 
you may be able to start from one of the existing proposals.

Best regards, Julian

---

From: Roberto Peon <[email-masked]>
Date: Tue, 3 Jul 2012 12:13:43 -0700

> >less grounds for complaining if it doesn't go your way).

Mark-
A number of us are in the process of organizing for this.
4th of July week over here has added delay to this because many people are
taking the week off.

-=R

---

From: Gabriel Montenegro <[email-masked]>
Date: Tue, 3 Jul 2012 20:52:40 +0000

The EoI wiki at http://trac.tools.ietf.org/wg/httpbis/trac/wiki/Http2CfI says that the deadline is "no later than 15 July 2012", so there still are a few days, right?

From: Roberto Peon [mailto:[email-masked]]
Sent: Tuesday, 3 July, 2012 12:14
To: Jan Engelhardt
Cc: Mark Nottingham; HTTP Working Group
Subject: Re: Call for Expressions of Interest in Proposals for HTTP/2.0 and New HTTP Authentication Schemes

On Tue, Jul 3, 2012 at 5:18 AM, Jan Engelhardt <[email-masked]<mailto:[email-masked]>> wrote:

Mark-
A number of us are in the process of organizing for this.
4th of July week over here has added delay to this because many people are taking the week off.

-=R

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 4 Jul 2012 06:55:25 +1000

Yup.

On 04/07/2012, at 6:52 AM, Gabriel Montenegro wrote:

> The EoI wiki at http://trac.tools.ietf.org/wg/httpbis/trac/wiki/Http2CfI says that the deadline is “no later than 15 July 2012”, so there still are a few days, right?
>