Subject: X-Content-Warning response for better world

From: Talisman Dima <[email-masked]>
Date: Wed, 24 Oct 2012 11:48:24 +0400

I think about children-safety and want discuss next thing:

What you think about creating new HTTP response-header, for example:
"X-Content-Warning:"

which for example will contain warnings about: adult content, harmful
content, obscene language

In browser settings parents could activate filtering of such content, It
will make Internet much more safer for children's.

For instance, website may response with header: "X-Content-Warning: adult,
harmful, obscene" if content is inappropriate for children's.

Is this nice thing, if sites will mark content in such way?

===
Dmitry Syrovatskiy

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Oct 2012 19:03:15 +1100

See:
  http://www.w3.org/PICS/
  http://www.w3.org/2007/powder/

Cheers,

On 24/10/2012, at 6:48 PM, Talisman Dima <[email-masked]> wrote:

> What you think about creating new HTTP response-header, for example: "X-Content-Warning:"
> 
> which for example will contain warnings about: adult content, harmful content, obscene language
> 
> In browser settings parents could activate filtering of such content, It will make Internet much more safer for children's.
> 
> For instance, website may response with header: "X-Content-Warning: adult, harmful, obscene" if content is inappropriate for children's.
> 

--
Mark Nottingham   http://www.mnot.net/