Subject: WGLC: SHOULD and conformance

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Apr 2013 12:25:54 +1000

Up until now, we've had this to say about the status of SHOULDs regarding conformance (p1, "Conformance and Error Handling):

> An implementation is considered conformant if it complies with all of the requirements associated with the roles it partakes in HTTP. Note that SHOULD-level requirements are relevant here, unless one of the documented exceptions is applicable.

After reviewing the specs (and taking in account the misused SHOULDs and those I think should be stronger, see previous messages), I believe that ALL of the remaining SHOULDs in the set are NOT relevant to conformance, but instead  represent implementation guidance. 

So, I propose we change the text above in p1 to:

"""
An implementation is considered conformant if it complies with all of the MUST-level requirements associated with the roles it partakes in HTTP. Note that SHOULD-level requirements are relevant to conformance, but do not formally impact it; instead, they represent implementation guidance.
"""

Thoughts?

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Mon, 29 Apr 2013 21:08:24 -0700

+1.. That's a lot closer to reality anyway.
On Apr 29, 2013 7:27 PM, "Mark Nottingham" <[email-masked]> wrote:

> Up until now, we've had this to say about the status of SHOULDs regarding
> conformance (p1, "Conformance and Error Handling):
>
> > An implementation is considered conformant if it complies with all of
> the requirements associated with the roles it partakes in HTTP. Note that
> SHOULD-level requirements are relevant here, unless one of the documented
> exceptions is applicable.
>
> After reviewing the specs (and taking in account the misused SHOULDs and
> those I think should be stronger, see previous messages), I believe that
> ALL of the remaining SHOULDs in the set are NOT relevant to conformance,
> but instead  represent implementation guidance.
>
> An implementation is considered conformant if it complies with all of the
> MUST-level requirements associated with the roles it partakes in HTTP. Note
> that SHOULD-level requirements are relevant to conformance, but do not
> formally impact it; instead, they represent implementation guidance.
> """
>
> Thoughts?
>
> --

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 30 Apr 2013 07:55:05 +0200

> +1.. That's a lot closer to reality anyway.

+1 as well. It really emphasizes the fast that MUST are non-negociable.

Willy

---

From: "Roy T. Fielding" <[email-masked]>
Date: Tue, 30 Apr 2013 01:13:35 -0700

I don't believe that suggested text is consistent with RFC2119.

In fact, the existing second sentence is just wrong (there is no
need for documented exceptions), so let's just delete it.
The existing first sentence is fine.

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Apr 2013 18:52:27 +1000

That works for me too.