Subject: p2: deprecating 205 Reset Content?

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Apr 2013 15:34:24 +1000

p2 defines this status code:

> The 205 (Reset Content) status code indicates that the server has fulfilled the request and desires that the user agent reset the "document view", which caused the request to be sent, to its original state as received from the origin server.

but AIUI it isn't implemented in any browser. See:
  http://benramsey.com/blog/2008/05/http-status-204-no-content-and-205-reset-content/

While it might have uses outside of browsers, the identified use case *is* data entry, which screams "browser" (at least to me). 

AFAICT it was first proposed here:
  http://lists.w3.org/Archives/Public/ietf-http-wg-old/1995MayAug/0575.html
and resolutely failed to catch on.

This being the case, should we consider noting its lack of implementation support, or even deprecating it (as we did for 305, which showed a similar lack of interest/deployment)?

Cheers,

P.S. I don't want to spend a lot of time on this; if people have strong feelings against both noting lack of support and deprecating it, just say so and I'm happy to drop it. OTOH if you think it's a good idea, say so and it'll help us make a decision more quickly.

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Mon, 29 Apr 2013 07:33:47 -0700

The last time I used 205 was in a document management app I wrote in 1999.
I think deprecating it is safe.
On Apr 28, 2013 10:35 PM, "Mark Nottingham" <[email-masked]> wrote:

> > The 205 (Reset Content) status code indicates that the server has
> fulfilled the request and desires that the user agent reset the "document
> view", which caused the request to be sent, to its original state as
> received from the origin server.
>
> While it might have uses outside of browsers, the identified use case *is*
> data entry, which screams "browser" (at least to me).
>
> This being the case, should we consider noting its lack of implementation
> support, or even deprecating it (as we did for 305, which showed a similar
> lack of interest/deployment)?
>
> Cheers,
>
> P.S. I don't want to spend a lot of time on this; if people have strong
> feelings against both noting lack of support and deprecating it, just say
> so and I'm happy to drop it. OTOH if you think it's a good idea, say so and
> it'll help us make a decision more quickly.
>
> --

---

From: William Chan (陈智昌) <[email-masked]>
Date: Mon, 29 Apr 2013 07:40:16 -0700

We don't use it either, so I'm fine with deprecating it.

On Mon, Apr 29, 2013 at 7:33 AM, James M Snell <[email-masked]> wrote:

>> While it might have uses outside of browsers, the identified use case
>> *is* data entry, which screams "browser" (at least to me).
>>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 29 Apr 2013 16:48:05 +0200

On 2013-04-29 16:33, James M Snell wrote:
> The last time I used 205 was in a document management app I wrote in
> 1999. I think deprecating it is safe.

+-0

In general, I'd like to focus on things that are *essential* to get 
HTTPbis out of the door. This seems to be a change that's not essential.

And no: we don't need to submit *perfect* documents. They just need to 
be better than RFC 2616, and optimally without known issues. I totally 
expect to work on httpbisbis once http2 is out of the door, 
incorporating the feedback that will surely come out of that.

Best regards, Julian

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 29 Apr 2013 10:14:12 -0700

The most common use of 205 is within custom HTTP systems, not browsers.
We could only do harm by deprecating it.

....Roy

---

From: James M Snell <[email-masked]>
Date: Mon, 29 Apr 2013 10:23:03 -0700

Deprecating it in spec doesn't harm those existing systems in any way,  it
just means,  at worse,  eventually future iterations of those systems would
need to find a better approach to that particular problem.  Let's not be
afraid to dump stuff we really don't need. That said.  I do agree that
there are more important things to be focusing on.
On Apr 29, 2013 10:15 AM, "Roy T. Fielding" <[email-masked]> wrote:

> > This being the case, should we consider noting its lack of
> implementation support, or even deprecating it (as we did for 305, which
> showed a similar lack of interest/deployment)?
> >
> > Cheers,
> >

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Apr 2013 12:09:55 +1000

Ok. What about noting its implementation status? We've done that in a few other places, where people might be surprised by lack of support for a feature.