Subject: p6: Vary and effects on future requests

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Apr 2013 15:13:37 +1000

p6 4.3 says:

"""A Vary header field value of "*" always fails to match, and subsequent requests to that resource can only be properly interpreted by the origin server."""

Someone reading this could take away that *any* stored response with a Vary: * has an effect on ALL other stored responses that share that primary key (and a couple of the issues we discussed reflected this confusion, from memory).

As I recall, the goal for 4.3 Using Negotiated Responses was to assure that stored responses were independent and self-describing; i.e., that a cache didn't have to rationalise the value of the Vary header among multiple stored responses.

So, I'd suggest changing this to just:

"A Vary header field value of "*" always fails to match."

Make sense?

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Apr 2013 22:39:02 +1000

On a related note, the text in p6 4.3 doesn't explicitly account for the case when there are stored responses both with and without Vary that might match.

I think this can be addressed by changing:

"If multiple selected responses are available..."

to

"If multiple selected responses (potentially including responses without a Vary header) are available..."