Subject: what's up with commenting on http/2 github issues

From: William Chan (陈智昌) <[email-masked]>
Date: Tue, 23 Apr 2013 21:55:55 -0700

I just noticed people are doing this and I'm missing some of the
discussions. I'm starring the repo now and chiming in directly there, but I
thought we had agreed all the discussions would happen in ietf-http-wg@.
What's the plan?

---

From: James M Snell <[email-masked]>
Date: Tue, 23 Apr 2013 22:29:58 -0700

I'm rather wondering the same thing. I've chimed in a bit over there
but would much rather have the discussion here; however, I'm also
concerned about flooding the list with too much traffic. In the past
few days I've seen a ton of notes post from Mark about a broad variety
of issues (editorial and otherwise) that I'm simply not sure how to
respond to effectively.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Apr 2013 08:18:49 +0200

> but would much rather have the discussion here; however, I'm also

We talked about this during the last WG meeting; IMHO any discussion 
that leads to protocol changes (beyond editorial) needs to happen here.

> ...

Indeed, but that's because Mark does what we all should be doing - doing 
WGLC reviews. We'll just need to handle the back log carefully and see 
that we finish 1.1 as soon as possible.

Best regards, Julian

---

From: William Chan (陈智昌) <[email-masked]>
Date: Tue, 23 Apr 2013 23:37:34 -0700

On Tue, Apr 23, 2013 at 11:18 PM, Julian Reschke <[email-masked]>wrote:

> We talked about this during the last WG meeting; IMHO any discussion that
> leads to protocol changes (beyond editorial) needs to happen here.
>

That's what I recall, but there are definitely some design discussions
happening in Github.

> WGLC reviews. We'll just need to handle the back log carefully and see that
> we finish 1.1 as soon as possible.
>
> Best regards, Julian
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Apr 2013 17:33:28 +1000

On 24/04/2013, at 2:55 PM, William Chan (陈智昌) <[email-masked]> wrote:

> I just noticed people are doing this and I'm missing some of the discussions. I'm starring the repo now and chiming in directly there, but I thought we had agreed all the discussions would happen in ietf-http-wg@. What's the plan?

I don't mind if people discuss editorial issues over there, nor is it a problem if they're getting clarification on a point there before taking it to the mailing list (especially since the list distribution is so broad). 

However, design decisions cannot happen over there. Any substantial discussions should be happening on this list, and I have been periodically prodding folks over there to that effect.

My biggest concern with this is that these side discussions will reduce the value of the issue database; the editors and I use it to track what needs doing, and if it becomes overloaded with noise, we can't do our jobs effectively.

If you see someone taking an issue's discussion in that direction, please help me by asking for discussion to be moved to the list (and NOT continuing it in the issue), or notifying me. 

Thanks,

--
Mark Nottingham   http://www.mnot.net/