Subject: Status code 451 adoption

From: Tim Bray <[email-masked]>
Date: Mon, 15 Apr 2013 10:00:16 -0700

Just for information; Mozilla is using it in their app infrastructure:
http://goo.gl/z3N33

---

From: Julian Reschke <[email-masked]>
Date: Mon, 15 Apr 2013 19:40:45 +0200

> Just for information; Mozilla is using it in their app infrastructure:

Time to submit it for publication then?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Apr 2013 17:27:10 +1000

The link doesn't seem to work (or, at least, I can't find anything about 451 there). Do you have an updated one?

--
Mark Nottingham   http://www.mnot.net/

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 16 Apr 2013 09:44:07 +0200

On Tue, Apr 16, 2013 at 05:27:10PM +1000,
 Mark Nottingham <[email-masked]> wrote 
 a message of 15 lines which said:

> The link doesn't seem to work (or, at least, I can't find anything
> about 451 there). Do you have an updated one?

It seems it is
<http://firefox-marketplace-api.readthedocs.org/en/latest/topics/submission.html>

> > http://goo.gl/z3N33

I plan to write a RFC "URL shorteners use on IETF mailing list is bad
for open standards" :-)

---

From: Tim Bray <[email-masked]>
Date: Tue, 16 Apr 2013 08:56:34 -0700

Also, the implementer wrote a follow-up on his blog:
http://agmweb.ca/2013-04-13-http-status-codes/

---

From: Tim Bray <[email-masked]>
Date: Tue, 16 Apr 2013 08:59:16 -0700

Also, check out these (really rather good) large-format HTTP posters:
https://github.com/bigcompany/know-your-http#readme

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 17 Apr 2013 12:05:45 +1000

At the end, they write:

> Unfortunately some of these status codes are a little less well defined. For code 451 there are currently at least 3 proposed meanings:something about users mailboxes and something RTSP along with the legal restriction. But hopefully users of our API will realise we aren't using Exchange or RTSP

Exchange didn't register, so that's their luck. HTTP isn't RTSP, so that's not a worry.

> and maybe even read the docs to find out what this means.

The whole point of a HTTP status code is that you *don't* have to read application-specific documentation to figure out what it means.

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Wed, 17 Apr 2013 22:10:18 +0200

On 2013-04-16 17:59, Tim Bray wrote:
> ...

I had a look at the "methods" poster, and was unimpressed.

- it's very misleading to say something as GET being defined by HTTP/1.0

- it leaves out the fact that there is a method registry

- it has the idempotence of PATCH wrong

Best regards, Julian