Subject: FYI: Header Compression

From: Mark Nottingham <[email-masked]>
Date: Mon, 15 Apr 2013 15:35:36 +1000

As previously discussed, we're considering both Hervé's HeaderDiff and Roberto's Delta2 as the starting point for header compression.

These approaches are remarkably similar; in fact, both have been tweaking their approaches based upon what they've learned through discussion.

Because of this, I've been talking with them about how best to move forward, and they believe that it's worth trying to combine efforts and work on a unified approach, taking the best of each.

I think this is a good path, provided that we can get the result very soon - as in, within the next ~2 weeks, ideally sooner. 

They believe that they can meet that goal. So, we'll wait a bit longer for that proposal. If you have concerns, please don't hesitate to talk to me.

Roberto and Hervé - please keep the WG informed of your progress.

Thanks,

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Sun, 14 Apr 2013 23:42:40 -0700

FWIW, they are certainly not the only two working on this problem. The
two mechanisms are definitely quite similar and, as I described in the
note I posted yesterday, it ought to be exceedingly simple to merge
them into a single approach.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 15 Apr 2013 17:58:36 +1000

> them into a single approach.

Absolutely, and I didn't mean to minimise the work that others were doing; it's only the starting point we're talking about.

Regards,