Subject: Request: Have git commit messages for design changes include links to relevant discussion email threads

From: William Chan (陈智昌) <[email-masked]>
Date: Mon, 29 Apr 2013 15:06:35 -0300

It'd make it easier for me to go to github blame/history and identify where
stuff comes from. Cheers.

---

From: James M Snell <[email-masked]>
Date: Mon, 29 Apr 2013 11:55:08 -0700

+1
On Apr 29, 2013 11:08 AM, "William Chan (陈智昌)" <[email-masked]>
wrote:

> It'd make it easier for me to go to github blame/history and identify
> where stuff comes from. Cheers.
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Apr 2013 10:11:01 +1000

Yep, this is good practice. Editors, Github will automatically do this if you reference the issue with "#"; e.g.,

"Change Foo to Bar; see #555."

Also, you can use "fixes" or "closes" to close the related issue. Please be careful when doing so with design issues, as we need to make sure they're properly accounted for. See: <https://help.github.com/articles/closing-issues-via-commit-messages>

Cheers,

On 30/04/2013, at 4:06 AM, William Chan (陈智昌) <[email-masked]> wrote:

> It'd make it easier for me to go to github blame/history and identify where stuff comes from. Cheers.

--
Mark Nottingham   http://www.mnot.net/