Subject: p1: HTTP and TCP name delegation

From: Mark Nottingham <[email-masked]>
Date: Sat, 20 Apr 2013 14:07:29 +1000

p1 2.7.1 says:

> Although HTTP is independent of the transport protocol, the "http" scheme is specific to TCP-based services because the name delegation process depends on TCP for establishing authority. An HTTP service based on some other underlying connection protocol would presumably be identified using a different URI scheme, just as the "https" scheme (below) is used for resources that require an end-to-end secured connection. Other protocols might also be used to provide access to "http" identified resources — it is only the authoritative interface used for mapping the namespace that is specific to TCP.

I made a previous editorial comment that this should be clarified as follows:

"...because the name delegation process depends on the TCP port for establishing authority."   (note "port")

However, that wasn't integrated. Is that incorrect, or was there another reason?

Also, no such statement is made in the definition of the HTTPS URI scheme (2.7.2); it should be.

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 22 Apr 2013 13:49:26 +1000

Now:
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/447