Subject: Preliminary agenda for the SF Interim

From: Mark Nottingham <[email-masked]>
Date: Mon, 20 May 2013 13:54:34 +1000

As you can probably guess, we haven't been able to get implementations moving before this Interim, but I'd very much like to exit it being able to get there quickly.

With that in mind, I've asked the editors to publish a draft -03 by early next week, to give everyone enough time to review the draft.

Likewise, I've asked Herve and Roberto to get their header proposal(s) lined up and ready for discussion at the F2F.

Please come into the meeting having read ALL of those documents carefully (once updated), as well as the issues list <https://github.com/http2/http2-spec/issues>.

If there are particular issues that you believe are important to get sorted out for the first implementation draft, please bring them up on-list BEFORE the meeting, so that we can make that time as productive as possible. The current list of such issues is <https://github.com/http2/http2-spec/issues?milestone=1&page=1&state=open>

A _rough_ agenda for discussion:

* Administrivia
   - Blue sheets
   - Introductions
   - Scribe Selection
   - Agenda Bashing
   - NOTE WELL
   - Ground rules for the meeting
* Document review [editors]
  - Open editors' questions
* Header compression
* Server push walkthrough
   * PUSH_PROMISE
* Flow Control overview
* Prioritisation review
* Upgrade / negotiation
* Other issue discussion
* First implementation planning

As always, suggestions appreciated; this will firm up over the next week.

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Mon, 20 May 2013 09:30:02 -0700

> Likewise, I've asked Herve and Roberto to get their header proposal(s) lined up and ready for discussion at the F2F.

While I wasn't asked to have it "lined up and ready for discussion",
the current bohe header proposal will be updated one more time before
the F2F and will be ready for discussion. Specifically, the typed
codecs portion is pretty much done and ready to go.

>[snip]

Frame sizing, Unknown frame handling (clarification of must-ignore
rule), and max concurrent streams ought to be included as well.

- James