Subject: How to pronounce "charset"?

From: "Yi, EungJun" <[email-masked]>
Date: Mon, 13 May 2013 22:00:17 +0900

Hi, all.

I am translating the book "HTTP: The Definitive Guide" from English to
Korean, and I feel difficult to translate the word "charset" to Korean. So
I have just decided to translate the word as it sounds.

But I don't even know how to pronounce the word correctly. Many people
pronounce "charset" as "character set" but I think that is incorrect
because the word does not mean "character set".

Can anyone tell me how to pronounce?

Thanks in advance.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 May 2013 16:15:37 +0200

Great question.  
Coining new terms should never be done without giving pronunciation guidance.
It is one of the small obstacles that makes life for us non-native speakers harder.

I mostly hear "charset" pronounced "care-set" /kɛ(ə)rsɛt/, probably because that makes the root word "character" clear.
A rarer deviant pronunciation is "char-set" /tʃɑrsɛt/ (as if it where somewhat charring).

I'm sure I will now be pummeled to bits by native speakers.

Grüße, Carsten

On May 13, 2013, at 15:00, "Yi, EungJun" <[email-masked]> wrote:

> Hi, all.
> 
> I am translating the book "HTTP: The Definitive Guide" from English to Korean, and I feel difficult to translate the word "charset" to Korean. So I have just decided to translate the word as it sounds.
> 
> But I don't even know how to pronounce the word correctly. Many people pronounce "charset" as "character set" but I think that is incorrect because the word does not mean "character set".
>

---

From: Tim Bray <[email-masked]>
Date: Mon, 13 May 2013 07:42:20 -0700

I count myself an 18n/unicode/typography/font geek and have spent lots
of time among them, and can testify that the first half of “charming”
plus the last half of “handset” mostly prevails in that crowd, whether
it’s correct or not.  -T

---

From: Yoav Nir <[email-masked]>
Date: Mon, 13 May 2013 15:49:29 +0000

Wait, charset is not character set?  UTF-8 is not a set of characters?

But I agree with Tim, that I've heard more tshar-set than car-set

---

From: Ian Fette (イアンフェッティ) <[email-masked]>
Date: Mon, 13 May 2013 08:56:19 -0700

Wow, this seems ripe for bikeshedding. But I've always heard the "care-set"
pronunciation. Native speaker fwiw.

-Ian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 13 May 2013 18:14:18 +0200

> Wait, charset is not character set?  UTF-8 is not a set of characters?

RFC 6365 defines "Coded Character Set" and "charset", and no, they are 
not the same.

> But I agree with Tim, that I've heard more tshar-set than car-set

Same here :-)

Best regards, Julian

---

From: Roberto Peon <[email-masked]>
Date: Mon, 13 May 2013 13:37:12 -0700

I've also heard more 'tshar-set' than 'care-set' or 'car-set' when
'character-set' is abbreviated as 'char-set'.

On the other hand the non-abbreviated form 'character-set' I've always
heard pronounced as 'care-acter-set'

On Mon, May 13, 2013 at 9:14 AM, Julian Reschke <[email-masked]>wrote:

> RFC 6365 defines "Coded Character Set" and "charset", and no, they are not
> the same.
>
>

---

From: James Cloos <[email-masked]>
Date: Tue, 14 May 2013 09:27:27 -0400

>>>>> "YN" == Yoav Nir <[email-masked]> writes:

YN> Wait, charset is not character set?  UTF-8 is not a set of characters?
YN> But I agree with Tim, that I've heard more tshar-set than car-set

Weird.  I've never used or heard anything but the first syllable of
character and the single syllable of set.

Appropriate, of course, since charset is a contraction of character set.

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 1024D/ED7DAEA6

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 14 May 2013 18:32:44 -0700

Clearly from the replies, so far, the answer is both "char set" and "care
set". Feel free to make fun of how standards nerds can never agree on the
pronunciation of important words. (Over on another layer, about 20% of the
people in the Routing Area pronounce it as if it were the Rooting Area. I'm
sure there are other examples.)

--Paul Hoffman

---

From: Larry Masinter <[email-masked]>
Date: Wed, 15 May 2013 07:09:41 -0700

Personally, I think “charset” is a reference to the media type parameter name, and that even in a translation to Korean, it might be better to call it “charset” in Roman letters.

You wouldn’t translate other protocol parameter names, why “charset” ?

From: Paul Hoffman [mailto:[email-masked]]
Sent: Tuesday, May 14, 2013 6:33 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: How to pronounce "charset"?

Clearly from the replies, so far, the answer is both "char set" and "care set". Feel free to make fun of how standards nerds can never agree on the pronunciation of important words. (Over on another layer, about 20% of the people in the Routing Area pronounce it as if it were the Rooting Area. I'm sure there are other examples.)
--Paul Hoffman

On Mon, May 13, 2013 at 6:00 AM, Yi, EungJun <[email-masked]<mailto:[email-masked]>> wrote:
Hi, all.

Thanks in advance.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 May 2013 16:25:35 +0200

On May 15, 2013, at 16:09, Larry Masinter <[email-masked]> wrote:

>  “charset” is a reference to the media type parameter name

Not just a parameter name, it also is a term of art:

http://www.w3.org/TR/2005/REC-charmod-20050215/#sec-EncodingIdent

It is one of the great accidents in Web and Applications Area architecture that the term charset was built from the roots of "character set", which it is only loosely related to, and which in turn is a bad term by itself because it is not at all a set of characters either (the actual set is called "character repertoire" in JTC1/SC2 terms).

Grüße, Carsten

---

From: Karl Dubost <[email-masked]>
Date: Wed, 15 May 2013 10:39:03 -0400

> I have just decided to translate the word as it sounds.

How is it said in Korea? Ask developers in Web agencies, etc. Make a survey around you.

Fwiw, French speakers, pronounce mostly "ch" the French way, which would be equivalent in English to:

	shar-set

-- 
Karl Dubost
http://www.la-grange.net/karl/