Subject: HTTP/2.0 SETTINGS frame values

From: Michael Welzl <[email-masked]>
Date: Tue, 28 May 2013 11:25:31 +0200

(including ICCRG because folks there might be interested)

Hi,

I just joined the list. While I did look at some old presentations from minutes and the list archive, I might have missed an answer to the question I'm asking - my apologies in this case!

Here it goes: here, http://tools.ietf.org/html/draft-ietf-httpbis-http2-02#section-3.7.4
various values are defined, like an estimate of the upload bandwidth, download bandwidth, the RTT, the initial window and so forth.

I wonder, has it been discussed whether these things are useful and/or appropriate?
I have only seen a thread related to SETTINGS_CURRENT_CWND, but what about all the other stuff (values 1, 2, 3, 4, 6, 7)? This smells like a feedback channel for app-layer congestion control, is this the plan  (of, ahem, the whole HTTPBIS group) ?    :-)

Thanks, cheers,
Michael

---

From: Michael Welzl <[email-masked]>
Date: Tue, 28 May 2013 11:31:25 +0200

I can't believe that this keeps happening to me (being one of the chairs of ICCRG) - very sorry, everyone! Here's a fix, using the correct address for ICCRG!

Cheers,
Michael

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 28 May 2013 20:41:02 +1000

:)

We're planning a joint session with Transport area folks in Berlin, to discuss things just like this; ICCRG folks are of course welcome to come along.

Cheers,

--
Mark Nottingham   http://www.mnot.net/