Subject: Re: p1: Upgrade ordering (possible HTTP/2 impact)

From: Salvatore Loreto <[email-masked]>
Date: Wed, 8 May 2013 08:29:59 +0300

On 4/20/13 7:07 AM, Mark Nottingham wrote:
> p1 section 6.7 defines the Upgrade header, but no where does it say anything about relative preference.
>
> Should we define (or at least allow) for the ordering to be semantically significant? It seems to me that if we end up using this, and there are a few different variants of HTTP/2 (e.g., "normal" vs "mobile"), it'd be nice to rely on ordering here.
Mark
do you foresee the possibility HTTP/2 will be (or behave) differently 
or  it is just an example?

/Sal

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 8 May 2013 19:32:23 +1000

Not sure I understand the question; The Upgrade header likely won't be valid in HTTP/2...

On 08/05/2013, at 3:29 PM, Salvatore Loreto <[email-masked]> wrote:

> do you foresee the possibility HTTP/2 will be (or behave) differently or  it is just an example?
> 
> /Sal
> 
> 

--
Mark Nottingham   http://www.mnot.net/