Subject: http/2 test framework

From: William Chan (陈智昌) <[email-masked]>
Date: Sun, 12 May 2013 18:56:32 -0300

I know we talked about this at the last interim meeting, but as far as I
know, nothing has happened on this front. Has anyone started on this yet?
I'd love to see us make progress on this front. I also think that this will
help clarify corners of the spec, since everytime we raise an ambiguity, we
really oughta write a test for it.

Here are my rough thoughts here:
* Again, host all code/configuration on github, probably in the http2
organization again
* Run a http2 test server in EC2. Host client test on it
* Have code for a server test. Uses a test client and a set of test pages.
Servers must host the pages at well defined paths.
* Um, think something up for proxies. Not hard, but I'm running outta time
here.

Mostly, I want to get people thinking about this and wanted to see who's
interested in working on this. I actually don't want to work on it since as
many people know, I'm technically part-time (20%) employed now
hacking/traveling. But if no one steps up to contribute here, I will
probably do so. That would be terrible because I'm busy traveling most of
the time, and if people left it up to me, I would write everything in Go
just to learn it. I know Mark has some basic SPDY code in Python that would
be a good foundation for this work.

So yeah, let's get started on this testing thing. I think it's important.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 13 May 2013 12:07:15 +1000

+1. I've been waiting for the spec to settle down a bit before beginning this; however, I'd like to start by (or at least near) the SF F2F.

On 13/05/2013, at 7:56 AM, William Chan (陈智昌) <[email-masked]> wrote:

> I know we talked about this at the last interim meeting, but as far as I know, nothing has happened on this front. Has anyone started on this yet? I'd love to see us make progress on this front. I also think that this will help clarify corners of the spec, since everytime we raise an ambiguity, we really oughta write a test for it.
> 
> * Again, host all code/configuration on github, probably in the http2 organization again
> * Have code for a server test. Uses a test client and a set of test pages. Servers must host the pages at well defined paths.
> * Um, think something up for proxies. Not hard, but I'm running outta time here.
> 
> Mostly, I want to get people thinking about this and wanted to see who's interested in working on this. I actually don't want to work on it since as many people know, I'm technically part-time (20%) employed now hacking/traveling. But if no one steps up to contribute here, I will probably do so. That would be terrible because I'm busy traveling most of the time, and if people left it up to me, I would write everything in Go just to learn it. I know Mark has some basic SPDY code in Python that would be a good foundation for this work.
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Sun, 12 May 2013 19:54:13 -0700

Definitely interested in helping out on this also. Will have to see
what the schedule and plan is in late June, however.