Subject: "Magic" string

From: Mark Nottingham <[email-masked]>
Date: Mon, 20 May 2013 13:22:16 +1000

We've currently incorporated the magic as:

> The client connection header is a sequence of 25 octets (in hex notation)
> 
> 464f4f202a20485454502f322e300d0a0d0a4241520d0a0d0a
> (the string FOO * HTTP/2.0\r\n\r\nBAR\r\n\r\n) followed by a SETTINGS frame (Section 3.8.4). 

That string was based upon the quick testing I did a while back. 

I'm curious to know how people feel about this; while it's cosmetic, do we want to do something a little more... expected, like:

START * HTTP/2.0\r\n\r\nGO\r\n\r\n

?

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 May 2013 10:05:40 -0700

> START * HTTP/2.0\r\n\r\nGO\r\n\r\n

I don't care.  Existence > colour for this particular bike shed.

But I do know that 5 characters isn't going to fly.  I know at least
one (major) implementation that only expects 3 or 4 characters before
the space.

---

From: Roberto Peon <[email-masked]>
Date: Mon, 20 May 2013 11:52:18 -0700

For this bike shed, the shorter while still being effective, the better.

-=R

On Mon, May 20, 2013 at 10:05 AM, Martin Thomson
<[email-masked]>wrote:

> > I'm curious to know how people feel about this; while it's cosmetic, do
> we want to do something a little more... expected, like:
> >

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 21 May 2013 07:43:14 +1000

Let's task the editors as painters in this particular case, then.

On 21/05/2013, at 4:52 AM, Roberto Peon <[email-masked]> wrote:

> On Mon, May 20, 2013 at 10:05 AM, Martin Thomson <[email-masked]> wrote: