Subject: Re: p1: Upgrade ordering (possible HTTP/2 impact)

From: "Peter Occil" <[email-masked]>
Date: Tue, 14 May 2013 21:17:02 -0400

I suggest the following change, since otherwise it could be understood that the server may return the protocols in any
order instead of in order of relative preference in a 101 response:

"A server MUST send an Upgrade header field in 101 
(Switching Protocols) responses to indicate which 
protocol(s) are being switched to, in order of relative preference,
and MUST send it in 426 (Upgrade Required) responses [etc]."

--Peter

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 17 May 2013 13:15:47 +1000

Makes sense; I recorded that in the ticket.

Thanks,

--
Mark Nottingham   http://www.mnot.net/

---

From: "Peter Occil" <[email-masked]>
Date: Fri, 17 May 2013 00:20:29 -0400

Thank you! (Forgot to send it to the mailing list too.)

--Peter

-----Original Message----- 
From: Mark Nottingham
Sent: Thursday, May 16, 2013 11:15 PM
To: Peter Occil
Cc: [email-masked]
Subject: Re: p1: Upgrade ordering (possible HTTP/2 impact)

Thanks,

On 15/05/2013, at 11:17 AM, Peter Occil <[email-masked]> wrote:

> I suggest the following change, since otherwise it could be understood 
> that the server may return the protocols in any

---

From: "Peter Occil" <[email-masked]>
Date: Fri, 17 May 2013 00:25:28 -0400

One more thing:  The phrase "order of relative preference" is ambiguous; 
does it mean an ascending order or a descending order?
I prefer a descending order, myself, but it's up to you.

--Peter

-----Original Message----- 
From: Mark Nottingham
Sent: Thursday, May 16, 2013 11:15 PM
To: Peter Occil
Cc: [email-masked]
Subject: Re: p1: Upgrade ordering (possible HTTP/2 impact)

Thanks,

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 17 May 2013 14:47:21 +1000

Left a note in the ticket about that, thanks again.

On 17/05/2013, at 2:25 PM, Peter Occil <[email-masked]> wrote:

> One more thing:  The phrase "order of relative preference" is ambiguous; does it mean an ascending order or a descending order?
> -----Original Message----- From: Mark Nottingham