Subject: Re: WGLC: SHOULD and conformance

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 May 2013 15:15:52 +1000

Assigned for -23.

On 30/04/2013, at 6:52 PM, Mark Nottingham <[email-masked]> wrote:

> That works for me too.
> 
> On 30/04/2013, at 6:13 PM, Roy T. Fielding <[email-masked]> wrote:
> 
>> I don't believe that suggested text is consistent with RFC2119.
>> 
>> In fact, the existing second sentence is just wrong (there is no
>> need for documented exceptions), so let's just delete it.
>> The existing first sentence is fine.
>> 
>> ....Roy
>> 
>> On Apr 29, 2013, at 7:25 PM, Mark Nottingham wrote:
>> 
>>> Up until now, we've had this to say about the status of SHOULDs regarding conformance (p1, "Conformance and Error Handling):
>>> 
>>>> An implementation is considered conformant if it complies with all of the requirements associated with the roles it partakes in HTTP. Note that SHOULD-level requirements are relevant here, unless one of the documented exceptions is applicable.
>>> 
>>> After reviewing the specs (and taking in account the misused SHOULDs and those I think should be stronger, see previous messages), I believe that ALL of the remaining SHOULDs in the set are NOT relevant to conformance, but instead  represent implementation guidance. 
>>> 
>>> So, I propose we change the text above in p1 to:
>>> 
>>> """
>>> An implementation is considered conformant if it complies with all of the MUST-level requirements associated with the roles it partakes in HTTP. Note that SHOULD-level requirements are relevant to conformance, but do not formally impact it; instead, they represent implementation guidance.
>>> """
>>> 
>>> Thoughts?
>>> 
>>> --
>>> Mark Nottingham   http://www.mnot.net/
>>> 
>>> 
>>> 
>>> 
>> 
> 
> --
> Mark Nottingham   http://www.mnot.net/
> 
> 
> 
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: "Roy T. Fielding" <[email-masked]>
Date: Sun, 19 May 2013 13:10:55 -0700

Fixed in

http://trac.tools.ietf.org/wg/httpbis/trac/changeset/2259

....Roy