Subject: ADMIN: Discussion on Github issues

From: Mark Nottingham <[email-masked]>
Date: Thu, 27 Jun 2013 16:11:47 +1000

One of the problems with using Github for issue tracking is that it's proven *too* easy to comment upon an issue -- easier than taking the discussion to the mailing list, where it should be.

We've tried to address this in the past by asking people to move discussions to the list as they became substantial, but that doesn't appear to be working.

So, from now onwards, a few rules:

* Discussion on issues that are NOT tagged "editorial" will not be tolerated. This will be strictly enforced. If you see such discussion, please firmly ask for it to be moved to the mailing list. The only exception is for the editors to track the state of the issue's incorporation.

* Discussion on issues that are tagged "editorial" is allowed, but if it becomes substantial (i.e., more than editorial), must be moved to the list.

* When a non-editorial issue is discussed on-list, the Subject should indicate the issue number; e.g.,

  Subject: [#999] How Useless is the Foo Frame?

If you're starting such a discussion, it's friendly to provide a link to the issue in the message body.

I've updated the repository READMEs (since we now have two; one for HTTP2, one for compression) to reflect this.

Thanks,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 27 Jun 2013 17:25:41 +1000

On 27/06/2013, at 5:24 PM, Julian Reschke <[email-masked]> wrote:
> 
> It would be great if we could disambiguate them from Trac issues. Maybe
> 
> [#g999]

If people remember to do this, yes. I'm hoping that we won't have trac issues to discuss in the very near future :-)

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Thu, 27 Jun 2013 09:24:30 +0200

On 2013-06-27 08:11, Mark Nottingham wrote:
> ...

  [#g999]

?