Subject: #448, was: p2: Accept-Language missing, empty or no match

From: Julian Reschke <[email-masked]>
Date: Sun, 09 Jun 2013 18:41:45 +0200

I agree with Björn's comment, but replacing the MAY by SHOULD doesn't 
seem to be an improvement.

The proposal in the ticket is:

"A request without any Accept-Language header field implies that the 
user agent will accept any language in response. If an Accept-Language 
header field is present in a request and none of the available 
representations for the response have a language tag that is listed as 
acceptable, the origin server SHOULD either disregard the 
Accept-Language header field by treating the response as if it is not 
subject to content negotiation, or honor the Accept-Language header 
field by sending a 406 (Not Acceptable) response. However, the latter is 
not encouraged, as doing so can prevent users from accessing content 
that they might be able to use (with translation software, for example)."

The SHOULD doesn't make sense unless there's something else the client 
could conceivably do.

Can we just make the "SHOULD" a "can"?

Best regards, Julian

On 2013-05-07 07:14, Mark Nottingham wrote:
> Proposal updated in ticked and marked for -23.
>
> <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/448#comment:4>
>
> Thanks,
>
>
> On 01/05/2013, at 10:35 AM, Bjoern Hoehrmann <[email-masked]> wrote:
>
>> * Mark Nottingham wrote:
>>> Good point.
>>>
>>> how about:
>>>
>>> """
>>> A request without any Accept-Language header field implies that the user
>>> agent will accept any language in response. If an Accept-Language header
>>> field is present in a request and none of the available representations
>>> for the response have a language tag that is listed as acceptable, the
>>> origin server MAY either disregard the Accept header field by treating
>>> the response as if it is not subject to content negotiation, or honor
>>> the Accept header field by sending a 406 (Not Acceptable) response.
>>> However, the latter is not encouraged, as doing so can prevent users
>>> from accessing content that they might be able to use (with translation
>>> software, for example).
>>> """
>>
>> Two cases of s/Accept/Accept-Language/. "MAY either ... or ..." is bad
>> usage of RFC 2119 terms. And I don't like the implication that sending
>> anything other than 406 is "not honoring" the Accept-Language header.
>> But this is close enough to say "works for me".
>>
>> Thanks,
>> --
>> Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
>> Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
>> 25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/
>>
>
> --
> Mark Nottingham   http://www.mnot.net/
>
>
>
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 10 Jun 2013 09:59:46 +0900

WFM, although I note that we're not being very consistent in how we use language. (shrug)

On 10/06/2013, at 1:41 AM, Julian Reschke <[email-masked]> wrote:

> I agree with Björn's comment, but replacing the MAY by SHOULD doesn't seem to be an improvement.
> 
> "A request without any Accept-Language header field implies that the user agent will accept any language in response. If an Accept-Language header field is present in a request and none of the available representations for the response have a language tag that is listed as acceptable, the origin server SHOULD either disregard the Accept-Language header field by treating the response as if it is not subject to content negotiation, or honor the Accept-Language header field by sending a 406 (Not Acceptable) response. However, the latter is not encouraged, as doing so can prevent users from accessing content that they might be able to use (with translation software, for example)."
> 
> The SHOULD doesn't make sense unless there's something else the client could conceivably do.
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 10 Jun 2013 08:40:51 +0200

> WFM, although I note that we're not being very consistent in how we use language. (shrug)

Indeed; in the other cases we say "MAY". So my preference would be to 
change all of them to "can" (preferred), or to make this one a MAY.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 10 Jun 2013 16:08:47 +0900

Again, WFM.

On 10/06/2013, at 3:40 PM, Julian Reschke <[email-masked]> wrote:

> Indeed; in the other cases we say "MAY". So my preference would be to change all of them to "can" (preferred), or to make this one a MAY.
> 
> Best regards, Julian
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 12 Jun 2013 10:27:51 +0200

> Again, WFM.

Done in <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/2291>.

Best regards, Julian