Subject: Outcomes of the SF Interim Meeting

From: Mark Nottingham <[email-masked]>
Date: Wed, 26 Jun 2013 16:25:22 +1000

For those who couldn't make it to the SF Interim, we had a very productive meeting. 

There were many decisions made regarding the issues; for complete information, please take a look at the minutes:
  https://github.com/http2/wg_materials/blob/master/interim-13-06/minutes.md
  
... and the notes on individual issues in the issues list:
   https://github.com/http2/http2-spec/issues?milestone=&page=1&state=open

Two things are worth special notice:

1) We decided to use the joint proposal for header compression as a starting point going forward:
  http://tools.ietf.org/id/draft-ruellan-http-header-compression-00.txt

This will be published as a separate WG draft shortly.

2) We created a Layering Task Force to re-arrange the specification and make its structure more apparent.

The Layering TF should conclude shortly, recommending a rewritten spec to the WG. Once they do, we need to confirm that, incorporate any remaining issues, and publish a new draft.

That draft will be the one that we are targeting for our "First Implementation Draft", and that we'll (with luck and hard work) have implementations of going into Hamburg.

See the list of issues assigned for that milestone here:
  https://github.com/http2/http2-spec/issues?milestone=1&page=1&state=open

If you have questions or concerns about any of these decisions, please do bring them up on the list ASAP.

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Jun 2013 11:34:32 -0700

The Layering TF met yesterday to discuss a few things.

At this stage, we don't have proposals that address the HTTP mapping,
but James has promised progress on those this week.

For now, I've put a reorganized draft up here for early review:
  http://http2.github.io/http2-spec/layering.html

Expect the HTTP sections to be improved a little as James' work is
integrated.  The framing and streams sections are reasonably complete,
modulo the usual editorial hiccups.

Since the changes are big, I'm going to defer acceptance of any pull
requests until we conclude this work, which should be done early next
week.