Subject: Re: Preliminary agenda for the SF Interim

From: William Chan (陈智昌) <[email-masked]>
Date: Tue, 4 Jun 2013 11:11:00 -0700

I feel like we still have some open questions around stream lifetimes. If
we do not have consensus here yet, I think it'd be advisable to pencil in
time on the agenda to discuss this.

On Mon, May 20, 2013 at 9:30 AM, James M Snell <[email-masked]> wrote:

> On Sun, May 19, 2013 at 8:54 PM, Mark Nottingham <[email-masked]> wrote:
> > As you can probably guess, we haven't been able to get implementations
> moving before this Interim, but I'd very much like to exit it being able to
> get there quickly.
> >
> > With that in mind, I've asked the editors to publish a draft -03 by
> early next week, to give everyone enough time to review the draft.
> >
> > Likewise, I've asked Herve and Roberto to get their header proposal(s)
> lined up and ready for discussion at the F2F.
> >
>
> While I wasn't asked to have it "lined up and ready for discussion",
> the current bohe header proposal will be updated one more time before
> the F2F and will be ready for discussion. Specifically, the typed
> codecs portion is pretty much done and ready to go.
>
> > Please come into the meeting having read ALL of those documents
> carefully (once updated), as well as the issues list <
> https://github.com/http2/http2-spec/issues>.
> >
> > If there are particular issues that you believe are important to get
> sorted out for the first implementation draft, please bring them up on-list
> BEFORE the meeting, so that we can make that time as productive as
> possible. The current list of such issues is <
> https://github.com/http2/http2-spec/issues?milestone=1&page=1&state=open>
> >
> > A _rough_ agenda for discussion:
> >
> > * Administrivia
> >    - Blue sheets
> >    - Introductions
> >    - Scribe Selection
> >    - Agenda Bashing
> >    - NOTE WELL
> >    - Ground rules for the meeting
> > * Document review [editors]
> >   - Open editors' questions
> > * Header compression
> > * Server push walkthrough
> >    * PUSH_PROMISE
> > * Flow Control overview
> > * Prioritisation review
> > * Upgrade / negotiation
> > * Other issue discussion
> >[snip]
>
> Frame sizing, Unknown frame handling (clarification of must-ignore
> rule), and max concurrent streams ought to be included as well.
>
> - James
>
>

---

From: William Chan (陈智昌) <[email-masked]>
Date: Tue, 4 Jun 2013 13:00:54 -0700

NM, I see that
https://github.com/http2/wg_materials/blob/master/interim-13-06/agenda.mdis
significantly updated and fairly well fleshed out. It includes several
stream lifecycle issues, so I think this is sufficiently covered in the
agenda. If you do not already ignore all my emails, feel free to ignore
these emails on this thread.