Subject: Fwd: IPR Disclosure: Microsoft Corporation's Statement about IPR related to draft-ietf-httpbis-http2-04

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Jul 2013 15:17:18 +1000

FYI - Microsoft has made a patent disclosure and nominated licensing terms, as per the link below.

If anyone else has a patent in the works, or is aware of IPR that is relevant, it's appropriate to disclose (and in some circumstances, is required).

Regards,

Begin forwarded message:

> From: IETF Secretariat <[email-masked]>
> Subject: IPR Disclosure: Microsoft Corporation's Statement about IPR related to draft-ietf-httpbis-http2-04
> Date: 10 July 2013 3:20:27 AM AEST
> To: [email-masked], [email-masked], [email-masked], [email-masked]
> Cc: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> 
> 
> Dear Mike Belshe, Roberto Peon, Martin Thomson, Alexey Melnikov:
> 
> An IPR disclosure that pertains to your Internet-Draft entitled "Hypertext
> Transfer Protocol version 2.0" (draft-ietf-httpbis-http2) was submitted to the
> IETF Secretariat on 2013-07-09 and has been posted on the "IETF Page of
> Intellectual Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/2122/). The title of the IPR disclosure is
> "Microsoft Corporation's Statement about IPR related to draft-ietf-httpbis-
> http2-04."");
> 
> The IETF Secretariat
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: "Adrien W. de Croy" <[email-masked]>
Date: Wed, 10 Jul 2013 09:58:45 +0000

That link seems to be missing the patent disclosure, and only contains 
some proposed licensing terms for something which is not specified. Is 
that intentionally omitted, or will that information be following?

Regards

Adrien

------ Original Message ------
From: "Mark Nottingham" <[email-masked]>
To: "HTTP Working Group" <[email-masked]>
Sent: 10/07/2013 5:17:18 p.m.
Subject: Fwd: IPR Disclosure: Microsoft Corporation's Statement about 
IPR related to draft-ietf-httpbis-http2-04
>If anyone else has a patent in the works, or is aware of IPR that is 
>relevant, it's appropriate to disclose (and in some circumstances, is 
>required).
>
>Regards,
>
>
>
>Begin forwarded message:
>
>>  Cc: [email-masked], [email-masked], 
>>[email-masked], [email-masked], [email-masked]
>>
>>

---

From: Mike Belshe <[email-masked]>
Date: Wed, 10 Jul 2013 09:02:45 -0700

No, this is standard.  The lawyers are saying, "we're not sure if you do
infringe on any of our IP, but if you do, we license it to you under these
terms."

The Google IPR is effectively the same, although a little easier for mere
mortals (e.g. non-lawyers) to read.  Google references yet-unpublished
patents, but licenses them anyway.

Google's disclosure:  https://datatracker.ietf.org/ipr/1692/

Also, in the prior disclosure from Microsoft, they did reference two
patents.  https://datatracker.ietf.org/ipr/1737/  I do not know if HTTP/2
overlaps with these patents.

Be grateful they are licensing it to all of us, even if you don't like the
process.  The terms are ok.

On Wed, Jul 10, 2013 at 2:58 AM, Adrien W. de Croy <[email-masked]> wrote:

> some proposed licensing terms for something which is not specified. Is that
> intentionally omitted, or will that information be following?
>
> Regards
>
> Adrien
>
>
>
> Subject: Fwd: IPR Disclosure: Microsoft Corporation's Statement about IPR
> related to draft-ietf-httpbis-http2-04
>
>>>  Cc: [email-masked], [email-masked], [email-masked],
>>> [email-masked], [email-masked]
>>>
>>>
>>>  (https://datatracker.ietf.org/**ipr/2122/<https://datatracker.ietf.org/ipr/2122/>).
>>> The title of the IPR disclosure is

---

From: cowwoc <[email-masked]>
Date: Wed, 10 Jul 2013 12:35:27 -0400

It would help if the document (template) actually explained exactly 
what you said.

Gili

On 10/07/2013 12:02 PM, Mike Belshe wrote:
> No, this is standard.  The lawyers are saying, "we're not sure if you 
> do infringe on any of our IP, but if you do, we license it to you 
> under these terms."
>
> The Google IPR is effectively the same, although a little easier for 
> mere mortals (e.g. non-lawyers) to read.  Google references 
> yet-unpublished patents, but licenses them anyway.
>
> patents. https://datatracker.ietf.org/ipr/1737/  I do not know if 
> HTTP/2 overlaps with these patents.
>
> Be grateful they are licensing it to all of us, even if you don't like 
> the process.  The terms are ok.
>
>
>
> On Wed, Jul 10, 2013 at 2:58 AM, Adrien W. de Croy <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>     That link seems to be missing the patent disclosure, and only
>     contains some proposed licensing terms for something which is not
>     specified. Is that intentionally omitted, or will that information
>     be following?
>
>     Regards
>
>     Adrien
>
>
>
>     From: "Mark Nottingham" <[email-masked] <mailto:[email-masked]>>
>     To: "HTTP Working Group" <[email-masked]
>     <mailto:[email-masked]>>
>     Subject: Fwd: IPR Disclosure: Microsoft Corporation's Statement
>     about IPR related to draft-ietf-httpbis-http2-04
>
>         If anyone else has a patent in the works, or is aware of IPR
>         that is relevant, it's appropriate to disclose (and in some
>         circumstances, is required).
>
>         Regards,
>
>
>
>         Begin forwarded message:
>
>              From: IETF Secretariat <[email-masked]
>             <mailto:[email-masked]>>
>              Subject: IPR Disclosure: Microsoft Corporation's
>             Statement about IPR related to draft-ietf-httpbis-http2-04
>              To: [email-masked] <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>,
>             [email-masked]
>             <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>
>              Cc: [email-masked]
>             <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>,
>             [email-masked] <mailto:[email-masked]>
>
>