Subject: #303: Generic semantics for the 400 status code (also #302)

From: Julian Reschke <[email-masked]>
Date: Sun, 28 Jul 2013 11:45:09 +0200

On 2012-02-06 09:24, Julian Reschke wrote:
> On 2012-02-05 22:21, Mark Nottingham wrote:
>> Works for me.
>
> -> <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/1526>

So in draft -21 it read:

"The server cannot or will not process the request, due to a client 
error (e.g., malformed syntax)." -- 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-21.html#rfc.section.7.5.1>

In draft -22 this was changed to

"The 400 (Bad Request) status code indicates that the server cannot or 
will not process the request because the received syntax is invalid, 
nonsensical, or exceeds some limitation on what the server is willing to 
process." -- 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-22.html#rfc.section.6.5.1>

I'll change that to

""The 400 (Bad Request) status code indicates that the server cannot or 
will not process the request, due to a client error (e.g., malformed 
syntax)."

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 28 Jul 2013 11:50:11 +0200

WFM. Thanks,

On Jul 28, 2013, at 11:45 AM, Julian Reschke <[email-masked]> wrote:

> "The server cannot or will not process the request, due to a client error (e.g., malformed syntax)." -- <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-21.html#rfc.section.7.5.1>
> 
> "The 400 (Bad Request) status code indicates that the server cannot or will not process the request because the received syntax is invalid, nonsensical, or exceeds some limitation on what the server is willing to process." -- <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-22.html#rfc.section.6.5.1>
> 
> I'll change that to
> 
> ""The 400 (Bad Request) status code indicates that the server cannot or will not process the request, due to a client error (e.g., malformed syntax)."
> 
> Best regards, Julian
> 
> 

--
Mark Nottingham   http://www.mnot.net/