Subject: SETTINGS_MAX_BUFFER_SIZE in SETTINGS Frame?

From: "Kulkarni, Saurabh" <[email-masked]>
Date: Tue, 23 Jul 2013 20:01:10 -0500

The HTTP2-04 draft doesn't specify SETTINGS frame with setting for SETTINGS_MAX_BUFFER_SIZE, altho header-compression draft-01 requires this to set the max buffer size.

 1.  Is there a SETTINGS frame with SETTINGS_MAX_BUFFER_SIZE?
 2.  Is SETTINGS_MAX_BUFFER_SIZE passed in an HEADERS frame with stream_id of 0 (this is supposed to be flagged as PROTOCOL_ERROR as per the draft)?

Please clarify? Thanks.

- Saurabh

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Jul 2013 20:49:57 -0700

On 23 July 2013 18:01, Kulkarni, Saurabh <[email-masked]> wrote:
> Is there a SETTINGS frame with SETTINGS_MAX_BUFFER_SIZE?

In -04, no.  We decided not to allow this to be configurable because
it requires that any configuration change be acknowledged and a
settings acknowledgement feature hasn't been developed yet.  The
default value is the only value permitted.

> Is SETTINGS_MAX_BUFFER_SIZE passed in an HEADERS frame with stream_id of 0
> (this is supposed to be flagged as PROTOCOL_ERROR as per the draft)?

See above.