Subject: HTTP-draft-04/2.0 implementation in C

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 29 Jul 2013 01:53:00 +0900

I'm working on implementing draft-04 in C based on spdylay[1] library.
The code is open sourced and hosted at:
https://github.com/tatsuhiro-t/nghttp2
It currently lacks header continuation, ALPN and HTTP Upgrade but other
components work. For TLS, we use NPN instead of ALPN for now.

The project provides client, server and proxy. The client and server output
sent and received frame information, so they would be useful for
implementors to debug their implementation. The proxy can run as reverse
proxy for the existing web server and acts like SSL/TLS terminator and can
offer HTTP-draft-04/2.0, SPDY and HTTP/1.1 via NPN, so may be useful for
debugging using existing web servers/services.

[1] http://spdylay.sourceforge.net/

Best regards,

Tatsuhiro Tsujikawa

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Jul 2013 16:35:16 +0200

Thanks!

I've set up a wiki page to track implementations; other implementers, feel free to add yours.

Regards,

On Jul 28, 2013, at 6:53 PM, Tatsuhiro Tsujikawa <[email-masked]> wrote:

> It currently lacks header continuation, ALPN and HTTP Upgrade but other components work. For TLS, we use NPN instead of ALPN for now.
> 
> The project provides client, server and proxy. The client and server output sent and received frame information, so they would be useful for implementors to debug their implementation. The proxy can run as reverse proxy for the existing web server and acts like SSL/TLS terminator and can offer HTTP-draft-04/2.0, SPDY and HTTP/1.1 via NPN, so may be useful for debugging using existing web servers/services.
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Jul 2013 21:30:00 +0200

Sorry, I left the link out:
  https://github.com/http2/http2-spec/wiki/Implementations

Cheers,

---

From: <[email-masked]>
Date: Tue, 30 Jul 2013 08:34:46 +0000

Hi Mark,

I'm writing a prototype of a client and a server which supports 'in the clear' and over TLS. 
I will complete the wiki during the week.

Regards
Emile

-----Message d'origine-----
De : Mark Nottingham [mailto:[email-masked]] 
Envoyé : lundi 29 juillet 2013 21:30
À : Tatsuhiro Tsujikawa
Cc : [email-masked]
Objet : Re: Tracking implementations

Cheers,

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.