Subject: draft-ietf-httpbis-p2-semantics-23, "6.3.6 205 Reset Content"

From: Julian Reschke <[email-masked]>
Date: Thu, 25 Jul 2013 08:29:43 +0200

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p2-semantics-23.html#status.205>:

"Since the 205 status code implies that no additional content will be 
provided in the payload, the server MUST send a message body of zero 
length. In other words, the server MUST send a "Content-Length: 0" field 
in a 205 response or close the connection immediately after sending the 
blank line terminating the header section."

So would using Chunked Encoding be illegal? I don't think that was the 
intent.

The simplest possible fix seems to drop the second sentence.

Best regards, Julian

Origin: user npcode in 
<http://stackoverflow.com/questions/17826572/which-http-and-webdav-status-must-not-include-message-body/17827503?noredirect=1#comment26054009_17827503>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 25 Jul 2013 12:30:05 +0200

> <http://stackoverflow.com/questions/17826572/which-http-and-webdav-status-must-not-include-message-body/17827503?noredirect=1#comment26054009_17827503>

Now <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/491>.

---

From: "Roy T. Fielding" <[email-masked]>
Date: Thu, 25 Jul 2013 10:39:08 -0700

Yes, that was the intent. More specifically, generating chunked when there is no need to do so was considered far less interoperable than simply requiring C-L. We were able to make this a requirement because 205 was defined by the WG before any deployment.

....Roy

On Jul 24, 2013, at 11:29 PM, Julian Reschke <[email-masked]> wrote:

> "Since the 205 status code implies that no additional content will be provided in the payload, the server MUST send a message body of zero length. In other words, the server MUST send a "Content-Length: 0" field in a 205 response or close the connection immediately after sending the blank line terminating the header section."
> 
> So would using Chunked Encoding be illegal? I don't think that was the intent.
> 
> Origin: user npcode in <http://stackoverflow.com/questions/17826572/which-http-and-webdav-status-must-not-include-message-body/17827503?noredirect=1#comment26054009_17827503>
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 25 Jul 2013 19:54:53 +0200

On 2013-07-25 19:39, Roy T. Fielding wrote:
> ...

Well, RFC 2616 was kind of silent (if not wrong) about it.

I really wonder whether we need to rule out a silly edge case using a 
MUST. *If* we do, we really should be clear about the implication on 
Chunked Encoding...

Best regards, Julian