Subject: Who implemented which version of the compression draft?

From: Fred Akalin <[email-masked]>
Date: Wed, 7 Aug 2013 19:35:24 +0200

Hey guys,

There are two versions of the compression draft: -00 and -01.
httpbis-draft-04 refers to -00, but I vaguely remember an e-mail going out
previously saying that we should work off -01. However, I forgot about that
and worked off -00.

Out of curiosity, who implemented -00 and who implemented -01? I'm asking
because there's at least one important difference (see
https://github.com/MSOpenTech/http2-katana/issues/19 ) and I'd like to know
which one to refer to to get the widest interoperability.

-- Fred

---

From: Fred Akalin <[email-masked]>
Date: Wed, 7 Aug 2013 19:37:38 +0200

Actually, that particular issue may just be a difference in wording.

I'm still curious, though, about who implemented what version.

On Wed, Aug 7, 2013 at 7:35 PM, Fred Akalin <[email-masked]> wrote:

> https://github.com/MSOpenTech/http2-katana/issues/19 ) and I'd like to
> know which one to refer to to get the widest interoperability.
>
> -- Fred
>

---

From: "Jain, Shakesh" <[email-masked]>
Date: Wed, 7 Aug 2013 12:54:55 -0500

At Akamai we implemented draft –00 (with at least one bug to fix in our implementation). I could not make it to interop so can you please share what part of the spec you are talking about?

Shakesh

On Wed, Aug 7, 2013 at 7:35 PM, Fred Akalin <[email-masked]<mailto:[email-masked]>> wrote:
Hey guys,

There are two versions of the compression draft: -00 and -01. httpbis-draft-04 refers to -00, but I vaguely remember an e-mail going out previously saying that we should work off -01. However, I forgot about that and worked off -00.

Out of curiosity, who implemented -00 and who implemented -01? I'm asking because there's at least one important difference (see https://github.com/MSOpenTech/http2-katana/issues/19 ) and I'd like to know which one to refer to to get the widest interoperability.

-- Fred

---

From: Fred Akalin <[email-masked]>
Date: Wed, 7 Aug 2013 19:59:37 +0200

The spec text I mentioned is discussed in
https://github.com/MSOpenTech/http2-katana/issues/19 .

On Wed, Aug 7, 2013 at 7:54 PM, Jain, Shakesh <[email-masked]> wrote:

> At Akamai we implemented draft –00 (with at least one bug to fix in our
> implementation). I could not make it to interop so can you please share
> what part of the spec you are talking about?
>
> Shakesh
>
>
>

---

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Wed, 7 Aug 2013 22:11:41 +0000

MS OpenTech (Katana) implemented -01.

Fred, here’s the link to related emails on the list - http://lists.w3.org/Archives/Public/ietf-http-wg/2013JulSep/0440.html and earlier  http://lists.w3.org/Archives/Public/ietf-http-wg/2013JulSep/0256.html

Which suggests that it could be helpful to merge the compression draft into the http/2 draft? - https://github.com/http2/http2-spec/issues/224

…Brian

Brian Raymor
Senior Program Manager
Microsoft Open Technologies, Inc.
A subsidiary of Microsoft Corporation

From: Fred Akalin [mailto:[email-masked]]
Sent: Wednesday, August 7, 2013 11:00 AM

The spec text I mentioned is discussed in https://github.com/MSOpenTech/http2-katana/issues/19 .

On Wed, Aug 7, 2013 at 7:54 PM, Jain, Shakesh <[email-masked]<mailto:[email-masked]>> wrote:

Shakesh

-- Fred

---

From: Amos Jeffries <[email-masked]>
Date: Thu, 08 Aug 2013 15:39:07 +1200

On 8/08/2013 10:11 a.m., Brian Raymor (MS OPEN TECH) wrote:
> Fred, here’s the link to related emails on the list - 
> http://lists.w3.org/Archives/Public/ietf-http-wg/2013JulSep/0440.html 
> and earlier 
> http://lists.w3.org/Archives/Public/ietf-http-wg/2013JulSep/0256.html
>
> Which suggests that it could be helpful to merge the compression draft 
> into the http/2 draft? - https://github.com/http2/http2-spec/issues/224
>

But not if we are still at odds about even whether this particular 
compression is the true way forward. There is still a lot of memory 
hungry statefulness and processing overheads being placed on middleware 
simply to multiplex the streams between client and server connections. I 
have mentioned the mandatory compression/decompression as being the 
worst hurdle already.

I have been thinking we should have been adding a compression indicator 
to the declared version string. At least during the experimentation 
period so we can identify http2-draft-04-z00 from http2-draft-04-z01 
from http2-draft-04-b03 from http2-draft-04-b04 or whatever.

Amos

> *From:*Fred Akalin [mailto:[email-masked]]
> *Sent:* Wednesday, August 7, 2013 11:00 AM
>
>     At Akamai we implemented draft –00 (with at least one bug to fix
>     in our implementation). I could not make it to interop so can you
>     please share what part of the spec you are talking about?
>
>     Shakesh
>
>             There are two versions of the compression draft: -00 and
>             -01. httpbis-draft-04 refers to -00, but I vaguely
>             remember an e-mail going out previously saying that we
>             should work off -01. However, I forgot about that and
>             worked off -00.
>
>             Out of curiosity, who implemented -00 and who implemented
>             -01? I'm asking because there's at least one important
>             difference (see
>             https://github.com/MSOpenTech/http2-katana/issues/19 ) and
>             I'd like to know which one to refer to to get the widest
>             interoperability.
>
>             -- Fred
>