Subject: RLE for header compression opcodes

From: Martin Thomson <[email-masked]>
Date: Sun, 25 Aug 2013 10:43:13 -0700

James,

I notice that your draft uses run length encoding (up to 64 at a time)
for the header compression opcodes.  Do you have any information on
what that specific change might save?

--Martin

---

From: James M Snell <[email-masked]>
Date: Sun, 25 Aug 2013 11:00:09 -0700

Generally just saves a single byte per header when it's used. Also, given
that I use single octets for the table indices we have to use rle to
determine how many index encodings we have.