Subject: Re: Rough agenda for Vancouver

From: Mark Nottingham <[email-masked]>
Date: Mon, 21 Oct 2013 20:26:46 +1100

The agenda I've currently got is pasted below.

As always, suggestions welcome.

If folks have contributions they'd like to make -- especially in the "Encryption and HTTP/2" and "other privacy-related discussions" portions -- please get in touch ASAP.

Regards,

---8<---

# HTTPbis Working Group Agenda - IETF 88

* Meeting chat: <xmpp:[email-masked]?join>
* Minutes: <http://tools.ietf.org/wg/httpbis/minutes>

## MON 4 November 2013 - Afternoon Session III

### HTTP/1 and HTTP/2

Regency A

*   1 min - Blue sheets / scribe selection 
*   4 min - Agenda bashing
*  40 min - HTTP/1.x
            - IETF LC summary
            - Issue discussion (exact issues TBD)
*  75 min - HTTP/2.x
            - Seattle Interim meeting summary
            - Implementation Status summary
            - Draft changes and open questions [Martin Thomson]
            - Issue discussion (exact issues TBD)

## TUE 5 November 2013 - Morning Session I

### Security Area Joint Meeting

Georgia A

*   1 min - Blue sheets / scribe selection
*   4 min - Agenda bashing
*  25 min - ALPN review
*  30 min - HPACK review
            (focus on CRIME)
*  60 min - Encryption and HTTP/2
*  30 min - Other privacy-related discussions

--->8---

--
Mark Nottingham   http://www.mnot.net/

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 21 Oct 2013 13:44:06 +0000

Hi Mark,

the Proxy topic is missing on the current agenda.

I would suggest to dedicate a 15/20minutes to talk about Proxy in 2.0
and how the proxy features present in HTTP 1.1 will be mapped in 2.0
for the 2.0 plain scenario but not only for it,
This topic seems to fit in the first day slot

There has been also some discussions/proposals about room for secured/trusted
proxy, this should be more for the second day slot

best regards
Salvatore

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 31 Oct 2013 15:25:48 +1100

Hi Salvatore,

> This topic seems to fit in the first day slot

I strongly suspect that we're going to be digging pretty deeply into HTTP/2's notion of proxies as a result of the security work. However, if you have specific issues where HTTP/2 as specified isn't as functional as HTTP/1 *as specified* (NOTE: interception proxies are NOT specified in HTTP/1), please bring it up on-list and we can track it.

> proxy, this should be more for the second day slot

I've broken down the encryption topic on the second day into two areas:

*  90 min - Encryption and HTTP/2
            - Optimistic Encryption
            - Accommodating Proxies

At this point, I'm inclined to put some very high-level slides together to guide the discussion, based upon all of the drafts in this area that we've seen so far (NOT present their contents; people should already have read them). 

Current list of related drafts is now on the agenda:
  http://www.ietf.org/proceedings/88/agenda/agenda-88-httpbis

Cheers,