Subject: Re: [apps-discuss] FYI: LINK and UNLINK

From: Mark Nottingham <[email-masked]>
Date: Tue, 29 Oct 2013 16:48:00 +1100

On 24/09/2013, at 5:17 AM, James M Snell <[email-masked]> wrote:

> Just a general FYI... I have submitted iteration -04 of the
> LINK/UNLINK draft with a few minor editorial fixes... and, I have
> formally requested Last Call status as an Independent Submission on
> the Standards Track.
> 
>  http://tools.ietf.org/html/draft-snell-link-method-04

In Section 2 of -05:

"For any pair of resources, exactly one relationship of any given type can exist."

That's a new and apparently backwards-incompatible change to the model of linking on the Web... e.g., consider "stylesheet".

Also, can these methods be made conditional?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Mon, 28 Oct 2013 22:59:40 -0700

On Oct 28, 2013 10:48 PM, "Mark Nottingham" <[email-masked]> wrote:
> That's a new and apparently backwards-incompatible change to the model of
linking on the Web... e.g., consider "stylesheet".

No, read it again, as a uniqueness constraint on the tuple (resource, link
relation, resource). That's not new or novel.

> Also, can these methods be made conditional?

Yes. Of course.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 29 Oct 2013 17:01:30 +1100

On 29/10/2013, at 4:59 PM, James M Snell <[email-masked]> wrote:

> No, read it again, as a uniqueness constraint on the tuple (resource, link relation, resource). That's not new or novel. 

Right. Thanks :)

> > Also, can these methods be made conditional?

Mention it in the text, then; it's not automatic. Examples would be good too.

Cheers,

---

From: James M Snell <[email-masked]>
Date: Mon, 28 Oct 2013 23:03:17 -0700

Good idea :) will do.
On Oct 28, 2013 11:01 PM, "Mark Nottingham" <[email-masked]> wrote:

> > > That's a new and apparently backwards-incompatible change to the model
> of linking on the Web... e.g., consider "stylesheet".
> > >
> >
> > No, read it again, as a uniqueness constraint on the tuple (resource,
> link relation, resource). That's not new or novel.
>
> Right. Thanks :)
>