Subject: Cacheable response codes

From: cowwoc <[email-masked]>
Date: Tue, 22 Oct 2013 18:30:48 -0400

Hi,

     I already reported a bug in the "cache" document: 
http://trac.tools.ietf.org/wg/httpbis/trac/ticket/500 but now I see a 
similar problem in the "semantics" document.

http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-24#page-48 reads:

Responses with status codes that are defined as cacheable by default 
(e.g., 200, 203, 206, 300, 301, and 410 in this specification)

     But if you go through the actual response codes, one by one, you 
will find the following are explicitly listed as cacheable: 200, 203, 
204, 300, 301, 404, 405, 410, 414, 501.

 1. Are you sure no other response codes are cacheable?
 2. Are you sure that all these response codes are cacheable?
 3. Once we agree on a final list,
    http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-24#page-48 and
    http://trac.tools.ietf.org/wg/httpbis/trac/ticket/500 need to be
    updated with this information.

     Can someone please open a bug report to track this work (I don't 
have permissions to do so)?

Thank you,
Gili

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 24 Oct 2013 10:59:09 +1100

This is a leftover from issue #432; I've reopened - 
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/432#comment:5

Thanks!

On 23/10/2013, at 9:30 AM, cowwoc <[email-masked]> wrote:

> Hi,
> 
>     I already reported a bug in the "cache" document: http://trac.tools.ietf.org/wg/httpbis/trac/ticket/500 but now I see a similar problem in the "semantics" document.
> 
> Responses with status codes that are defined as cacheable by default (e.g., 200, 203, 206, 300, 301, and 410 in this specification)
> 
>     But if you go through the actual response codes, one by one, you will find the following are explicitly listed as cacheable: 200, 203, 204, 300, 301, 404, 405, 410, 414, 501.
> 
> 	• Are you sure no other response codes are cacheable?
> 	• Are you sure that all these response codes are cacheable?
> 	• Once we agree on a final list, http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-24#page-48 and http://trac.tools.ietf.org/wg/httpbis/trac/ticket/500 need to be updated with this information.
>     Can someone please open a bug report to track this work (I don't have permissions to do so)?
> 
> Thank you,
> Gili

--
Mark Nottingham   http://www.mnot.net/