Subject: Does HTTP/2.0 client connection header include SETTINGS frame?

From: "Yi, EungJun" <[email-masked]>
Date: Sun, 20 Oct 2013 23:16:27 +0900

Hi,

In the latest HTTP/2.0 draft, section 3.2. says:

   The first HTTP/2.0 frame sent by the server is a SETTINGS [SETTINGS]
   frame (Section 6.5).  Upon receiving the 101 response, the client
   sends a connection header (Section 3.5), which includes a SETTINGS
   [SETTINGS] frame.

and section 3.5 says:

   The client connection header is a sequence of 24 octets, which in hex
   notation are:

   505249202a20485454502f322e300d0a0d0a534d0d0a0d0a

   (the string "PRI * HTTP/2.0\r\n\r\nSM\r\n\r\n") followed by a
   SETTINGS [SETTINGS] frame (Section 6.5).

I guess the the former means a connection header "includes" SETTING frame
but the latter means
a connection header "is followed by" a SETTINGS frame. Which one is correct?

Best regards, EungJun

---

From: Mike Bishop <[email-masked]>
Date: Mon, 21 Oct 2013 18:20:02 +0000

The formatting on the second could perhaps be clearer.  The client connection header consists of two elements:

·         A sequence of 24 octets (505…d0a, which is the string “PRI * HTTP/2.0….”

·         A SETTINGS frame

That is, the header is a sequence of octets followed immediately by a SETTINGS frame, so it’s equally correct to say that the header “includes” the frame and to say that the sequence of octets “is followed by” the SETTINGS frame.

From: Yi, EungJun [mailto:[email-masked]]
Sent: Sunday, October 20, 2013 7:16 AM
To: [email-masked]
Subject: Does HTTP/2.0 client connection header include SETTINGS frame?

Hi,

and section 3.5 says:

I guess the the former means a connection header "includes" SETTING frame but the latter means
a connection header "is followed by" a SETTINGS frame. Which one is correct?

Best regards, EungJun

---

From: "Yi, EungJun" <[email-masked]>
Date: Tue, 22 Oct 2013 23:59:15 +0900

Oh, it was my misunderstanding. Thank you for letting me know.

On Tue, Oct 22, 2013 at 3:20 AM, Mike Bishop
<[email-masked]>wrote:

>  The formatting on the second could perhaps be clearer.  The client
> connection header consists of two elements:****
>
> **·         **A sequence of 24 octets (505…d0a, which is the string “PRI
> * HTTP/2.0….”****
>
> **·         **A SETTINGS frame****
>
> ** **
>
> That is, the header is a sequence of octets followed immediately by a
> SETTINGS frame, so it’s equally correct to say that the header “includes”
> the frame and to say that the *sequence of octets* “is followed by” the
> SETTINGS frame.****
>
> ** **
>
> *From:* Yi, EungJun [mailto:[email-masked]]
> *Sent:* Sunday, October 20, 2013 7:16 AM
> *To:* [email-masked]
> *Subject:* Does HTTP/2.0 client connection header include SETTINGS frame?*
> ***
>
> ** **
>
> Hi,****
>
> ** **
>
> In the latest HTTP/2.0 draft, section 3.2. says:****
>
> ** **
>
>    The first HTTP/2.0 frame sent by the server is a SETTINGS [SETTINGS]***
> *
>
>    frame (Section 6.5).  Upon receiving the 101 response, the client****
>
>    sends a connection header (Section 3.5), which includes a SETTINGS****
>
>    [SETTINGS] frame.****
>
> ** **
>
> and section 3.5 says:****
>
> ** **
>
>    The client connection header is a sequence of 24 octets, which in hex**
> **
>
>    notation are:****
>
> ** **
>
>    505249202a20485454502f322e300d0a0d0a534d0d0a0d0a****
>
> ** **
>
>    (the string "PRI * HTTP/2.0\r\n\r\nSM\r\n\r\n") followed by a****
>
>    SETTINGS [SETTINGS] frame (Section 6.5).****
>
> ** **
>
> but the latter means ****
>
> a connection header "is followed by" a SETTINGS frame. Which one is
> correct?****
>
> ** **
>
> Best regards, EungJun****
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Oct 2013 08:58:52 -0700

> Oh, it was my misunderstanding. Thank you for letting me know.

I hope that https://github.com/http2/http2-spec/commit/eb1117a8e8c003e84b52263c491d6c15de5949c0
helps a little as well.

---

From: "Yi, EungJun" <[email-masked]>
Date: Thu, 24 Oct 2013 02:21:50 +0900

Thanks, The newer looks much clearer for me!

On Wed, Oct 23, 2013 at 12:58 AM, Martin Thomson
<[email-masked]>wrote:

> I hope that
> https://github.com/http2/http2-spec/commit/eb1117a8e8c003e84b52263c491d6c15de5949c0
> helps a little as well.
>