Subject: Trailer bug

From: Simon Yarde <[email-masked]>
Date: Fri, 13 Dec 2013 10:36:02 +0000

http://tools.ietf.org/html/draft-ietf-httpbis-p1-messaging-25#section-4.1.2

>  A server MUST generate an empty trailer with the chunked transfer
>  coding unless at least one of the following is true:

RFC2616:

> A server using chunked transfer-coding in a response MUST NOT use the trailer for any header fields unless at least one of the following is true:

Presumably it's nicer to use the affirmative as in RFC2616:

>  A server MUST NOT generate a trailer with the chunked transfer
>  coding unless at least one of the following is true:

than to bend to the MUST clause:

>  A server MUST generate an empty trailer with the chunked transfer
>  coding if one of the following is false:

Best Regards

Simon

---

From: Simon Yarde <[email-masked]>
Date: Fri, 13 Dec 2013 13:09:20 +0000

On reflection I can see the current wording is logically correct but it does seem to break with the established style for usage of MUST and MUST NOT — it reads like "MUST not do something".

It might be possible to preserve the intention of the wording whilst putting the MUST NOT action up-front:

-- > A server MUST NOT generate any header-fields in the trailer-part
-- > unless at least one of the following is true:

Best Regards

Simon