Subject: https://github.com/http2/http2-spec/issues/329 - Flow control window overflow

From: William Chan (陈智昌) <[email-masked]>
Date: Fri, 6 Dec 2013 11:42:43 -0800

Just making sure people see this. Two options were presented for how
to handle this:
* GOAWAY
* RST_STREAM

Hasan is in favor of GOAWAY, and FWIW I agree.

Presumably Hasan will use the FLOW_CONTROL_ERROR status code here, but I dunno.

---

From: Martin Thomson <[email-masked]>
Date: Fri, 6 Dec 2013 11:54:07 -0800

> Hasan is in favor of GOAWAY, and FWIW I agree.

I think that a stream error would potentially cause problems with
connection-level flow control if you aren't careful.  It seems better
to err on the side of caution.

> Presumably Hasan will use the FLOW_CONTROL_ERROR status code here, but I dunno.

That sounds fine, though I don't like to second-guess Hasan.  Maybe
the code he chooses will be covered in awesome.

---

From: Roberto Peon <[email-masked]>
Date: Fri, 6 Dec 2013 12:18:35 -0800

Getting flow control detectably wrong should cause the connection to be
torn down. RST_STREAM doesn't cut it.
-=R