Subject: Redundant rule? quoted-str-nf

From: Simon Yarde <[email-masked]>
Date: Fri, 13 Dec 2013 10:36:59 +0000

Seems quoted-str-nf in chunk-ext is now redundant?

-- > chunk-ext      = *( ";" chunk-ext-name [ "=" chunk-ext-val ] )
-- >
-- > chunk-ext-name = token
-- > chunk-ext-val  = token / quoted-str-nf
-- >
-- > quoted-str-nf  = DQUOTE *( qdtext-nf / quoted-pair ) DQUOTE
-- >                ; like quoted-string, but disallowing line folding
-- > qdtext-nf      = HTAB / SP / %x21 / %x23-5B / %x5D-7E / obs-text

-- > quoted-string  = DQUOTE *( qdtext / quoted-pair ) DQUOTE
-- > qdtext         = HTAB / SP /%x21 / %x23-5B / %x5D-7E / obs-text
-- > obs-text       = %x80-FF

chunk-ext could be simplified to:

-- > chunk-ext      = *( ";" chunk-ext-name [ "=" chunk-ext-val ] )
-- >
-- > chunk-ext-name = token
-- > chunk-ext-val  = token / quoted-string

Best Regards

Simon

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Dec 2013 13:22:43 +0100

> -- > chunk-ext-val  = token / quoted-string

Good catch. quoted-string changed in [1966] not to allow line folding.

Fixed with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/2509>.

Best regards, Julian

---

From: Simon Yarde <[email-masked]>
Date: Mon, 16 Dec 2013 11:05:28 +0000

Might be neater to use the new 'word' rule?

-- > chunk-ext      = *( ";" chunk-ext-name [ "=" chunk-ext-val ] )
-- >
-- > chunk-ext-name = token
-- > chunk-ext-val  = word

-- > word           = token / quoted-string

Best Regards

Simon

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Dec 2013 12:16:21 +0100

On 2013-12-16 12:05, Simon Yarde wrote:
> ...

Maybe. Right now we use "word" only in two places; either we should get 
rid of it, or use it consistently.

Best regards, Julian

---

From: Simon Yarde <[email-masked]>
Date: Mon, 16 Dec 2013 11:27:59 +0000

It does seem to represent a proper simplification in the spirit of the project, and presumably consistency is desirable.

I'm rather late to the party and probably not the right person to present further argument.

Best Regards

Simon

On 16 Dec 2013, at 11:16, Julian Reschke <[email-masked]> wrote:

> Maybe. Right now we use "word" only in two places; either we should get rid of it, or use it consistently.
> 
> Best regards, Julian

---

From: "Roy T. Fielding" <[email-masked]>
Date: Fri, 20 Dec 2013 16:45:23 -0800

> Maybe. Right now we use "word" only in two places; either we should get rid of it, or use it consistently.

Removed in 

   http://trac.tools.ietf.org/wg/httpbis/trac/changeset/2519

along with some other unnecessary rules.

....Roy

---

From: Julian Reschke <[email-masked]>
Date: Sat, 21 Dec 2013 10:08:59 +0100

> along with some other unnecessary rules.

I have re-added the "special" rule. It's not referenced by the ABNF but 
it was there to clarify "tchar":

   tchar          = "!" / "#" / "$" / "%" / "&" / "'" / "*"
                  / "+" / "-" / "." / "^" / "_" / "`" / "|" / "~"
                  / DIGIT / ALPHA
                  ; any VCHAR, except special

   special        = "(" / ")" / "<" / ">" / "@" / ","
                  / ";" / ":" / "\" / DQUOTE / "/" / "["
                  / "]" / "?" / "=" / "{" / "}"

Best regards, Julian