Subject: HTTP/2 and NCSA

From: Poul-Henning Kamp <[email-masked]>
Date: Mon, 06 Jan 2014 09:54:47 +0000

One of my users asked and I couldn't answer, so I'm passing it on:

    Who will (and when will they) standardize how NCSA log format
    works with HTTP/2.0, in particular for "new" stuff like PUSH ?

My cursory research indicates that W3C has documented the NCSA
format (somewhat) but it is not clear to me if they actually
consider themselves steward of the standardisation ?

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe
Never attribute to malice what can adequately be explained by incompetence.

---

From: Yves Lafon <[email-masked]>
Date: Mon, 6 Jan 2014 11:30:59 -0500 (EST)

> consider themselves steward of the standardisation ?

The document is from... 1996 [1], so the space is up for grab.

[1] http://www.w3.org/TR/WD-logfile.html

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Mon, 06 Jan 2014 16:37:12 +0000

>[1] http://www.w3.org/TR/WD-logfile.html

Yes, that's how I derived that W3C didn't seem to be very interested.

Are we ?

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Jan 2014 16:33:40 +0800

> Yes, that's how I derived that W3C didn't seem to be very interested.

Hmm. It’s not really a standard in the sense that IETF does them, and I don’t know of any other log formats that have been standardised in that sense.

That said, if an implementation wanted to publish an Informational RFC documenting their HTTP2-friendly log format, that’s entirely doable, and I’m sure they’d get some help if they asked.

Cheers,

Mark Nottingham   http://www.mnot.net/

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 07 Jan 2014 13:58:09 +0000

On 01/07/2014 08:33 AM, Mark Nottingham wrote:
> Hmm. It’s not really a standard in the sense that IETF does them, and
> I don’t know of any other log formats that have been standardised in
> that sense.
> 
> That said, if an implementation wanted to publish an Informational
> RFC documenting their HTTP2-friendly log format, that’s entirely
> doable, and I’m sure they’d get some help if they asked.

I've no opinion of whether a log format should or should
not be "part" of the HTTP/2.0 work. But the IETF has done
similar stuff - SIPCLF [1] was a WG that set out to define
a log file format for SIP that's based on the Apache log
file format.

Unfortunately they never thought about privacy when doing
that, and by the time I heard about it, it was too late.
E.g. there's no well-defined way to obsfuscate IP addresses
so they can be correlated for a while only. If someone were
to try do such work for HTTP/2.0 I'd hope that they would
seriously consider privacy issues.

S.

[1] http://tools.ietf.org/wg/sipclf/

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Tue, 07 Jan 2014 14:37:43 +0000

In message <[email-masked]>, Mark Nottingham wri
tes:

>That said, if an implementation wanted to publish an Informational RFC 
>documenting their HTTP2-friendly log format, that's entirely doable, 
>and I'm sure they'd get some help if they asked.

Purely as a matter of making it easier for people to adopt HTTP/2.0,
it might be a good idea to be a *little* bit more proactive than that.

---

From: "Nicolas Mailhot" <[email-masked]>
Date: Tue, 7 Jan 2014 17:51:08 +0100

> it might be a good idea to be a *little* bit more proactive than that.

And, it would make the protocol better (actually thinking how it will be
used, and making sure things can be logged for example not forgetting to
reserve a symbol in headers that can be used as log separator)

Regards,

-- 
Nicolas Mailhot

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 8 Jan 2014 08:32:18 +0800

> it might be a good idea to be a *little* bit more proactive than that.

If you (or someone else) wants to see it done, write it up and submit a draft; if you need help with the drafting, ask. If the draft looks good and worthwhile to folks, we can talk about adopting it as a WG item.

Cheers,

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Wed, 08 Jan 2014 09:06:25 +0000

In message <[email-masked]>, Mark Nottingham wri
tes:

>If you (or someone else) wants to see it done, write it up and submit a =
>draft; if you need help with the drafting, ask. If the draft looks good =
>and worthwhile to folks, we can talk about adopting it as a WG item.

I still have not found anybody willing to pay me for standards work
on HTTP/2 and this would require more research and effort than I can
squeeze into the cracks.