Subject: #532 IESG ballot on draft-ietf-httpbis-p2-semantics-25, reason phrase optional?

From: Julian Reschke <[email-masked]>
Date: Sat, 04 Jan 2014 11:56:10 +0100

Sean Turner asks:

> s6.1: Is it worth mentioning that the reason-phrase can also be not sent? I think that's elsewhere but it might be worth mentioning again.

AFAIU, the reason phrase is not optional, but it can be empty. Consider 
the ABNF in 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p1-messaging-25.html#status.line>:

   status-line = HTTP-version SP status-code SP reason-phrase CRLF
   reason-phrase  = *( HTAB / SP / VCHAR / obs-text )

So it wouldn't be unreasonable for a recipient to split on the first two 
SP occurrences (and fail if there is none).

Best regards, Julian

---

From: Amos Jeffries <[email-masked]>
Date: Sun, 05 Jan 2014 00:17:10 +1300

On 4/01/2014 11:56 p.m., Julian Reschke wrote:
> Sean Turner asks:
> 
>> s6.1: Is it worth mentioning that the reason-phrase can also be not
>> sent? I think that's elsewhere but it might be worth mentioning again.
> 

And by that ABNF definition it can also consist of nothing but a series
of whitespace following an initial SP delimiter.

Amos