Subject: Re: GOAWAY -> GTFO

From: "CIURANA EUGENE (pr3d4t0r)" <[email-masked]>
Date: Wed, 29 Jan 2014 08:25:40 -0800

>> On Tue, Jan 28, 2014 at 1:22 PM, Adrian Cole
<[email-masked]>
>> wrote:
>>> FWIW, when GTFO was
suggested last week at the working group, all people
>>> present had an
opportunity to dissent and I heard not a single dissent
>>> voiced!

>>> That said, I wouldn't conflate above PR/commit as a "popular move"
as who
>>> knows.. GOAWAY might actually lose a popular vote vs
GTFO!
>>> 
>>> That said, silencing the argument is likely a popular
move, so maybe the
>>> description still fits.

I expressed this in the
GitHub comments about the issue, echoing it here as well because this
mailing list has a wider audience.

Use of GTFO is fine. Anyone arguing
that because foreign speakers may not understand potential slang is
being naïve or needs to get out more. I've managed development teams in
Moscow, Novosibirsk, Kiev, the San Francisco Bay Area, London, and
Japan. The use of slang or jargon derived from English in technical
documentation, implementations, code, or configuration has never
deterred anybody from applying the appropriate knowledge. GOAWAY vs.
GTFO -- if I were to implement a server or a client handler for this,
I'd go for GTFO as the most meaningful (and perhaps get a secret
chuckle, sure).

So -- can we keep this instead? Think of HTTP status
code 418 IMATEAPOT (which is Russian slang for "I don't know what I'm
doing"). Not many web servers or app servers implement it, granted, but
it's part of the official spec. And I've known teams in the US and
Europe who've used 418 as a placeholder for an app RESTful handler that
is only mocked up/yet to be implemented.

Just my $0,02.

Cheers!

E

--

http://eugeneciurana.com | http://ciurana.eu

---

From: Simon Yarde <[email-masked]>
Date: Wed, 29 Jan 2014 16:42:24 +0000

This issue as I see it is not that non-native English speakers won't get the joke;  it is that course humour is disrespectful to the work being done.

Um.. it was an 'April Fool'. And yes it is part of 'a' protocol, but not 'the' HTTP protocol. At least it was non-offensive.

> 2. HTCPCP Protocol
> 
> 
>    The HTCPCP protocol is built on top of HTTP,

I think matters have rightly moved along now.

Simon Yarde

On 29 Jan 2014, at 16:25, CIURANA EUGENE (pr3d4t0r) <[email-masked]> wrote:

>  
> >> On Tue, Jan 28, 2014 at 1:22 PM, Adrian Cole <[email-masked]
> >
> >> wrote:
> >>> 
> >>> FWIW, when GTFO was suggested last week at the working group, all people
> >>> present had an opportunity to dissent and I heard not a single dissent
> >>> voiced!
> >>> 
> >>> That said, I wouldn't conflate above PR/commit as a "popular move" as who
> >>> knows.. GOAWAY might actually lose a popular vote vs GTFO!
> >>> 
> >>> That said, silencing the argument is likely a popular move, so maybe the
> >>> description still fits.
> 
> 
> I expressed this in the GitHub comments about the issue, echoing it here as well because this mailing list has a wider audience.
> 
> Use of GTFO is fine.  Anyone arguing that because foreign speakers may not understand potential slang is being naïve or needs to get out more.  I've managed development teams in Moscow, Novosibirsk, Kiev, the San Francisco Bay Area, London, and Japan.  The use of slang or jargon derived from English in technical documentation, implementations, code, or configuration has never deterred anybody from applying the appropriate knowledge.  GOAWAY vs. GTFO -- if I were to implement a server or a client handler for this, I'd go for GTFO as the most meaningful (and perhaps get a secret chuckle, sure).
> 
> So -- can we keep this instead?  Think of HTTP status code 418 IMATEAPOT (which is Russian slang for "I don't know what I'm doing").  Not many web servers or app servers implement it, granted, but it's part of the official spec.  And I've known teams in the US and Europe who've used 418 as a placeholder for an app RESTful handler that is only mocked up/yet to be implemented.
> 
> Just my $0,02.
> 
> Cheers!
> 
> E
> --

---

From: Yoav Nir <[email-masked]>
Date: Wed, 29 Jan 2014 18:48:19 +0200

On 29/1/14 6:25 PM, CIURANA EUGENE (pr3d4t0r) wrote:
>   
> >> On Tue, Jan 28, 2014 at 1:22 PM, Adrian Cole <[email-masked]  <mailto:[email-masked]?Subject=Re%3A%20GOAWAY%20-%3E%20GTFO&In-Reply-To=%3C1509C1A4-808B-4D44-BDB8-EBCB67902A30%40oracle.com%3E&References=%3C1509C1A4-808B-4D44-BDB8-EBCB67902A30%40oracle.com%3E>>
> >> wrote:
> >>>
The issue is not that it would be misunderstood, but that it is 
inappropriate. It's not terribly offensive, just more offensive than it 
needs to be.

"GOAWAY" was clear, well understood, and I don't see why it needed to be 
changed.

We could always go with the classic name for this operation in Internet 
protocols and call it "HANGUP" or "HUP". Then all the young people will 
try to figure out what we are hanging and where, and conclude that it is 
an allusion to something dirty.

Yoav

---

From: Zhong Yu <[email-masked]>
Date: Wed, 29 Jan 2014 12:35:08 -0600

On Wed, Jan 29, 2014 at 10:25 AM, CIURANA EUGENE (pr3d4t0r)
<[email-masked]> wrote:
>
>
>>> On Tue, Jan 28, 2014 at 1:22 PM, Adrian Cole <[email-masked]>
>>> wrote:
>>>>
> I expressed this in the GitHub comments about the issue, echoing it here as
> well because this mailing list has a wider audience.
>
> Use of GTFO is fine.  Anyone arguing that because foreign speakers may not
> understand potential slang is being naïve or needs to get out more.  I've

I need to get out? Out where? Do I need to get the fuck out?

The phrase "get the fuck out" has multiple meanings, often depending
on the context and the tone of speaking, like all slangs. For a
non-native English speaker to understand the nuance and subtlety,
forget-about-it.

I apologize for joining in this conversation; I will STFU now.

Zhong Yu

> managed development teams in Moscow, Novosibirsk, Kiev, the San Francisco
> Bay Area, London, and Japan.  The use of slang or jargon derived from
> English in technical documentation, implementations, code, or configuration
> has never deterred anybody from applying the appropriate knowledge.  GOAWAY
> vs. GTFO -- if I were to implement a server or a client handler for this,
> I'd go for GTFO as the most meaningful (and perhaps get a secret chuckle,
> sure).
>
> So -- can we keep this instead?  Think of HTTP status code 418 IMATEAPOT
> (which is Russian slang for "I don't know what I'm doing").  Not many web
> servers or app servers implement it, granted, but it's part of the official
> spec.  And I've known teams in the US and Europe who've used 418 as a
> placeholder for an app RESTful handler that is only mocked up/yet to be
> implemented.
>
> Just my $0,02.
>
> Cheers!
>
> E
>
> --

---

From: Matthew Kerwin <[email-masked]>
Date: Thu, 30 Jan 2014 08:03:50 +1000

Daniel Sommermann <[email-masked]>:
> I was surprised by this change.
> [...]
> Is this just a prank?

Everyone:
> [...]

> I think matters have rightly moved along now.

So I guess now is not the time to complain about "PRI"/"SM" again, huh?
(I want 48454c4f202a20485454502f322e300d0a0d0a2e0d0a0d0a.)

-- 
  Matthew Kerwin
  http://matthew.kerwin.net.au/