Subject: Reg spydy implementations

From: "Appanasamy, Palanivelan" <[email-masked]>
Date: Wed, 12 Feb 2014 20:37:29 +0530

Hi Mark,

Few queries on spydy.

1.We see spdy implementations in webservers as in twitter, google and facebook. All of these are http1.1+spdy3.1. With 1.1 implementations, are there any limitations we r living with that won't be there with http2.0 spydy? Or is it just as good as 2.0 spdy.

2. Are there usecases for non-encrypted spydy or spydy on port 80? Is there a webserver today that supports this?

Appreciate your responses.

Thanks,
Palanivelan,
Verizon labs, Bangalore.

---

From: William Chan (陈智昌) <[email-masked]>
Date: Wed, 12 Feb 2014 11:19:15 -0800

Are you asking about SPDY or HTTP/2? SPDY specific questions should go
to [email-masked].

> 1.We see spdy implementations in webservers as in twitter, google and facebook. All of these are http1.1+spdy3.1. With 1.1 implementations, are there any limitations we r living with that won't be…

HTTP/1.1 is not "just as good" as SPDY / HTTP/2, otherwise people
wouldn't bother with SPDY / HTTP/2.

> 2. Are there usecases for non-encrypted spydy or spydy on port 80? Is there a webserver today that supports this?

There are use cases for non-encrypted SPDY / HTTP/2, but no browser
today supports that, although IE has expressed interest. Chrome and
Firefox have both stated that they do not plan to support it. I think
there may be a webserver that supports it, but I don't know offhand.