Subject: Re: Mark's coalescing proposal

From: Carsten Bormann <[email-masked]>
Date: Sat, 1 Feb 2014 11:20:27 +0100

On 01 Feb 2014, at 05:25, Mark Nottingham <[email-masked]> wrote:

> whether the MAY ought to be a SHOULD; i.e., when possible, clients are encouraged

There is a wide spectrum between MAY (whatever you want) and SHOULD (you really have to have one of the following documented reasons not to).  This strikes me as a quality of implementation expectation, not an interoperability mandate, so maybe wording with “clients are encouraged” is actually appropriate.

Grüße, Carsten

(Meta note: it is a deficiency that 2119 does not discuss the subject of quality of implementation expectations, and even 6919 only skirts the issue.)

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 01 Feb 2014 19:23:32 +0000

Hi Martin,

On 31/01/2014 18:23, Martin Thomson wrote:
> I think that this is mostly right:
>
> Partial proposal: insert after 9.1 Connection Management second paragraph:
>
> Clients MAY use a single connection for more than one origin when each
> origin's hostname resolves to the same IP address, and they share the
> same port. When an origin's scheme is "https", the server's
> certificate MUST be valid for the origin's hostname to be used in this
> fashion; this might be accomplished using a "wildcard certificate",
> subjectAltName [RFC3280], or some other mechanism.
> <<<
>
> However, 3280 is out of date.  I wonder if 6125 is not a better
> reference to use here.  As in:
>
> When an origin's scheme is "https", the server MUST be authenticated,
> either by validating the server certificate against the hostname in
> the origin [RFC6125], or by some other mechanism.
If you want to do that, you need to define:
1) whether wildcards are allowed or not
2) whether CN-ID (CN=<hostname> in the subject DN) is allowed or not
3) whether DNS-ID is allowed or not.

So basically you can't just say "use RFC 6125", you need a bit more 
information.

---

From: Martin Thomson <[email-masked]>
Date: Sat, 1 Feb 2014 11:38:19 -0800

> So basically you can't just say "use RFC 6125", you need a bit more

Ahh, I should really read that again.  Last time I tried, I only
barely managed to finish the title.

We're not looking to changing anything, so it's wildcards and CN.

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 2 Feb 2014 11:29:44 +1100

> There is a wide spectrum between MAY (whatever you want) and SHOULD (you really have to have one of the following documented reasons not to).  This strikes me as a quality of implementation expecta…

We've used SHOULD to encourage behaviour with good network effects / social benefit before -- e.g., sending caching metadata. Personally, I think this falls in the same bucket; the client's behaviour here has strong impact on the network and server (indeed, the network impact is one of the major reasons we're doing /2).

Cheers,

--
Mark Nottingham   http://www.mnot.net/