Subject: Priorities, draft -10 and our next implementation draft

From: Mark Nottingham <[email-masked]>
Date: Thu, 13 Feb 2014 14:14:43 +1100

We discussed priority levelling <https://github.com/http2/http2-spec/issues/270> in Zurich, and decided there to take Roberto's "Weighted Dependency Tree" approach.

However, discussion on the list since has moved on to other proposals, especially Osama's: <http://www.w3.org/mid/[email-masked]>

It's not clear to me that we have consensus on one approach here yet.

We also said that we'd put out another Implementation Draft before London, but with the date fast approaching, we need to either choose one quickly or defer the Implementation Draft.

Unless we converge in the next day or so, I think Martin should ship a draft -10 with the "vanilla" priority field as before, and we can discuss this issue in more depth in London (presumably shipping an implementation draft shortly thereafter).

Thoughts?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: William Chan (陈智昌) <[email-masked]>
Date: Wed, 12 Feb 2014 20:06:01 -0800

I think that's definitely the pragmatic path forward. I apologize for
being late to reply to Osama's proposal earlier, although I don't know
if it would have made a difference timeline wise.

---

From: Patrick McManus <[email-masked]>
Date: Thu, 13 Feb 2014 07:49:00 -0500

i agree we should take this to london

On Wed, Feb 12, 2014 at 10:14 PM, Mark Nottingham <[email-masked]> wrote:

> We discussed priority levelling <
> https://github.com/http2/http2-spec/issues/270> in Zurich, and decided
> there to take Roberto's "Weighted Dependency Tree" approach.
>
> However, discussion on the list since has moved on to other proposals,
> especially Osama's: <
> http://www.w3.org/mid/[email-masked]
> >
>
> We also said that we'd put out another Implementation Draft before London,
> but with the date fast approaching, we need to either choose one quickly or
> defer the Implementation Draft.
>
> Unless we converge in the next day or so, I think Martin should ship a
> draft -10 with the "vanilla" priority field as before, and we can discuss
> this issue in more depth in London (presumably shipping an implementation
> draft shortly thereafter).
>
> Thoughts?
>
> Cheers,
>
>
> --

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 13 Feb 2014 15:31:14 +0000

+1
On Thu, Feb 13, 2014 at 4:52 AM, Patrick McManus <[email-masked]>

---

From: Osama Mazahir <[email-masked]>
Date: Thu, 13 Feb 2014 19:21:00 +0000

+1 for sticking with "vanilla" and unblocking draft-10.

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 13, 2014 7:31 AM
To: Patrick McManus; Mark Nottingham; HTTP Working Group
Subject: Re: Priorities, draft -10 and our next implementation draft

+1
On Thu, Feb 13, 2014 at 4:52 AM, Patrick McManus <[email-masked]<mailto:[email-masked]>> wrote:
i agree we should take this to london

On Wed, Feb 12, 2014 at 10:14 PM, Mark Nottingham <[email-masked]<mailto:[email-masked]>> wrote:
We discussed priority levelling <https://github.com/http2/http2-spec/issues/270> in Zurich, and decided there to take Roberto's "Weighted Dependency Tree" approach.

Thoughts?

Cheers,