Subject: Publically accessible website running HTTP2 compatible servers

From: "Richard Wheeldon (rwheeldo)" <[email-masked]>
Date: Wed, 12 Mar 2014 18:32:53 +0000

Hi,

Does anyone have a list of web servers which can be accessed using HTTP2  (Mozilla or curl) for testing? Or do I need to set aside the time to install my own somewhere? Ideally they should work in both the TLS and non-TLS cases. The closest I've found is https://github.com/http2/http2-spec/wiki/Implementations 

Regards,

Richard

---

From: Daniel Stenberg <[email-masked]>
Date: Wed, 12 Mar 2014 19:42:32 +0100 (CET)

On Wed, 12 Mar 2014, Richard Wheeldon (rwheeldo) wrote:

> Does anyone have a list of web servers which can be accessed using HTTP2 
> (Mozilla or curl) for testing? Or do I need to set aside the time to install 
> my own somewhere? Ideally they should work in both the TLS and non-TLS 
> cases. The closest I've found is 
> https://github.com/http2/http2-spec/wiki/Implementations

Hi,

Within the curl project we've mostly used nghttp2's own server locally and 
twitter.com for manual tests while Firefox is being tested again a local 
node-http2 server (in addition to the other two).

I too would like more public server implementations to run interop tests 
against...

-- 

  / daniel.haxx.se

---

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Wed, 12 Mar 2014 19:59:50 +0000

On Wed, 12 Mar 2014, Richard Wheeldon (rwheeldo) wrote:

> Does anyone have a list of web servers which can be accessed using 
> HTTP2 (Mozilla or curl) for testing? Or do I need to set aside the 
> time to install my own somewhere? Ideally they should work in both the 
> TLS and non-TLS cases. The closest I've found is 

Richard,

Take a look at https://github.com/MSOpenTech/http2-katana. There are public endpoints available for testing the current implementable draft (-09):

http://http2katanatest.cloudapp.net:8080/root/index.html

https://http2katanatest.cloudapp.net:8443/root/index.html

Brian Raymor
Senior Program Manager
Microsoft Open Technologies, Inc. 
A subsidiary of Microsoft Corporation