Subject: HTTP/2 schedule - implementation draft, interim meeting, WGLC

From: Mark Nottingham <[email-masked]>
Date: Wed, 12 Mar 2014 18:07:36 +0800

One of the things we discussed at the Design Team Meeting on Saturday was the schedule for our next Implementation Draft and its companion interop / interim meeting.

Martin thinks we can get our next Implementation Draft out by the end of March, and the implementers in the room there seemed to think that a longer period was necessary before the next interop. 

Therefore, we talked about having the next interim meeting (where we’d do interop on that draft) on the US East Coast in early June (most likely, 5-6 June in Boston).

The idea behind that is that, barring any major problems, that would be our last implementation draft, and we’d go to Working Group Last Call shortly thereafter. 

Doing that would put us about two months behind our charter deliverable schedule for WGLC, but the implementers we spoke to felt that it was necessary to have a bit more time, since otherwise we’d be talking about a less-than-one-month iteration. 

What do folks here think — does that make sense? I’d like to decide this ASAP, since some people have said they need to make travel plans.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Adrian Cole <[email-masked]>
Date: Thu, 13 Mar 2014 17:34:48 -0700

So, I don't plan to work on a non-implementation draft, so catching up
with work in progress will end up being deferred until June in this
case.  That seems like a missed opportunity to move things like
twitter (and clients of it) closer to the goal.

If there is either contention or other cause (overhead?) to hold off
on an implementation draft between now and June, then maybe a punt
sounds reasonable.

-A

On Wed, Mar 12, 2014 at 3:07 AM, Mark Nottingham <[email-masked]> wrote:
> Therefore, we talked about having the next interim meeting (where we'd do interop on that draft) on the US East Coast in early June (most likely, 5-6 June in Boston).
>
> The idea behind that is that, barring any major problems, that would be our last implementation draft, and we'd go to Working Group Last Call shortly thereafter.
>
> Doing that would put us about two months behind our charter deliverable schedule for WGLC, but the implementers we spoke to felt that it was necessary to have a bit more time, since otherwise we'd be talking about a less-than-one-month iteration.
>
> What do folks here think -- does that make sense? I'd like to decide this ASAP, since some people have said they need to make travel plans.
>
> Cheers,
>
> --

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Mar 2014 18:31:23 -0700

> twitter (and clients of it) closer to the goal.

I've read this 5 times now, and I'm not sure what you mean.  We intend
to mark the next draft as an interoperability test target.  That
should happen in less than 2 weeks.  We hope this will be the last.

What, if anything, do you think we should be doing to make the overall
process faster?

---

From: Adrian Cole <[email-masked]>
Date: Thu, 13 Mar 2014 19:07:46 -0700

Sounds like I completely misunderstood this email, then.  Apologies for the
confusion.

-A

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 17 Mar 2014 11:39:00 +1100

> Therefore, we talked about having the next interim meeting (where we’d do interop on that draft) on the US East Coast in early June (most likely, 5-6 June in Boston).

Looking at this more closely, MIT's commencement is on those exact days, making hotels in Boston and Cambridge very expensive and hard to find.

Because of that, I'm looking at switching to June 12-13, still in Boston. The other option is to do New York on June 5-6.

If anyone has a preference, please get back to me ASAP.

Cheers,

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Mar 2014 09:59:56 +1100

Hi everybody,

Based on the feedback I've received, we won't be moving the dates; it'll still be June 5/6. We're working on a host in NYC now, should be final soon.

Cheers and thanks for your patience,

---

From: William Chan (陈智昌) <[email-masked]>
Date: Mon, 24 Mar 2014 16:07:11 -0700

W00t! Is NYC confirmed? Just want to know if I can buy tickets. Thanks.

On Mon, Mar 24, 2014 at 3:59 PM, Mark Nottingham <[email-masked]> wrote:

> Hi everybody,
>
> Based on the feedback I've received, we won't be moving the dates; it'll
> still be June 5/6. We're working on a host in NYC now, should be final soon.
>
> >> Therefore, we talked about having the next interim meeting (where we'd
> do interop on that draft) on the US East Coast in early June (most likely,
> 5-6 June in Boston).
> >
> > Looking at this more closely, MIT's commencement is on those exact days,
> making hotels in Boston and Cambridge very expensive and hard to find.
> >
> > Because of that, I'm looking at switching to June 12-13, still in
> Boston. The other option is to do New York on June 5-6.
> >

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Mar 2014 10:10:09 +1100

> W00t! Is NYC confirmed? Just want to know if I can buy tickets. Thanks.

http://lmgtfy.com/?q=soon