Subject: RE: Alternate service framework: question about Alt-Svc HTTP Header Field

From: <[email-masked]>
Date: Thu, 6 Mar 2014 12:21:17 +0000

Hi Martin

Thanks for the link toward OWS token definition. It answer 75% of my question about the meaning of 'OWS parameter' .

Regards
Emile

-----Message d'origine-----
De : Martin Thomson [mailto:[email-masked]] 
Envoyé : mercredi 5 mars 2014 18:05
À : STEPHAN Emile IMT/OLN
Cc : Mark Nottingham ([email-masked]); [email-masked]
Objet : Re: Alternate service framework: question about Alt-Svc HTTP Header Field

On 5 March 2014 17:42,  <[email-masked]> wrote:
> What is the OWS parameter ? is it another alternate port or can it be 
> ancillary parameters ?

That is an ABNF product that is used in HTTP to define header fields.
It defines "optional whitespace".

   OWS = *( SP / HTAB )

-- http://tools.ietf.org/html/draft-ietf-httpbis-p1-messaging-26#appendix-B

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 06 Mar 2014 14:37:28 +0100

> Thanks for the link toward OWS token definition. It answer 75% of my question about the meaning of 'OWS parameter' .

What are the other 25%?

---

From: <[email-masked]>
Date: Thu, 6 Mar 2014 13:57:33 +0000

The meaning of parameter :-)

-----Message d'origine-----
De : Julian Reschke [mailto:[email-masked]] 
Envoyé : jeudi 6 mars 2014 13:37
À : STEPHAN Emile IMT/OLN; Martin Thomson
Cc : Mark Nottingham ([email-masked]); [email-masked]
Objet : Re: Alternate service framework: question about Alt-Svc HTTP Header Field

What are the other 25%?

---

From: Martin Thomson <[email-masked]>
Date: Thu, 6 Mar 2014 14:01:00 +0000

> The meaning of parameter :-)

OWS carries no meaning.

---

From: <[email-masked]>
Date: Thu, 6 Mar 2014 14:17:40 +0000

Hi Martin

I'm saying that the meaning of the token 'parameter' in 'OWS parameter' is not clearly defined.
It seems limited to 'ma' as 'max-age' .

Regards
Emile

-----Message d'origine-----
De : Martin Thomson [mailto:[email-masked]] 
Envoyé : jeudi 6 mars 2014 14:01
À : STEPHAN Emile IMT/OLN
Cc : Julian Reschke; Mark Nottingham ([email-masked]); [email-masked]
Objet : Re: Alternate service framework: question about Alt-Svc HTTP Header Field

OWS carries no meaning.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 6 Mar 2014 14:24:29 +0000

> I'm saying that the meaning of the token 'parameter' in 'OWS parameter' is not clearly defined.

Ahh, I believe that the parameter production is this one:

   parameter = token "=" ( token / quoted-string )

This allows for arbitrary key-value pairs, of which "ma" is defined.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 06 Mar 2014 15:28:40 +0100

On 2014-03-06 15:17, [email-masked] wrote:
> ...

Ah.

It's an extension point.

We'll have to think about how to use that (extensions defined by spec 
update, and "must ignore unknown parameters" rule?).

Best regards, Julian

---

From: <[email-masked]>
Date: Thu, 6 Mar 2014 16:48:28 +0000

Defined in that way, I agree with Roberto that it is an elegant way of solving a few problems at the same time. 

-----Message d'origine-----
De : Martin Thomson [mailto:[email-masked]] 
Envoyé : jeudi 6 mars 2014 14:24
À : STEPHAN Emile IMT/OLN
Cc : Yutaka OIWA; Julian Reschke; Mark Nottingham ([email-masked]); [email-masked]
Objet : Re: Alternate service framework: question about Alt-Svc HTTP Header Field