Subject: Alternate service framework: question about Alt-Svc HTTP Header Field

From: <[email-masked]>
Date: Wed, 5 Mar 2014 17:42:46 +0000

Hi Mark

First of all, I support the altsvc framework.

I have a clarification question with regards to the alt-svc header defined in section 3.2 of http://tools.ietf.org/id/draft-nottingham-httpbis-alt-svc-03.txt .

What is the OWS parameter ? is it another alternate port or can it be ancillary parameters ?

Regards
Emile

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 5 Mar 2014 18:05:28 +0000

> What is the OWS parameter ? is it another alternate port or can it be

That is an ABNF product that is used in HTTP to define header fields.
It defines "optional whitespace".

   OWS = *( SP / HTAB )

-- http://tools.ietf.org/html/draft-ietf-httpbis-p1-messaging-26#appendix-B

---

From: Yutaka OIWA <[email-masked]>
Date: Thu, 6 Mar 2014 03:16:30 +0900

Up to my understanding,
The "parameter" is the ancillary parameters.
An example is "ma" in the section following that.
OWS means "optional white space" before that parameter.

2014-03-06 2:42 GMT+09:00  <[email-masked]>:
> I have a clarification question with regards to the alt-svc header defined
> in section 3.2 of
> http://tools.ietf.org/id/draft-nottingham-httpbis-alt-svc-03.txt .
>
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

-- 
Yutaka OIWA, Ph.D.                 Leader, System Life-cycle Research Group
                               Research Institute for Secure Systems (RISEC)
     National Institute of Advanced Industrial Science and Technology (AIST)
                       Mail addresses: <[email-masked]>, <[email-masked]>
OpenPGP: id[440546B5] fp[7C9F 723A 7559 3246 229D  3139 8677 9BD2 4405 46B5]

---

From: <[email-masked]>
Date: Thu, 6 Mar 2014 12:27:13 +0000

Hi

Thanks for you precise answer. I was confused by the  'OWS' prefix.

Is it possible to use other parameters than 'ma' (e.g. max-age)  ?

Regards
Emile

-----Message d'origine-----
De : Yutaka OIWA [mailto:[email-masked]] 
Envoyé : mercredi 5 mars 2014 18:17
À : STEPHAN Emile IMT/OLN
Cc : Mark Nottingham ([email-masked]); [email-masked]
Objet : Re: Alternate service framework: question about Alt-Svc HTTP Header Field

Up to my understanding,

2014-03-06 2:42 GMT+09:00  <[email-masked]>:
> I have a clarification question with regards to the alt-svc header 
> defined in section 3.2 of 
> ______________________________________________________________________
> ___________________________________________________
>
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.