Subject: #426: Unsupported Scheme

From: Mark Nottingham <[email-masked]>
Date: Sun, 30 Mar 2014 18:31:36 +1100

<https://github.com/http2/http2-spec/issues/426>

This issue came up in London. Since then, we adopted Alt-Svc, which includes a HTTP Status Code for "Not Authoritative".

<http://http2.github.io/http2-spec/alt-svc.html#the-4nn-not-authoritative-http-status-code>

That status code is slightly more broad than just "Unsupported Scheme", but IIRC people felt that that's OK.

If that seems reasonable to people, we can close this issue.

Cheers,

P.S. Julian, let's go ahead and choose a status code for "Not Authoratative" before the implementation draft.

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 31 Mar 2014 14:28:48 +0200

On 2014-03-30 09:31, Mark Nottingham wrote:
> ...

Done in 
<https://github.com/http2/http2-spec/commit/c450d00725dedafaa866bd4531c6b245b020d2e2>.

Best regards, Julian