Subject: Priority Tree Synchronization Draft

From: RUELLAN Herve <[email-masked]>
Date: Sun, 20 Jul 2014 14:04:39 +0000

All,

During an HTTP/2 connection, the client and the server each have their own view of the priority tree. For a good working of priorities, these views should be as much as possible synchronized.

We're in the process of publishing a draft outlining this synchronization problem and its potential impacts. It also sketches some possible solutions. While waiting for the IETF publishing tool to reopen, I'm sending this draft directly to the list.

Comments on this are most welcomed.

Cheers,

Hervé.

---

From: RUELLAN Herve <[email-masked]>
Date: Mon, 21 Jul 2014 22:40:21 +0000

Here is the published draft.

Hervé

------

A new version of I-D, draft-ruellan-priority-tree-sync-00.txt
has been successfully submitted by Herve Ruellan and posted to the
IETF repository.

Name:           draft-ruellan-priority-tree-sync
Revision:       00
Title:          HTTP/2 Priority Tree Synchronization
Document date:  2014-07-22
Group:          Individual Submission
Pages:          10
URL:            http://www.ietf.org/internet-drafts/draft-ruellan-priority-tree-sync-00.txt
Status:         https://datatracker.ietf.org/doc/draft-ruellan-priority-tree-sync/
Htmlized:       http://tools.ietf.org/html/draft-ruellan-priority-tree-sync-00

Abstract:
   This specification describes an issue in HTTP/2 linked to the
   synchronization of priority trees between a client and a server.  It
   outlines possible solutions to this issue.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat
________________________________________
From: RUELLAN Herve [[email-masked]]
Sent: Sunday, July 20, 2014 16:04
To: HTTP Working Group ‎[[email-masked]]‎
Subject: Priority Tree Synchronization Draft

All,

Cheers,

Hervé.