Subject: draft-ietf-httpbis-http2-encryption

From: <[email-masked]>
Date: Tue, 22 Jul 2014 14:18:41 +0000

Hi Mark,

During the meeting we discussed about proxies.
It appears that the usage of opportunistic encryption with proxies is not documented in draft-ietf-httpbis-http2-encryption-00.txt<http://tools.ietf.org/html/draft-ietf-httpbis-http2-encryption-00.txt>.
I volunteer to add text on that.
Is there a github page to propose text ?

Regards
Emile

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jul 2014 07:29:46 -0700

On 22 July 2014 07:18,  <[email-masked]> wrote:
> It appears that the usage of opportunistic encryption with proxies is not
> documented in draft-ietf-httpbis-http2-encryption-00.txt.
>

https://github.com/httpwg/http-extensions

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Jul 2014 16:35:11 +0200

On 2014-07-22 16:18, [email-masked] wrote:
> It appears that the usage of opportunistic encryption with proxies is
> not documented in draft-ietf-httpbis-http2-encryption-00.txt
> <http://tools.ietf.org/html/draft-ietf-httpbis-http2-encryption-00.txt>.
>
> ...

Over here: 
<https://github.com/httpwg/http-extensions/blob/master/draft-ietf-httpbis-http2-encryption.md>

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 Jul 2014 13:09:34 -0400

Sure, but note that we have an open issue about this:
  https://github.com/httpwg/http-extensions/issues/9

… and we still need to discuss it.

On 22 Jul 2014, at 10:18 am, [email-masked] wrote:

> It appears that the usage of opportunistic encryption with proxies is not documented in draft-ietf-httpbis-http2-encryption-00.txt.

--
Mark Nottingham   http://www.mnot.net/