Subject: RE: I-D Action: draft-hutton-httpbis-connect-protocol-00.txt

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 1 Jul 2014 09:05:46 +0000

Hi Andy,

Wouldn't it make sense to include a token for "http" as well?

Kind regards,
Uwe 

> -----Original Message-----
> From: ext Hutton, Andrew [mailto:[email-masked]]
> Sent: Friday, June 27, 2014 10:21 AM
> To: [email-masked]
> Subject: FW: I-D Action: draft-hutton-httpbis-connect-protocol-00.txt
> 
> I just submitted this draft for which there is a short agenda slot in
> Toronto.
> 
> Andy
> 
> 
>         Title           : HTTP Connect - Tunnel Protocol For WebRTC
>         Authors         : Andrew Hutton
>                           Justin Uberti
>                           Martin Thomson
> 	Filename        : draft-hutton-httpbis-connect-protocol-00.txt
> 	Pages           : 7
> 	Date            : 2014-06-27
> 
> Abstract:
>    This document describes a mechanism to enable HTTP Clients to provide
>    an indication within a HTTP Connect request as to which protocol will
>    be used within the tunnel established to the Server identified by the
>    target resource.  The tunneled protocol is declared using the Tunnel-
>    Protocol HTTP Request header field.  Label usage relating to the use
>    of HTTP Connect by WebRTC clients (e.g. turn, webrtc) are described
>    in this document.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hutton-httpbis-connect-protocol/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-hutton-httpbis-connect-protocol-00
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Martin Thomson <[email-masked]>
Date: Tue, 1 Jul 2014 11:10:45 -0700

> Wouldn't it make sense to include a token for "http" as well?

We already have those:
  https://tools.ietf.org/html/draft-ietf-tls-applayerprotoneg-05#section-6
  https://http2.github.io/http2-spec/#versioning