Subject: Questions about SETTINGS and SETTINGS ACK

From: Michael Sweet <[email-masked]>
Date: Thu, 03 Jul 2014 15:29:03 -0400

All,

Quick questions for my implementation about SETTINGS: 

1. Can an endpoint have more than one SETTINGS frame in flight? That is, can an endpoint send a second SETTINGS frame without waiting for the corresponding ACK?  The spec doesn't forbid this, but does talk about having the sender time out after some reasonable period of time.

2. If multiple SETTINGS frames can be "in flight", how does the sender know *which* settings are being acknowledged when it gets a SETTINGS frame back with the ACK bit set?

3. If multiple SETTINGS frames cannot be in flight, does the receiver issue a connection error of type PROTOCOL_ERROR?

Thanks!

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Mike Bishop <[email-masked]>
Date: Thu, 3 Jul 2014 19:35:55 +0000

Since TCP is ordered, SETTINGS will be arrived (and must be processed) in order.  So you can have multiple outstanding SETTINGS frames, and the first ACK you get back is for the first one you sent, etc.

If we were to define a mapping over an out-of-order transport, this is one of the things that would have to change.

-----Original Message-----
From: Michael Sweet [mailto:[email-masked]] 
Sent: Thursday, July 3, 2014 12:29 PM
To: HTTP Working Group
Subject: Questions about SETTINGS and SETTINGS ACK

All,

Thanks!