Subject: Wiki for CONTINUATION Proposals

From: Mark Nottingham <[email-masked]>
Date: Sat, 12 Jul 2014 16:46:39 +1000

I've heard from a few people that the conversation about CONTINUATION has become too difficult to follow.

So, let's try to use a wiki page to hold the state of the proposals, their pros and cons. 

Please have a look:
  https://github.com/http2/http2-spec/wiki/ContinuationProposals

I'm sure that I've missed a lot of nuance, and very well may have got it completely wrong. 

It's a wiki; please correct it, elaborate and add to it.

All that I ask is that you represent your own views, not others', and you respect what other people have written; if you think that something that's written is wrong and want to change it, please take it to the list (except for what I've written; I'm pretty sure it's wrong).

Let's see how this goes; hopefully it will cut the list traffic to something a bit more manageable, and allow some people to keep up a bit more easily.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Sat, 12 Jul 2014 09:51:45 +0200

Hi Mark,

> I'm sure that I've missed a lot of nuance, and very well may have got it

No I think it was a good summary, thank you for that. I have slightly updated
it (two extra points and 3 comments).

Cheers,
Willy

---

From: Greg Wilkins <[email-masked]>
Date: Mon, 14 Jul 2014 11:41:31 +1000

Mark,

I added a proposal:

<https://github.com/http2/http2-spec/wiki/ContinuationProposals#fragment-headers-in-the-same-way-as-data-frames>Fragment
HEADERS in the same way as DATA frames

cheers

On 12 July 2014 16:46, Mark Nottingham <[email-masked]> wrote:

> All that I ask is that you represent your own views, not others', and you
> respect what other people have written; if you think that something that's
> written is wrong and want to change it, please take it to the list (except
> for what I've written; I'm pretty sure it's wrong).
>
> Let's see how this goes; hopefully it will cut the list traffic to
> something a bit more manageable, and allow some people to keep up a bit
> more easily.
>
> Cheers,
>
> --

-- 
Greg Wilkins <[email-masked]>
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Roberto Peon <[email-masked]>
Date: Mon, 14 Jul 2014 15:14:26 -0700

Added comments and 'requirements' sections for each, along with a summary
at the bottom.
-=R