Subject: draft-ietf-httpbis-http2-latest, 6.2 HEADERS again

From: Kari Hurtta <[email-masked]>
Date: Sun, 06 Jul 2014 10:09:51 +0000

Hypertext Transfer Protocol version 2
draft-ietf-httpbis-http2-latest, July 5, 2014
http://http2.github.io/http2-spec/

6.2 HEADERS
http://http2.github.io/http2-spec/#HEADERS

> END_SEGMENT (0x2): Bit 2 being set indicates that this frame is the last for the
>    current segment.

Should this be:

>  END_SEGMENT (0x2): Bit 2 being set indicates that this header block is the last 
>     for the current segment.
              
because

> END_SEGMENT, like END_STREAM, applies to a complete sequence of
> HEADERS and CONTINUATION frames. 

Therefore "this frame" is incorrect. 

Same formalation is on END_STREAM:

> END_STREAM (0x1): Bit 1 being set indicates that the header block (Section 4.3) is
> the last that the endpoint will send for the identified stream.

In other hand "this header block" may refer "a complete sequence of
HEADERS and CONTINUATION frames."

/ Kari Hurtta

---

From: Martin Thomson <[email-masked]>
Date: Mon, 7 Jul 2014 09:41:35 -0700

https://github.com/http2/http2-spec/commit/f8020a699206671915bcd1fd6c18ed8b722d2767