Subject: Re: hpack table size 0

From: Mark Nottingham <[email-masked]>
Date: Tue, 1 Jul 2014 17:15:00 +1000

On 1 Jul 2014, at 1:46 am, [email-masked] wrote:

> Won’t "RST_STREAM CANCEL" lead to indeterminate behaviour from the client?  How does the client know to retry the stream?  The spec never mentions that a client should retry.

This spec doesn't, but HTTP does...
  <http://httpwg.github.io/specs/rfc7230.html#persistent.retrying.requests>

That said, the layering here needs some cleaning up. We could either re-specify this in HTTP/2, or make it clear when we re-factor 7230 to go to full Standard.

The latter is on the agenda for Toronto...

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mike Bishop <[email-masked]>
Date: Tue, 1 Jul 2014 14:29:58 +0000

I was thinking of REFUSED_STREAM, not CANCEL -- sorry.  REFUSED_STREAM does explicitly say that the request can be retried.

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]] 
Sent: Tuesday, July 1, 2014 12:15 AM
To: [email-masked]
Cc: Mike Bishop; [email-masked]
Subject: Re: hpack table size 0

On 1 Jul 2014, at 1:46 am, [email-masked] wrote:

> Won't "RST_STREAM CANCEL" lead to indeterminate behaviour from the client?  How does the client know to retry the stream?  The spec never mentions that a client should retry.

Cheers,