Subject: "Can we please append a byte to the HEADERS frame"

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Jul 2014 10:30:12 -0700

Can someone articulate how someone might extend HPACK without
negotiating what that extension might mean?

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Thu, 10 Jul 2014 18:53:29 +0000

In message <CABkgnnUKi4N4iHC4Ni91rPC9DuY=[email-masked]>, Martin Thomson w

>negotiating what that extension might mean?

Same ways usual:  Use SETTINGS to tell what you support, let the
other end decide what to send.  Minimum compliance MUST takes care
of interop.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Jul 2014 12:43:12 -0700

> other end decide what to send.  Minimum compliance MUST takes care

Smells like negotiation to me, so you need anything reserved.  All good.

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Thu, 10 Jul 2014 19:56:33 +0000

In message <[email-masked]>, Martin Thomson w

>Smells like negotiation to me, so you need anything reserved.  All good.

That is not a negotiation, that is an announcement of capability.

(If you want to see what negotiation looks like, stare at a PPP
connection trying to get its act together.)

And please notice that all I asked for was that we reserved some bits, not
that we do the entire mechanism now.