Subject: Re: draft-ietf-httpbis-header-compression-09, 3.3.2. Header Table

From: Martin Thomson <[email-masked]>
Date: Fri, 1 Aug 2014 09:31:56 -0700

On 1 August 2014 03:35, Kari Hurtta <[email-masked]> wrote:
>
> » The header table is initially empty.
>
> I guess that "initially" means "beginning of HTTP/2 connection".
>
> That is not very clear.

https://github.com/http2/http2-spec/pull/577

---

From: RUELLAN Herve <[email-masked]>
Date: Fri, 29 Aug 2014 16:44:10 +0000

The text in 3.3.2 was a remaining of the previous ordering of the Header Table and Static Table.
This is corrected by: https://github.com/http2/http2-spec/commit/28807c0e9aec75d6b313e0dd24bcfd0f4c01bbce

Hervé.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Kari Hurtta
> Sent: vendredi 1 août 2014 09:21
> To: Roberto Peon; RUELLAN Herve
> Cc: Kari Hurtta; HTTPBIS working group mailing list
> Subject: draft-ietf-httpbis-header-compression-09, 3.3.2. Header Table
> 
> HPACK - Header Compression for HTTP/2
> draft-ietf-httpbis-header-compression-09
> July 31, 2014
> 
> 
> 3.3.2. Header Table
> http://tools.ietf.org/html/draft-ietf-httpbis-header-compression-09#section-
> 3.3.2
> 
> »   The header table consists of a list of header fields maintained in
> »   first-in, first-out order.  The first and newest entry in a header
> »   table is always at index 1, and the oldest entry of a header table is
> »   at the index corresponding to the number of entries in the header
> »   table.
> 
> ( So here "index" is different than "index" on Index Address Space. )
> 
> 3.3.3. Index Address Space
> http://tools.ietf.org/html/draft-ietf-httpbis-header-compression-09#section-
> 3.3.3
> 
> »   Indices strictly greater than the length of the static table refer to
> »   elements in the header table (see Section 3.3.2).  The length of the
> »   static table is subtracted to find the index into the header table.
> 
> 
> So in terms of *Index Address Space*, the first and newest entry in a
> header table is always at index (length of the static table) + 1.
> 
> And The oldest entry of a header table in terms of *Index Address Space*
> is at the index corresponding (length of the static table) + (length of
> the header table).
> 
> »        <----------  Index Address Space ---------->
> »        <-- Static  Table -->  <-- Header  Table -->
> »        +---+-----------+---+  +---+-----------+---+
> »        | 1 |    ...    | s |  |s+1|    ...    |s+k|
> »        +---+-----------+---+  +---+-----------+---+
> »                               ^                   |
> »                               |                   V
> »                        Insertion Point      Dropping Point
> 
> / Kari Hurtta