Subject: Re: [http2-spec] Hpack optimization (#587)

From: Greg Wilkins <[email-masked]>
Date: Wed, 13 Aug 2014 17:58:30 +1000

Move this here as don't want to discuss on issue comments:

On 13 August 2014 17:23, Mark Nottingham <[email-masked]> wrote:

> application/x-javascript is non-standard; I don't think we want to
> encourage that.
>
> text/html; charset=utf8 might be more the go.
>
>
images, css and javascript were all more frequent than html.   But if none
of them have good standard content-types, then I'm OK to favour text/html;
charset=utf8

A few more:
>
>    - If we're going to include expect, why not 100-continue?
>    - If we're going to include access-control-allow-origin, it'd be nice
>    to confirm with the W3C that this is going to stick (they've had a few
>    tries at CORS), and that there's not anything else on the horizon.
>    - If-Unmodified-Since? Really?
>    - Max-Forwards? Considering we're no longer hop-by-hop, that's a good
>    trick.
>    - Refresh is non-standard, and badly interoperable. Shouldn't be
>    encouraged.
>    - Uhhhhh, we don't allow Transfer-Encoding; why is it in the static
>    table?
>
>
All good points..... I'm starting to feel that these all combined warrant a
breaking change in themselves... but no hurry to do so.

cheers

-- 
Greg Wilkins <[email-masked]>
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Aug 2014 16:49:22 +0000

What’s surprising about If-Unmodified-Since?  Not for a GET, sure, but perfectly reasonable for a PUT.

From: Greg Wilkins [mailto:[email-masked]]
Sent: Wednesday, August 13, 2014 12:59 AM
To: HTTP Working Group
Subject: Re: [http2-spec] Hpack optimization (#587)

On 13 August 2014 17:23, Mark Nottingham <[email-masked]<mailto:[email-masked]>> wrote:

application/x-javascript is non-standard; I don't think we want to encourage that.

images, css and javascript were all more frequent than html.   But if none of them have good standard content-types, then I'm OK to favour text/html; charset=utf8

A few more:

  *   If we're going to include expect, why not 100-continue?
  *   If we're going to include access-control-allow-origin, it'd be nice to confirm with the W3C that this is going to stick (they've had a few tries at CORS), and that there's not anything else on the horizon.
  *   If-Unmodified-Since? Really?
  *   Max-Forwards? Considering we're no longer hop-by-hop, that's a good trick.
  *   Refresh is non-standard, and badly interoperable. Shouldn't be encouraged.
  *   Uhhhhh, we don't allow Transfer-Encoding; why is it in the static table?

All good points..... I'm starting to feel that these all combined warrant a breaking change in themselves... but no hurry to do so.
cheers

--
Greg Wilkins <[email-masked]<mailto:[email-masked]>>
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 14 Aug 2014 10:45:42 +1000

> What’s surprising about If-Unmodified-Since?  Not for a GET, sure, but perfectly reasonable for a PUT.

If-Match is far more useful for a PUT, since it can be explicitly strong. It's also just not that comment AFAIK.

Again, not a big deal. 

> 	• If we're going to include expect, why not 100-continue?
> 	• If we're going to include access-control-allow-origin, it'd be nice to confirm with the W3C that this is going to stick (they've had a few tries at CORS), and that there's not anything else on the horizon.
> 	• If-Unmodified-Since? Really?
> 	• Max-Forwards? Considering we're no longer hop-by-hop, that's a good trick.
> 	• Refresh is non-standard, and badly interoperable. Shouldn't be encouraged.
> 	• Uhhhhh, we don't allow Transfer-Encoding; why is it in the static table?
>  

--
Mark Nottingham   https://www.mnot.net/