Subject: Re: Call for Adoption: draft-hutton-httpbis-connect-protocol-00

From: Mark Nottingham <[email-masked]>
Date: Wed, 6 Aug 2014 14:34:24 +1000

I'm not hearing any pushback, so we'll adopt the document.

Martin, are you willing to continue editing?

Regards,

On 29 Jul 2014, at 4:38 pm, Mark Nottingham <[email-masked]> wrote:

> <http://tools.ietf.org/html/draft-hutton-httpbis-connect-protocol-00>
> 
> In Toronto, we had a discussion about adopting this document as a WG document:
>  <https://github.com/httpwg/wg-materials/blob/gh-pages/ietf90/minutes.md#draft-hutton-httpbis-connect-protocol>
> 
> One concern raised there was regarding the model for the extension; i.e., by effectively making support for webrtc (or any other protocol) on proxy opt-in rather than opt-out, it may cause problems as more traffic goes over proxies. However, the HTTP folks in the room didn't seem to concerned about this, since bad actors were already able to (ab)use CONNECT tunnels with impunity (effectively.
> 
> Another concern briefly mentioned was that such an extension might inhibit protocol evolution; e.g., if a firewall whitelists what tunnelled protocols it accepts, it might be that we're stuck advertising "h2" in the future. However, there didn't seem to be strong concern here, since ALPN negotiation is a separate step, and HTTP can choose to omit this header when using CONNECT for its own purposes.
> 
> With that context in place, it seemed like there was general support in the room for adopting this spec. Does anyone else have additional thoughts / concerns? 

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin Thomson <[email-masked]>
Date: Wed, 6 Aug 2014 11:30:34 -0700

> Martin, are you willing to continue editing?

Andy has the token here, I'm just helping.  As long as that's OK with
you (I don't really want to be primarily responsible for all the
drafts).

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 6 Aug 2014 19:45:22 +0000

I am ok with continuing to edit if that is ok with everyone.

Andy

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 7 Aug 2014 09:24:34 +1000

Sounds like we have a plan. I'll flip the bit on the draft; Andrew, do you have XML or Markdown source we can get into the repo? 

Regards,

---

From: Martin Thomson <[email-masked]>
Date: Wed, 6 Aug 2014 20:27:48 -0700

> Sounds like we have a plan. I'll flip the bit on the draft; Andrew, do you have XML or Markdown source we can get into the repo?

https://github.com/andyhutton/http-connect-protocol