Subject: #601: HTTP2-Settings header field name

From: Mark Nottingham <[email-masked]>
Date: Fri, 26 Sep 2014 16:45:48 +0100

<https://github.com/http2/http2-spec/issues/601>

Roy commented that it’d be nice if this header name was shorter; my response was that it is only sent once, so it’s not critical, and he seemed to agree.

Does anyone feel strongly about this? If not, we’ll close as WONTFIX.

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Matthew Kerwin <[email-masked]>
Date: Sat, 27 Sep 2014 07:46:41 +1000

On 27/09/2014, Mark Nottingham <[email-masked]> wrote:
> Roy commented that it’d be nice if this header name was shorter; my response
> was that it is only sent once, so it’s not critical, and he seemed to
> agree.
>

Works for me.

-- 
  Matthew Kerwin
  http://matthew.kerwin.net.au/

---

From: Amos Jeffries <[email-masked]>
Date: Sat, 27 Sep 2014 18:02:42 +1200

On 27/09/2014 9:46 a.m., Matthew Kerwin wrote:
>> Roy commented that it’d be nice if this header name was shorter;
>> my response was that it is only sent once, so it’s not critical,
>> and he seemed to agree.

I disagree that it will be sent only once. Middleware is likely to be
sending it multiple times as multiple connections to an origin are used.

Having said that, the occurances should not be very many even with
that. So WFM too.

>> Does anyone feel strongly about this? If not, we’ll close as

Amos

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Sep 2014 17:52:28 +0100

Closing.

Thanks,

On 27 Sep 2014, at 7:02 am, Amos Jeffries <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2.0.22 (MingW32)
> 
> iQEcBAEBAgAGBQJUJlMBAAoJELJo5wb/XPRjYSAH/i6J0WwC4Ssl/2WUjDxrvXtH
> IbyXGGm+E+j78b3C00GJss5Tzl98PvtkZSmAlmuh/0l7J063W/k5RHEUTOpd7o8G
> I1Y+9XFFbuUipnEVYQSykkQ77Twy2nPyvJLsVkbSyRKGJEk73aB/nnZWU1uvCRk3
> 8rJXKA8X9Br0vh8uiYMWJJ+CjGe9fcFIlQQnGbOAXqewuNJCz3ybgvjETkX/3mnZ
> vtcDAb7Pc3IVh/atufqmuwHFicV+8xeoDVg8gGV4gLYJm2gyZxbUN6rzKD5+Vber
> 30M/bLlQ+SoQ2otLyfIjQQ2wDOex/anvrSU9yM5E7s/NtkUiOHNoNTIMHXkbE0E=
> =51L1
> -----END PGP SIGNATURE-----
>