Subject: RE: HPACK WGLC feedback

From: RUELLAN Herve <[email-masked]>
Date: Mon, 1 Sep 2014 07:49:51 +0000

It's the remnant of an evolution process that didn't get far enough. I'm going to change this if it's not too much trouble.

Hervé.

> -----Original Message-----
> From: Willy Tarreau [mailto:[email-masked]]
> Sent: dimanche 31 août 2014 17:41
> To: Julian Reschke
> Cc: HTTP Working Group
> Subject: Re: HPACK WGLC feedback
> 
> Hi Julian
> 
> On Sun, Aug 31, 2014 at 03:46:14PM +0200, Julian Reschke wrote:
> > Hi there,
> >
> > so I just read this (the current version checked into git) end-to-end,
> > and don't have any substantial comments. I might if I actually tried to
> > implement it, though.
> >
> > The one *editorial* comment I have is that having the two tables called
> > "static table" and "header table" is very confusing. Is there a reason
> > why it's not simply "static table" and "dynamic table"?
> 
> I agree with you, and it's how I noted it on paper while thinking about
> implementation, because I had the same concerns.
> 
> Willy
>

---

From: Pavel Rappo <[email-masked]>
Date: Mon, 1 Sep 2014 11:00:57 +0100

> The one *editorial* comment I have is that having the two tables called
"static table" and "header table" is very confusing.
> Is there a reason why it's not simply "static table" and "dynamic table"?

​+1 That's exactly how I named corresponding classes in my implementation.​

On Sun, Aug 31, 2014 at 2:46 PM, Julian Reschke <[email-masked]>
wrote:

> Hi there,
>
> so I just read this (the current version checked into git) end-to-end, and
> don't have any substantial comments. I might if I actually tried to
> implement it, though.
>
> "static table" and "header table" is very confusing. Is there a reason why
> it's not simply "static table" and "dynamic table"?
>
> Best regards, Julian
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Sep 2014 09:31:46 +0300

That seems reasonable, Herve; I also think this is editorial.

Cheers,

--
Mark Nottingham   http://www.mnot.net/