Subject: Re: h2 header field names

From: Louis Ryan <[email-masked]>
Date: Thu, 23 Oct 2014 20:31:12 +0000

Was the intent of the edit

https://github.com/http2/http2-spec/commit/52c32efea314ca6bd504be6f08e91e895add7bc9

to prohibit 0x0 & 0xa in scenarios where a proxy or server is not
interpreting HTTP2 as HTTP/1.1?

The language is certainly stronger than the earlier version.

http://tools.ietf.org/html/draft-ietf-httpbis-http2-14#section-10.3

which seems only to apply to the HTTP2 -> HTTP/1.1 case.

Encoding efficiency questions aside why not predicate this constraint on
either the :scheme being http/https or the proxies desire to interpret some
other :scheme as http.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Oct 2014 13:51:35 -0700

> interpreting HTTP2 as HTTP/1.1?

0x0 and 0xa are already prohibited.  We're really only really
reiterating the point.