Subject: WPD and Multiple Proxies

From: Salvatore Loreto <[email-masked]>
Date: Mon, 3 Nov 2014 13:26:17 +0000

Hi there

proxies is on agenda for the httpbis Wednesday session in Honolulu.
WPD draft [1] will be presented and discussed, so here some input:

Users take the same device to multiple networks.  
Proxies that provide optimization (caching and content transformation) benefit a great deal from proximity to users.  
And the authority (in the WPD sense) might change between networks.

Roaming users are one example of who might disproportionately benefit from optimization.  Being able to configure a proxy while roaming without altering the configuration that is used while at home.  This is also potentially relevant for users who migrate between cellular networks and WiFi.

Users that select a proxy for optimization might still be required to accept the use of a proxy at their workplace or captive network of choice.

The trick here is balancing the requirements of different use cases.
  
Proxies that provide privacy features need to be used exclusively, otherwise they could risk packet sniffing or pervasive monitoring by other nodes and risk the same sort of exposure that brought down the Silk Road.  That's at odds with this scenario and we'd obviously need measures to ensure that this doesn't fail catastrophically.

Any thoughts from the group would be great.

br
Salvatore

[1] http://tools.ietf.org/html/draft-nottingham-web-proxy-desc-01

---

From: Roland Zink <[email-masked]>
Date: Mon, 03 Nov 2014 18:02:43 +0100

> Users that select a proxy for optimization might still be required to accept the use of a proxy at their workplace or captive network of choice.
Do you suggest to create dynamic proxy chains? E.g. the proxy at the 
workplace go out to the optimization proxy to fulfill user requests.
> Proxies that provide privacy features need to be used exclusively, otherwise they could risk packet sniffing or pervasive monitoring by other nodes and risk the same sort of exposure that brought d…
For a workplace proxy it may not be an option to allow privacy features, 
so I guess there are conflicting requirements.
> [1] http://tools.ietf.org/html/draft-nottingham-web-proxy-desc-01
Regards,
Roland

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 3 Nov 2014 20:32:33 +0000

Hi Roland,

thanks for the comments
see in line

On Nov 3, 2014, at 7:02 PM, Roland Zink <[email-masked]> wrote:

> Do you suggest to create dynamic proxy chains? E.g. the proxy at the workplace go out to the optimization proxy to fulfill user requests.

yes the idea is to investigate the possibility (i.e. the use case) to chain the proxies.
The fact that a particular context forces the user to accept a particular proxy in between, should not preclude \ from using
also proxies that the user has deliberately chosen to have in place for optimisation purposes or other kind of services (i.e. malware scanning).

> For a workplace proxy it may not be an option to allow privacy features, so I guess there are conflicting requirements.

That is an interesting point, that makes thinks even more tricky

br
Salvatore