Subject: Improving the state machine

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Nov 2014 13:22:15 -0800

Jonathan Thackray has suggested some editorial changes to the state
machine.  These improve the clarity and correct an error regarding the
reservation of streams for push.

https://github.com/http2/http2-spec/pull/658

I plan to accept them unless I hear screams.

---

From: Greg Wilkins <[email-masked]>
Date: Thu, 27 Nov 2014 10:28:10 +1100

Well, the state diagram is essentially a fantasy either way: like TCP with
CLOSE_WAIT and TIME_WAIT left out, and don't even mention CONTINUATIONs!

But other than than old lost battle.... I think the send/recv
clarifications are good ones.    Not such a big fan of the use of the word
"either", which looks like it applies to the frame type and not to the send
or recv.   Maybe "send/recv" would be better than "either".

cheers

-- 
Greg Wilkins <[email-masked]>  @  Webtide - *an Intalio subsidiary*
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Matthew Kerwin <[email-masked]>
Date: Thu, 27 Nov 2014 09:51:08 +1000

On 27 November 2014 at 09:28, Greg Wilkins <[email-masked]> wrote:

> <snip>
> ​​
I agree, the word "either" isn't great. Since the space in the diagram is
so limited, I'd be tempted to suggest symbols for send/recv/both. However
that would get messy fast.

Why not leave out the "either", and reorder the two ambigious cases: "R /
send ES", "R / recv ES" ?

If that's too finicky, this PR is still an improvement.

-- 
  Matthew Kerwin
  http://matthew.kerwin.net.au/

---

From: RUELLAN Herve <[email-masked]>
Date: Thu, 27 Nov 2014 07:59:37 +0000

I just gave a try at the send/recv clarifications.

https://github.com/http2/http2-spec/pull/659

Hervé.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Matthew Kerwin
> Sent: jeudi 27 novembre 2014 00:51
> To: Greg Wilkins
> Cc: Martin Thomson; HTTP Working Group
> Subject: Re: Improving the state machine
> 
> 	But other than than old lost battle.... I think the send/recv clarifications
> are good ones.    Not such a big fan of the use of the word "either", which looks
> like it applies to the frame type and not to the send or recv.   Maybe
> "send/recv" would be better than "either".
> 
> 	​
> 
> 
> 
> I agree, the word "either" isn't great. Since the space in the diagram is so
> limited, I'd be tempted to suggest symbols for send/recv/both. However that
> would get messy fast.
> 
> Why not leave out the "either", and reorder the two ambigious cases: "R / send
> ES", "R / recv ES" ?
>

---

From: Matthew Kerwin <[email-masked]>
Date: Thu, 27 Nov 2014 18:28:59 +1000

> https://github.com/http2/http2-spec/pull/659
Fine with me.

---

From: Jonathan Thackray <[email-masked]>
Date: Thu, 27 Nov 2014 14:32:51 +0000

Thanks Hervé,

> I just gave a try at the send/recv clarifications.

Looks good to me. +1.

Thanks,
Jonathan.

---

From: Greg Wilkins <[email-masked]>
Date: Fri, 28 Nov 2014 08:27:04 +1100

> I just gave a try at the send/recv clarifications.

nice