Subject: Re: impact of 9.2.2 changes and discussions on opportunistic encryption draft

From: Martin Thomson <[email-masked]>
Date: Mon, 3 Nov 2014 12:01:36 -0800

On 31 October 2014 11:56, Erik Nygren <[email-masked]> wrote:
> If everyone sticks with #1 or #2 and only uses #3 for the HTTP-TLS case
> we're fine.

That's not an *if*, that's a *requirement*.  You can't have a
situation where both peers have different expectations regarding a
critical feature like authentication.

If -encryption fails to make that clear, let's work on that.

---

From: Erik Nygren <[email-masked]>
Date: Mon, 3 Nov 2014 15:42:02 -0500

> If -encryption fails to make that clear, let's work on that.

Is it clear to people how the different drafts interact?
In particular, if someone were to decide to not implement -encryption
but implement with altsvc then you'd end up with them using #3
all of the time in a way that is indistinguishable.

        Erik