Subject: WPD Discovery Options

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Mon, 3 Nov 2014 13:58:49 +0000

Hi,

Taking advantage of Salva's recent message, let me come again with some more input for WPD.

WPD discusses discovery of proxies using a well known URI. Automatic proxy discovery may be desirable by some. The choice of an automatic proxy discovery method should be decided by the client. Below is a selection of possible methods:

mDNS / DNS-SD: the best all round solution. DNS can query a well-known/predefined WPD hostname(s) and is currently supported by wide variety of clients. One drawback is that DNS can be spoofed so would require a trusted network.

PDP/PDN Context: best for working with a mobile network. It is also possible to use the PDP/PDN signalling also over WiFI etc for configuring parameters, though in WiFi scenarios tethering can become an issue: a client could detect the network type to the next hop which could be a tethered wifi connection but onwards from this point could be any type of network. (Any suggested solutions to this are welcome!)

If a client is looking for one universal solution a DNS based solution probably would be preferable, though the particularities of 3GPP mobile networks make extremely advisable to use PDP/PDN Context in those environments

It would be great to find out what the group feels about this and any other methods that you might think are a good fit for one or more types of networks.

Be goode,

--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Martin Nilsson" <[email-masked]>
Date: Tue, 04 Nov 2014 16:55:45 +0100

On Mon, 03 Nov 2014 14:58:49 +0100, DIEGO LOPEZ GARCIA  
<[email-masked]> wrote:

>>
>
>> WPD discusses discovery of proxies using a well known URI. Automatic  
>> proxy discovery may be desirable by some. The choice of
> an automatic proxy discovery method should be decided by the client.  
> Below is a selection of possible methods:
>
> mDNS / DNS-SD: the best all round solution. DNS can query a  
> well-known/predefined WPD hostname(s) and is currently supported
> by wide variety of clients. One drawback is that DNS can be spoofed so  
> would require a trusted network.
>
> PDP/PDN Context: best for working with a mobile network. It is also  
> possible to use the PDP/PDN signalling also over WiFI etc
> for configuring parameters, though in WiFi scenarios tethering can  
> become an issue: a client could detect the network type to the >next hop  
> which could be a tethered wifi connection but onwards from this point  
> could be any type of network. (Any suggested solutions
> to this are welcome!)

I think it is important to find a single method that works everywhere, if  
possible. Once that is in place, it would be possible for other actors to  
optimize that for specific domains. E.g. if we standardize on a DNS based  
discovery, you could push the relevant records to the device in PDP  
context. Higher layer code still only needs to know about a single method.

/Martin Nilsson

-- 
Using Opera's mail client: http://www.opera.com/mail/

---

From: Amos Jeffries <[email-masked]>
Date: Wed, 05 Nov 2014 07:20:55 +1300

On 5/11/2014 4:55 a.m., Martin Nilsson wrote:
> WPD discusses discovery of proxies using a well known URI.
> Automatic proxy discovery may be desirable by some. The choice of
> an automatic proxy discovery method should be decided by the
> client. Below is a selection of possible methods:
> 
> well-known/predefined WPD hostname(s) and is currently supported by
> wide variety of clients. One drawback is that DNS can be spoofed so
> possible to use the PDP/PDN signalling also over WiFI etc for
> configuring parameters, though in WiFi scenarios tethering can
> become an issue: a client could detect the network type to the next
> hop which could be a tethered wifi connection but onwards from this
> point could be any type of network. (Any suggested solutions to
> this are welcome!)
> 
> 
> I think it is important to find a single method that works
> everywhere, if possible. Once that is in place, it would be
> possible for other actors to optimize that for specific domains.
> E.g. if we standardize on a DNS based discovery, you could push the
> relevant records to the device in PDP context. Higher layer code
> still only needs to know about a single method.

At first look SRV records under the .local domain should be
serviceable in all networking situations.

As you say the records or results can be optimized by pushing via any
other means appropriate to the specific use-case.

AYJ

---

From: Martin Thomson <[email-masked]>
Date: Tue, 4 Nov 2014 10:24:44 -0800

On 4 November 2014 07:55, Martin Nilsson <[email-masked]> wrote:
> discovery, you could push the relevant records to the device in PDP context.
> Higher layer code still only needs to know about a single method.

I think that if anything has a chance of working everywhere, it would
be a DNS-based approach (intentionally handwaving about RFC 6762
here).  My experience here is that the operational hurdles are
significant.  Discovery is hard in general because it relies on
properties of the network below the IP layer.  That means dealing with
all sorts of wireline and wireless access network technologies, the
operational considerations imposed by each, and all the complications
of middleboxes on those networks.

>From that perspective, it's easy to see how a "just rely on a name
being entered" is an easy conclusion to reach: you can't say that it
runs afoul of the morass

That's assuming that we can agree in principle that discovery is worth
pursuing; I'm not certain that we all agree on what the desired
properties are regarding authorization.  This is always a challenging
topic of discussion here: we don't know how to do UX, but it's also
critical in determining the properties of any action that touches
users.

---

From: Dave Dolson <[email-masked]>
Date: Tue, 4 Nov 2014 18:53:59 +0000

I'm just seeing this at a high level, so I'll just throw this idea out there:

Don't bother with DNS names; you could use a well-known multicast IP address, similar to other discovery protocols.
E.g., IPv6 multicast address FF05::1:3 is used to discover DHCP agents.

Or use a dedicated anycast IP address. 
E.g., 192.0.0.1 used in RFC 6333.

-Dave

-----Original Message-----
From: Amos Jeffries [mailto:[email-masked]] 
Sent: Tuesday, November 04, 2014 1:21 PM
To: [email-masked]
Subject: Re: WPD Discovery Options

AYJ

---

From: [email-masked]
Date: Wed, 5 Nov 2014 09:19:01 +0100 (CET)

De: "Martin Thomson"

> of middleboxes on those networks.

My experience is the same. Unless you have a technically homogeneous centralized network any solution that relies on network properties is not practical. Corporation-side part of the network growth will always be organic and omit such niceties as "advanced" network properties (for very basic understandings of "advanced").

Even DNS is not always reliable because local entities will deploy local caches that ignore original DNS TTLs (in the name of speed) or even override part of the naming.

DNS is the least bad solution but it is a very good idea to limit its scope as much as possible and keep the load balancing properties (for example) inside the WPD file. And when DNS fails, being able to replace discovery with pre-configured settings in the web client can be a lifesaver (otherwise people compound the problem with another layer of DNS overrides).

-- 
Regards,