Subject: What is the rough plan from here?

From: Greg Wilkins <[email-masked]>
Date: Fri, 21 Nov 2014 10:39:48 +1100

What is the rough plan from here?

A h2-16 draft? then?

-- 
Greg Wilkins <[email-masked]>  @  Webtide - *an Intalio subsidiary*
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 21 Nov 2014 12:05:56 +1100

Hey Greg,

Good question.

I'm going to review the discussion and hopefully declare consensus on 9.2.2 today (my time).

We also have <https://github.com/http2/http2-spec/issues/645>, but I think that's just a matter of making a detailed proposal and getting the text in; I don't imagine it'll be controversial.

Once Martin is back, we'll roll h2-16 and hpack-10. 

While the diffs between h2-14 and the purported -16 are not small, I think the bulk of them are editorial, and the larger changes are well-understood by the Working Group, so another WGLC is not necessary. Likewise for hpack-10.

That said, we'll take at least a few days to make sure everyone understand the changes and has a chance to read through.

Assuming we get through that, I'll declare consensus to ship h2-16 and hpack-10 to the IESG, where IETF LC will begin.

Regards,

> On 21 Nov 2014, at 10:39 am, Greg Wilkins <[email-masked]> wrote:
> 
> 
> Greg Wilkins <[email-masked]>  @  Webtide - an Intalio subsidiary

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Nov 2014 14:18:06 +0100

> That said, we'll take at least a few days to make sure everyone understand the changes and has a chance to read through.

FWIW:

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-http2-latest-from-wglc.diff.html>

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-header-compression-latest-from-previous.diff.html>

So yes, the diffs aren't small at all :-)

Best regards, Julian

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Nov 2014 21:54:20 +0000

FWIW, the diff is long, but that happens when you renumber figures. And
virtually all of the changes are editorial in nature [1].

While it is always true that any document would benefit from more review,
my sense is that we could spend another 6 months, find a continuous stream
of minor niggles, and still be in the same state. Of course, we would be 6
months less relevant too.

The substantial technical issues stopped a while back. It is past time to
move on.

[1] I probably need to add to the change log. I'm in the process of doing a
check.

On Mon, Nov 24, 2014, 03:22 Julian Reschke <[email-masked]> wrote:

<
http://greenbytes.de/tech/webdav/draft-ietf-httpbis-http2-latest-from-wglc.diff.html

<
http://greenbytes.de/tech/webdav/draft-ietf-httpbis-header-compression-latest-from-previous.diff.html