Subject: HTTP/2 status, IPR

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Dec 2014 10:26:34 +1100

Everyone,

I believe that the HTTP/2 and HPACK documents are ready for submission to the IESG. We have a small number of editorial issues that have been brought up since last review, but there will doubtless be other changes brought about by review; they can be incorporated then. I need to finish the shepherd's writeups, and then will be submitting the documents.

As part of that, I want to bring everyone's attention to the IPR declarations already made:

* Canon - https://datatracker.ietf.org/ipr/2015/
* Google - https://datatracker.ietf.org/ipr/1737/
* Microsoft - https://datatracker.ietf.org/ipr/2122/

The Canon and Google declarations are required by the process, since their employees had personal knowledge of the declared IPR, and were document editors. My understanding is that these declarations are currently being updated to apply to our most current documents. 

The Google declaration has long been linked to the HTTP/2 document in the datatracker, so everyone should be aware of it already.

The Canon declaration was made against draft-ruellan-headerdiff, and I've just updated HPACK to indicate that it replaces that document in the datatracker (thereby linking in the declaration):
  https://datatracker.ietf.org/doc/draft-ietf-httpbis-header-compression/

If you haven't seen this declaration before, please have a look.

The Microsoft declaration was not required by the process, so I want to thank them for making it. If anyone else would like to make a declaration (hopefully with a generous license!), I would encourage them to do so.

Regards,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Dec 2014 10:38:10 +1100

> * Google - https://datatracker.ietf.org/ipr/1737/

Should be:

https://datatracker.ietf.org/ipr/1692/

Cheers,

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 19 Dec 2014 10:38:51 +1100

... and here's Google's updated disclosure:
  https://datatracker.ietf.org/ipr/2506/

Cheers,

> On 16 Dec 2014, at 10:26 am, Mark Nottingham <[email-masked]> wrote:
> 
> Everyone,
>