Subject: Use of TLS Features in HTTP2

From: WeiXinpeng <[email-masked]>
Date: Wed, 24 Dec 2014 20:22:32 +0800 (CST)

Hi all,
When I review HTTP2 protocol draft, I find that for the description of "Use of TLS Feature" in sectiion 9.2, there is some change from v15 to v16 as following:
In v15 it says:
"Implementations of HTTP/2 MUST support TLS 1.2 [TLS12] for HTTP/2
over TLS. " 
But in v16 it says:
"Implementations of HTTP/2 MUST use TLS [TLS12] version 1.2 or higher
for HTTP/2 over TLS." (v16)
Maybe I have missed some discussion in the list about this, but could you someone tell me the reason why change "support" to "use"?
For the description in v16, how should I interpret the description: 
Option 1: HTTP/2 MUST use TLS, and the versioin of TLS MUST be 1.2 or higher.
Option 2: If people want to use HTTP/2 over TLS, then the version of TLS MUST be 1.2 or higher.
Should I take option 1 or option 2?

it will be appreciated if some people can give some clarifications about what I mentioned here. Thanks!

Regards,
-Xinpeng

---

From: FERNANDO PASCUAL BLANCO <[email-masked]>
Date: Fri, 26 Dec 2014 14:15:22 +0000

Xinpeng,

Option 2 is the correct one.

Cheers,
Fer

Sent from my iPhone

On 24 Dec 2014, at 13:28, WeiXinpeng <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

In v15 it says:

"Implementations of HTTP/2 MUST support TLS 1.2 [TLS12<http://tools.ietf.org/html/draft-ietf-httpbis-http2-15#ref-TLS12>] for HTTP/2
over TLS. "
But in v16 it says:
"Implementations of HTTP/2 MUST use TLS [TLS12<http://tools.ietf.org/html/draft-ietf-httpbis-http2-16#ref-TLS12>] version 1.2 or higher
for HTTP/2 over TLS." (v16)
Maybe I have missed some discussion in the list about this, but could you someone tell me the reason why change "support" to "use"?
For the description in v16, how should I interpret the description:
Option 1: HTTP/2 MUST use TLS, and the versioin of TLS MUST be 1.2 or higher.
Option 2: If people want to use HTTP/2 over TLS, then the version of TLS MUST be 1.2 or higher.
Should I take option 1 or option 2?

Regards,
-Xinpeng

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Walter H." <[email-masked]>
Date: Sat, 27 Dec 2014 09:33:35 +0100

which means the other way 'round:

if a client (user agent) DOES NOT support TLS 1.2, the server MUST use 
HTTP/1.1 ...

On 26.12.2014 15:15, FERNANDO PASCUAL BLANCO wrote:
>> When I review HTTP2 protocol draft, I find that for the description 
>> of "Use of TLS Feature" in sectiion 9.2, there is some change from 
>> v15 to v16 as following:
>>   In v15 it says:
>> "Implementations of HTTP/2 MUST supportTLS 1.2 [TLS12 
>> <http://tools.ietf.org/html/draft-ietf-httpbis-http2-15#ref-TLS12>] 
>> for HTTP/2
>> over TLS. "
>> But in v16 it says:
>> "Implementations of HTTP/2 MUST useTLS [TLS12 
>> <http://tools.ietf.org/html/draft-ietf-httpbis-http2-16#ref-TLS12>] 
>> version 1.2 or higher
>> Maybe I have missed some discussion in the list about this, but could 
>> you someone tell me the reason why change "support" to "use"?