Subject: draft-ietf-httpbis-http2-latest, "Abstract"

From: Tim Wright <[email-masked]>
Date: Mon, 30 Mar 2015 15:45:42 +0000

​Would it be possible to volunteer to work on the typography for this document? I was reading through it today and found it generally difficult​ to get through. I think some fonts and small type changes could go a long way for this (and other similar documents).

<http://http2.github.io/http2-spec/#rfc.abstract <http://http2.github.io/http2-spec/#rfc.abstract>>:

​Best,
Tim​

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Mar 2015 12:50:02 -0500

On 30 March 2015 at 10:45, Tim Wright <[email-masked]> wrote:
> Would it be possible to volunteer to work on the typography for this
> document? I was reading through it today and found it generally difficult to
> get through. I think some fonts and small type changes could go a long way
> for this (and other similar documents).

We take pull requests here: https://github.com/http2/http2-spec

Better typography is - as you might expect - very low on the priority list.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 31 Mar 2015 10:55:04 +1100

Hi Tim,

There are a lot of background projects to improve the presentation of RFCs out there; it’s probably best to get involved in one (or several) of them, rather than any one spec (since we use external stylesheets).

A few links that might interest you:

## Julian Rescke’s XSLT — <https://github.com/http2/http2-spec/blob/master/lib/rfc2629.xslt>

This is what produced the spec you link to below. Last I heard, Julian doesn’t have a definitive repository for this; Julian?

## My Bootstrap-flavoured XSLT — <https://github.com/mnot/rfcbootstrap>

Based upon Julian’s, but grafting in Boostrap for presentation. See <http://httpwg.github.io/specs/rfc7231.html> for an example. I’m happy to take issues / pull requests (it definitely needs more work).

## xml2rfc — <http://xml2rfc.ietf.org>

Python program that produces HTML output, often considered to be the “definitive” (if very ugly) output.

## RFC future format — <http://www.rfc-editor.org/rse/FormatFAQ.html>

The RFC Editor is running a program to change the format of RFCs itself, and last I heard, the definitive format would be XML, allowing different stylesheets to be used to present it. Participating here may give you the most bang for your buck in the long term.

Cheers,

> On 31 Mar 2015, at 2:45 am, Tim Wright <[email-masked]> wrote:
> 
> <http://http2.github.io/http2-spec/#rfc.abstract>:
> 
> ​Best,
> Tim​
> 

--
Mark Nottingham   https://www.mnot.net/