Subject: Re: [Editorial Errata Reported] RFC7230 (4281)

From: Demian Brecht <[email-masked]>
Date: Fri, 27 Feb 2015 18:33:28 +0000

> On Feb 27, 2015, at 10:13 AM, Roy T. Fielding <[email-masked]> wrote:
> What we
> have here is a summary of the field's semantics given the message framing
> algorithm, as described in the remainder of that section and 3.3.3.

Thanks for that and the consideration, the distinction in the intent of the paragraphs does indeed clear up the confusion.

---

From: Demian Brecht <[email-masked]>
Date: Fri, 27 Feb 2015 05:54:52 +0000

> On Feb 26, 2015, at 9:36 PM, Mark Nottingham <[email-masked]> wrote:
> I think Roy wrote this text, but from my standpoint, it's REJECT -- Content-Length defines message length under these conditions no matter what the UA should or should not do.

My interpretation is that this alludes that it is valid for a user agent to specify a the size of a representation of a resource even though in practice, such  information resides solely with and is sent in outbound messages from the origin server. I’m looking to simply remove the need for interpretation (albeit minor as the following paragraph /does/ clarify) for future readers.