Subject: draft-ietf-httpbis-auth-info

From: Mark Nottingham <[email-masked]>
Date: Tue, 3 Mar 2015 13:49:45 +1100

Julian has disposed of all of the issues raised during WGLC, and there's only one editorial issue left (regarding RFC2119 language).

Julian, could you please generate a new WG draft (once you've figured out that last issue) so that we can take a look at it (and the diffs)?

Regards,

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Mar 2015 07:37:54 +0100

> Julian has disposed of all of the issues raised during WGLC, and there's only one editorial issue left (regarding RFC2119 language).

The ones I added in github. Amos, are you ok with the changes I made?

> Julian, could you please generate a new WG draft (once you've figured out that last issue) so that we can take a look at it (and the diffs)?

Current drafts are here: 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-auth-info-latest-from-previous.diff.html>.

But yes, I can post a new draft any time.

Best regards, Julian

---

From: Amos Jeffries <[email-masked]>
Date: Tue, 03 Mar 2015 20:01:20 +1300

On 3/03/2015 7:37 p.m., Julian Reschke wrote:
>> Julian has disposed of all of the issues raised during WGLC, and
>> there's only one editorial issue left (regarding RFC2119 language).
> 

In the new text for section 4 copied from RFC7235:

"
  Hence, in such a configuration, it will appear as if	
  Proxy-Authentication-Info is being forwarded because each proxy will	
  send the same challenge set.
"

I'm not sure if "challenge set" is the right words there since this is a
response header and challenge is request detail.
 Perhapse "header field-value" instead?

Overall it looks good to me, even with the above.

Amos

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Mar 2015 09:56:30 +0100

> Overall it looks good to me, even with the above.

Good catch: 
<https://github.com/httpwg/http-extensions/commit/b1cfbee4c65805839f32e0477848e1f8791cfcad>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Mar 2015 14:59:34 +0100

> <https://github.com/httpwg/http-extensions/commit/b1cfbee4c65805839f32e0477848e1f8791cfcad>

...and I have submitted version -03.

Best regards, Julian