Subject: HTTP2 HEADERS state

From: Daurnimator <[email-masked]>
Date: Mon, 16 Mar 2015 16:48:23 -0400

>From 5.1:
> All streams start in the "idle" state.
> The following transitions are valid from this state:
> Sending or receiving a HEADERS frame causes the stream to become "open". The stream identifier is selected as described in Section 5.1.1. The same HEADERS frame can also cause a stream to immediately become "half closed".

>From 6.2:
> HEADERS frames can be sent on a stream in the "open" or "half closed (remote)" states.

I assume the text in section 6.2 needs to be modified to add "idle"?

---

From: Martin Thomson <[email-masked]>
Date: Mon, 16 Mar 2015 15:40:22 -0700

> I assume the text in section 6.2 needs to be modified to add "idle"?

You assume right.  I will add this - sorry, ask the RFC editor to add
this - unless I hear screams.