Subject: HTTP2 spec HEADERS padding needs clarification

From: Daurnimator <[email-masked]>
Date: Mon, 16 Mar 2015 14:57:49 -0400

>From 6.2 HEADERS:
> The HEADERS frame can include padding. Padding fields and flags are identical to
> those defined for DATA frames (Section 6.1).

>From 6.1 DATA:
> The total number of padding octets is determined by the value of the Pad Length field.
> If the length of the padding is the length of the frame payload or greater, the recipient
> MUST treat this as a connection error (Section 5.4.1) of type PROTOCOL_ERROR.

This could do with clarification. The HEADERS frame has additional
fields around priority.
i.e. stream dependency, weight.

I assume it should be a protocol error if padding length does not
leave enough room for weight?
Or could it be a valid frame for an empty header fragment and a weight
of 0 that overlaps padding?

Daurn.

---

From: Martin Thomson <[email-masked]>
Date: Mon, 16 Mar 2015 16:20:53 -0700

I originally thought that this was OK.  But it's not 100%, and I think
that I might ask the RFC editor to fix it.

https://github.com/http2/http2-spec/issues/723
https://github.com/http2/http2-spec/pull/724

This is small, and I'm mostly inclined not to worry.  Does anyone care?