Subject: I-D ACTION:draft-ietf-httpbis-auth-info-04.txt

From: [email-masked]
Date: Wed, 11 Mar 2015 09:02:40 -0700

A new Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Hypertext Transfer Protocol Working Group of the IETF.

    Title         :  The Hypertext Transfer Protocol (HTTP) Authentication-Info and Proxy-Authentication-Info Response Header Fields
    Author(s)     : J. Reschke
    Filename      : draft-ietf-httpbis-auth-info
    Pages         : 7 
    Date          : 2015-03-11 
    
   This specification defines the &quot;Authentication-Info&quot; and &quot;Proxy-
   Authentication-Info&quot; response header fields for use in HTTP
   authentication schemes which need to return information once the
   client&#39;s authentication credentials have been accepted.

A URL for this Internet-Draft is:
https://www.ietf.org/internet-drafts/draft-ietf-httpbis-auth-info-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Mar 2015 10:25:15 +1100

This draft contains some last-minute editorial updates that I caught during the shepherd review:
  https://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-auth-info-04.txt

... and with that, I think we have WG consensus to submit. 

> On 12 Mar 2015, at 3:02 am, [email-masked] wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Amos Jeffries <[email-masked]>
Date: Thu, 12 Mar 2015 14:50:28 +1300

> ... and with that, I think we have WG consensus to submit. 

The change itself and the changelog entry do not match.

The text is now saying the Proxy-Authorization header is *not*
applicable. When a Proxy-Authoriation may be what actually exists.

The new words need to be "indicated by Authorization or
Proxy-Authorization" or some equivalent.

Amos

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Mar 2015 13:30:41 +1100

Hi Amos,

The changelog is removed before the RFC is published, so I think we're OK there.

WRT the text, I think we can fix that by adding an equivalent proviso to proxy-auth-info, e.g.,:

"""
The Proxy-Authentication-Info response header field is equivalent to Authentication-Info, except that its semantics are defined by the authentication scheme indicated by the Proxy-Authorization header field of the corresponding request, and applies to proxy authentication.
"""

We can do that as part of LC processing (we just wanted to get this change in before that because of the change IPR declaration).

Thanks,

> On 12 Mar 2015, at 12:50 pm, Amos Jeffries <[email-masked]> wrote:
>

---

From: Amos Jeffries <[email-masked]>
Date: Thu, 12 Mar 2015 16:06:00 +1300

> The changelog is removed before the RFC is published, so I think we're OK there.

Understood. I was using it to compare what my reading of the text was vs
what your intention was. They didnt sync.

> The Proxy-Authentication-Info response header field is equivalent to Authentication-Info, except that its semantics are defined by the authentication scheme indicated by the Proxy-Authorization hea…

Yes, thats way better than what I proposed.

Amos

---

From: Julian Reschke <[email-masked]>
Date: Thu, 12 Mar 2015 09:06:37 +0100

> The change itself and the changelog entry do not match.

How so?

> applicable. When a Proxy-Authoriation may be what actually exists.

The text was changed in Section 3, which is about Authentication-Info.

Section 4, which is about Proxy-Authentication-Info, was not modified, 
as I though that the general statement:

"The Proxy-Authentication-Info response header field is equivalent to 
Authentication-Info..."

would be sufficient.

> Proxy-Authorization" or some equivalent.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 17 Mar 2015 08:12:48 +0100

> We can do that as part of LC processing (we just wanted to get this change in before that because of the change IPR declaration).

Done in 
<https://github.com/httpwg/http-extensions/commit/f06bc492259a5a7762fdc168bffa736dc5afcc3c>.

Best regards, Julian