Subject: HTTP/2 in Apache Traffic Server (proxy server / cache)

From: Leif Hedstrom <[email-masked]>
Date: Mon, 30 Mar 2015 21:47:55 -0600

Hi all,

hopefully not too much out of scope here, but we’ve just prepared our first release candidate of ATS which has HTTP/2 support. It’s not complete, it does not handle push for example, but it does most of h2. We’d love for more people to test this release, particularly h2 interop tests etc. The RC is available from

	http://people.apache.org/~sorber/releases/trafficserver/5.3.0-rc0/ <http://people.apache.org/~sorber/releases/trafficserver/5.3.0-rc0/>

You can see it in use on e.g. 	https://docs.trafficserver.apache.org/en/latest/ <https://docs.trafficserver.apache.org/en/latest/> .

— leif

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 31 Mar 2015 15:29:04 +1100

Great stuff, Leif. Please add it to the implementation list when you get a moment:
  https://github.com/http2/http2-spec/wiki/Implementations

Cheers,

> On 31 Mar 2015, at 2:47 pm, Leif Hedstrom <[email-masked]> wrote:
> 
> Hi all,
> 
> 	http://people.apache.org/~sorber/releases/trafficserver/5.3.0-rc0/
> 
> 
> You can see it in use on e.g. 	https://docs.trafficserver.apache.org/en/latest/ .
> 
> — leif
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Roberto Peon <[email-masked]>
Date: Mon, 30 Mar 2015 21:34:48 -0700

Awesome! :)
-=R

On Mon, Mar 30, 2015 at 9:29 PM, Mark Nottingham <[email-masked]> wrote:

> > hopefully not too much out of scope here, but we’ve just prepared our
> first release candidate of ATS which has HTTP/2 support. It’s not complete,
> it does not handle push for example, but it does most of h2. We’d love for
> more people to test this release, particularly h2 interop tests etc. The RC
> is available from
> >
> > You can see it in use on e.g.
> https://docs.trafficserver.apache.org/en/latest/ .
> >
> > — leif
> >
> >
>
> --

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 31 Mar 2015 10:38:09 -0700

Fantastic! This is great news!

---

From: Greg Wilkins <[email-masked]>
Date: Wed, 1 Apr 2015 10:02:53 +1100

That wiki list is getting a bit long and hard to find particular servers as
the order appears random (or is that in order implemented).
Anybody mind if I put it into alphabetical order?

I think it would also be good to know if push is supported - perhaps add a
column for that???

-- 
Greg Wilkins <[email-masked]>  @  Webtide - *an Intalio subsidiary*
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Amos Jeffries <[email-masked]>
Date: Wed, 01 Apr 2015 16:59:12 +1300

> Anybody mind if I put it into alphabetical order?

Can we please drop the implementations that dont support latest
implementation+ draft(s) down to the bottom or an appendix table?

Amos

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 1 Apr 2015 15:15:08 +1100

I’m neutral on alphabetical order; people can search for a specific implementation in the table easily.

What I’d like to do is switch the “draft support” column to “advertised version(s)”, but that would mean everyone would need to fill out their implementation status again — anyone mind?

Moving old implementations to a separate table makes sense; I’ve just done so for everything older than -12.

> On 1 Apr 2015, at 2:59 pm, Amos Jeffries <[email-masked]> wrote:
>