Subject: HEADERS in idle

From: Martin Thomson <[email-masked]>
Date: Thu, 26 Mar 2015 14:27:20 -0500

https://github.com/http2/http2-spec/pull/734/files

I am going to propose this to the RFC editor during AUTH-48.  i.e., very soon.

This fixes what is a pretty silly bug:, namely that sending HEADERS
was disallowed in the "idle" or "reserved (local)" states by the
original text.  Clearly, you have to be able to send HEADERS in that
state to actually cause the stream to open.

Thanks to @daurminator for identifying the problem and Hervé for
noticing that I missed the push case.

---

From: Daurnimator <[email-masked]>
Date: Fri, 27 Mar 2015 11:09:35 +1100

> noticing that I missed the push case.

*daurnimator
:)