Subject: Range Responses of Indeterminate Length: Draft

From: Rodger Combs <[email-masked]>
Date: Mon, 06 Apr 2015 12:17:54 +0000

Hello!

I've written up a draft standard for an HTTP extension that allows range requests to work more effectively with resources of indeterminate length. I've submitted it as an Internet-Draft, and wondered if anyone had any suggestions as to how to improve it, or move it towards standardization?
https://tools.ietf.org/html/draft-combs-http-indeterminate-range-01 <https://tools.ietf.org/html/draft-combs-http-indeterminate-range-01>

Thanks,
--Rodger

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Apr 2015 15:24:17 +1000

Hi Roger,

There are a bunch of folks talking about how to do streaming (especially video) over HTTP, and byte ranges often come up as a mechanism. This reminds me of a discussion we briefly had at the end of the Dallas meeting, where some folks wanted to use byte ranges for sparse content in MPEG DASH.

I think the concerns I had there apply here too; by overloading/changing the partial content mechanism, you’re risking interoperability problems with deployed infrastructure — especially proxy/caches, which can and do cache partial responses, generate partial requests, etc.

For example, if there’s a caching proxy in the middle that doesn’t understand Accept-Indefinite-Ranges, it’ll pass it through unmodified, and the server will then potentially generate 206 responses that are malformed.

This and many similar discussions I’ve had recently makes me wonder whether it’d be interesting to define a genuinely new partial content mechanism that’s tailored for media streaming; while it would depend on intermediaries rolling out support for the new mechanism to get any benefit from them, at least we could design it so that it doesn’t interact badly with deployed intermediaries.

What do people (especially intermediary implementers) think?

Cheers,

> On 6 Apr 2015, at 10:17 pm, Rodger Combs <[email-masked]> wrote:
> 
> Hello!
> 
> https://tools.ietf.org/html/draft-combs-http-indeterminate-range-01
> 
> Thanks,
> --Rodger

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Apr 2015 17:39:39 +1000

That’s what I was thinking. Having said that, I’d want to test some deployed implementations before saying so for sure.

Cheers,

> On 7 Apr 2015, at 5:38 pm, Martin J. Dürst <[email-masked]> wrote:
> 
> I haven't studied all of the syntax details, but couldn't using a different unit name, such as "newbytes" (even if it's the same unit as bytes) be made to work? That would avoid the need to deploy a totally new mechanism.
> 
> Regards,   Martin.
> 
> On 2015/04/07 14:24, Mark Nottingham wrote:
>> Hi Roger,
>> 
>> .

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 7 Apr 2015 16:38:26 +0900

I haven't studied all of the syntax details, but couldn't using a 
different unit name, such as "newbytes" (even if it's the same unit as 
bytes) be made to work? That would avoid the need to deploy a totally 
new mechanism.

Regards,   Martin.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Apr 2015 17:54:22 +1000

Do you happen to have references to the specific code in each? Regardless of what we do here, it’d be good to file bugs.

Cheers,

> On 7 Apr 2015, at 5:45 pm, Rodger Combs <[email-masked]> wrote:
> 
> I strongly considered this (instead of adding a header), but upon looking into existing implementations, it's clear it wouldn't work with existing software. No implementation I checked actually parses `Accept-Ranges` as per the RFC:
> 
> 	• libavformat checks if the first 5 characters of the header are "bytes"
> 	• Chromium checks if the string "bytes" appears at all
> 	• WebKit just checks if it's not equal to "none"
> 	• Firefox checks if it's exactly equal to "bytes"
> 
> That last one makes it impossible to change the header's value without breaking backwards-compatibility with older Firefox versions, and the others are differing degrees of problematic.
> 
>> On Apr 7, 2015, at 02:39, Mark Nottingham <[email-masked]> wrote:
>>

---

From: Rodger Combs <[email-masked]>
Date: Tue, 07 Apr 2015 07:46:19 +0000

libavformat checks if the first 5 characters of the header are "bytes"
Chromium checks if the string "bytes" appears at all
WebKit just checks if it's not equal to "none"
Firefox checks if it's exactly equal to "bytes"

> On Apr 7, 2015, at 02:39, Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On 7 Apr 2015, at 5:38 pm, Martin J. Dürst <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>>> On 6 Apr 2015, at 10:17 pm, Rodger Combs <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Hello!
>>>> 
>>> Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>
>>> 
>>> 
>>> .
>>> 
> 
> --
> Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>
>

---

From: Rodger Combs <[email-masked]>
Date: Tue, 07 Apr 2015 08:28:47 +0000

All links from the mirror most convenient for me:

libavformat: https://github.com/FFmpeg/FFmpeg/blob/master/libavformat/http.c#L583 <https://github.com/FFmpeg/FFmpeg/blob/master/libavformat/http.c#L583>
Chromium: https://github.com/ChromiumWebApps/chromium/blob/c7361d39be8abd1574e6ce8957c8dbddd4c6ccf7/content/renderer/media/buffered_resource_loader.cc#L399 <https://github.com/ChromiumWebApps/chromium/blob/c7361d39be8abd1574e6ce8957c8dbddd4c6ccf7/content/renderer/media/buffered_resource_loader.cc#L399>
WebKit: https://github.com/WebKit/webkit/blob/4633eb6dd73f925b45244a7f716e571a94f65628/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp#L860 <https://github.com/WebKit/webkit/blob/4633eb6dd73f925b45244a7f716e571a94f65628/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp#L860>
Firefox: https://github.com/mozilla/gecko-dev/blob/174ec4f7153479c41f6cae2cf58f0a8ac927db0e/dom/media/MediaResource.cpp#L234 <https://github.com/mozilla/gecko-dev/blob/174ec4f7153479c41f6cae2cf58f0a8ac927db0e/dom/media/MediaResource.cpp#L234>
> On Apr 7, 2015, at 02:54, Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On 7 Apr 2015, at 5:45 pm, Rodger Combs <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 07 Apr 2015 07:14:20 -0400

Have you looked at:

    https://datatracker.ietf.org/doc/draft-pantos-http-live-streaming/

> On Apr 7, 2015, at 1:24 AM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Roger,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Rodger Combs <[email-masked]>
Date: Tue, 07 Apr 2015 11:39:48 +0000

Yup; we use that for some platforms, but not all devices support it, and it limits us to the codecs supported by MPEG-TS (or that the platform supports in it). We use MPEG-DASH on some platforms, but it has similar issues. Both also require either knowledge of the segment durations beforehand (here, before they're generated), or the ability to force them to be consistent (which is impractical if remuxing streams a user's existing video files), though HLS implementations tend to be a fair bit more forgiving on this point than DASH ones. When it's possible, we've found that a single live-generated MKV file streamed over chunked HTTP is both compatible with a very wide variety of codecs, and very flexible about the sizes of a stream's GoPs and the like.

One thing I've had success in some experiments with lately is writing the MKV header to a single file, writing individual segments to separate files, and keeping track of their start timestamps. Then, when a request comes in for time T, I can return the header concatenated to the segment with the greatest start time <= T, and all segments after it. This approach is somewhat similar to how MPEG-DASH works, but with the work of preparing a fully-valid MKV file handled by the server instead of the client. The downside is that implementations often refuse to make any kind of seek in a resource that doesn't support range requests (and you can't properly support them when the content length is unknown), so I end up limited to seeks to the nearest on-server chunk boundary.

Sorry for going off-topic, but I hope this provides some insight into the complex issues involved in my use-case.

(Oh, and yes, you can use HLS without foreknowledge of segment durations for live streams, but not if you intend to present the media as a fully-seekable VOD stream... which we like doing when possible, as it means less work for the client to handle when seeking)

> On Apr 7, 2015, at 06:14, Michael Sweet <[email-masked]> wrote:
> 
> Have you looked at:
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 8 Apr 2015 15:12:57 +1000

Thanks! CC:ing a couple of relevant people re: the tickets below.

> On 7 Apr 2015, at 6:28 pm, Rodger Combs <[email-masked]> wrote:
> 
> libavformat: https://github.com/FFmpeg/FFmpeg/blob/master/libavformat/http.c#L583

https://trac.ffmpeg.org/ticket/4451

> Chromium: https://github.com/ChromiumWebApps/chromium/blob/c7361d39be8abd1574e6ce8957c8dbddd4c6ccf7/content/renderer/media/buffered_resource_loader.cc#L399

https://code.google.com/p/chromium/issues/detail?id=474864

> WebKit: https://github.com/WebKit/webkit/blob/4633eb6dd73f925b45244a7f716e571a94f65628/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp#L860

https://bugs.webkit.org/show_bug.cgi?id=143512

> Firefox: https://github.com/mozilla/gecko-dev/blob/174ec4f7153479c41f6cae2cf58f0a8ac927db0e/dom/media/MediaResource.cpp#L234

https://bugzilla.mozilla.org/show_bug.cgi?id=1152162

> 
>> On Apr 7, 2015, at 02:54, Mark Nottingham <[email-masked]> wrote:
>>

---

From: Rodger Combs <[email-masked]>
Date: Wed, 08 Apr 2015 07:26:00 +0000

Some of the ticket descriptions there are incorrect. libavformat's strncmp() approach only matches if the _first_ 5 characters match "bytes", WebKit's g_ascii_strcasecmp only matches if the entire header is exactly "none", Gecko's nsAutoCString::EqualsLiteral only matches if the entire header is exactly "bytes", and Chrome's std::string::find approach works as you described. So they'd all be potentially buggy in different circumstances.

> On Apr 8, 2015, at 00:12, Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On 7 Apr 2015, at 6:28 pm, Rodger Combs <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> https://trac.ffmpeg.org/ticket/4451 <https://trac.ffmpeg.org/ticket/4451>
> 
> https://code.google.com/p/chromium/issues/detail?id=474864 <https://code.google.com/p/chromium/issues/detail?id=474864>
> 
> https://bugs.webkit.org/show_bug.cgi?id=143512 <https://bugs.webkit.org/show_bug.cgi?id=143512>
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1152162 <https://bugzilla.mozilla.org/show_bug.cgi?id=1152162>
> 
>>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 8 Apr 2015 19:43:42 +1000

I did a fairly quick cut-n-paste; feel free to correct/elaborate in the bugs.

Cheers,

> On 8 Apr 2015, at 5:25 pm, Rodger Combs <[email-masked]> wrote:
> 
>> On Apr 8, 2015, at 00:12, Mark Nottingham <[email-masked]> wrote:
>>