Subject: [Errata Rejected] RFC7234 (4334)

From: RFC Errata System <[email-masked]>
Date: Sun, 12 Apr 2015 20:43:57 -0700 (PDT)

The following errata report has been rejected for RFC7234,
"Hypertext Transfer Protocol (HTTP/1.1): Caching".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7234&eid=4334

--------------------------------------
Status: Rejected
Type: Editorial

Reported by: Antonio Vera <[email-masked]>
Date Reported: 2015-04-12
Rejected by: Barry Leiba (IESG)

Section: 5.3

Original Text
-------------
The Expires value is an HTTP-date timestamp, as defined in Section
   7.1.1.1 of [RFC7231].

Corrected Text
--------------
The Expires value is an HTTP-date timestamp, as defined in Section
   7.1.1.1 of [RFC7231].

Notes
-----
There's no error in the text itself, but the address of the link in 7.1.1.1 is pointing to a hashtag in RFC 7234, not RFC 7231 as it should.

Currently, 7.1.1.1 points to: http://tools.ietf.org/html/rfc7234#section-7.1.1.1
It should point to: http://tools.ietf.org/html/rfc7231#section-7.1.1.1
 --VERIFIER NOTES-- 
The RFC Editor has nothing to do with the HTML versions on tools.ietf.org, which are unofficial versions, with the HTML conversion on a best-effort basis.

--------------------------------------
RFC7234 (draft-ietf-httpbis-p6-cache-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Caching
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 14 Apr 2015 09:51:25 +1000

Antonio,

Thanks for noticing that. I suspect that Julian will correct it in our online source at:
  https://github.com/httpwg/http11bis
.. and it'll filter through to the places where we can get it in time.

If you like, you can raise an issue here:
  https://github.com/httpwg/http11bis/issues

Cheers,

> On 13 Apr 2015, at 1:43 pm, RFC Errata System <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Tony Hansen <[email-masked]>
Date: Mon, 13 Apr 2015 20:18:54 -0400

I have a feeling that this is not a problem with the document, but 
instead with the tooling.

That is, the missing piece of information is which HTML-ized version of 
the document was Antonio Vera looking at?

If he was looking at http://tools.ietf.org/html/rfc7234, then yup, it's 
pointing at the wrong document. The htmlizer tool on tools.ietf.org 
picked up the "Section ..." text and made that into a link to the 
section within the current document.

However, if he was looking at the files in github, he would have seen a 
link to the proper document.

So I think there is nothing that needs to be done here by anyone in the 
http group. But it might be worth poking Henrik to take a look at the 
rfcmarkup tool to see if an improvement can be made.

OR, anyone else can take a look at the rfcmarkup code and see if they 
can come up with a code fix. I'm sure Henrik would love to buy it back.

     Tony Hansen

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 14 Apr 2015 10:21:40 +1000

Aha. Thanks, Tony.

Cheers,

> On 14 Apr 2015, at 10:18 am, Tony Hansen <[email-masked]> wrote:
> 
> I have a feeling that this is not a problem with the document, but instead with the tooling.
> 
> That is, the missing piece of information is which HTML-ized version of the document was Antonio Vera looking at?
> 
> If he was looking at http://tools.ietf.org/html/rfc7234, then yup, it's pointing at the wrong document. The htmlizer tool on tools.ietf.org picked up the "Section ..." text and made that into a link to the section within the current document.
> 
> However, if he was looking at the files in github, he would have seen a link to the proper document.
> 
> 
> So I think there is nothing that needs to be done here by anyone in the http group. But it might be worth poking Henrik to take a look at the rfcmarkup tool to see if an improvement can be made.
> 
> OR, anyone else can take a look at the rfcmarkup code and see if they can come up with a code fix. I'm sure Henrik would love to buy it back.
> 
>    Tony Hansen
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 14 Apr 2015 07:27:11 +0200

> .. and it'll filter through to the places where we can get it in time.

As Barry said, it's a defect in the HTML generated at tools.ietf.org; it 
has nothing whatsoever to do with the actual RFC (or our tools).

Best regards, Julian