Subject: Connection Reuse spec clarification

From: Samuel Giles <[email-masked]>
Date: Fri, 10 Apr 2015 13:14:03 +0000

Hey,

Section 9.1.1 Connection Reuse (
http://http2.github.io/http2-spec/#rfc.section.9.1.1) says:

> A connection can be reused as long as the origin server is authoritative
(Section 10.1). For TCP connections without TLS, this depends on the host
having resolved to the same IP address.

The wording here may have mislead me a little, wouldn't a TCP connection
_with_ TLS also depend on the host resolving to the same IP address?

Many Thanks,

Sam

---

From: Patrick McManus <[email-masked]>
Date: Fri, 10 Apr 2015 09:46:14 -0400

next line says.. for https resources connection reuse _additionally_
depends on..