Subject: h2 implementation list -- PLEASE UPDATE

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Apr 2015 11:35:58 +1100

Everyone,

If you have an HTTP/2 implementation, please take a moment to update <>. 

The last column is now the APLN protocol ID(s) that your implementation advertises support for / accepts. 

E.g., if you support the last draft version and the final, you’d include:

“h2 h2-14”

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Apr 2015 11:42:35 +1100

Argh.

Link: <https://github.com/http2/http2-spec/wiki/Implementations>

> On 2 Apr 2015, at 11:35 am, Mark Nottingham <[email-masked]> wrote:
> 
> Everyone,
>

---

From: Max Bruce <[email-masked]>
Date: Wed, 1 Apr 2015 18:58:33 -0700

Is draft 17 the final? I never found an actual finalized RFC.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 1 Apr 2015 19:15:49 -0700

> Is draft 17 the final? I never found an actual finalized RFC.

The RFC editor is working on -17.  There will be no technical changes
between that and the final document.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Apr 2015 13:26:35 +1100

Right.

The most common values will be “h2” and “h2-14” (because 14 is the last implementation draft we nominated, and is what most implementations use today AFAICT).

Cheers,

> On 2 Apr 2015, at 1:15 pm, Martin Thomson <[email-masked]> wrote:
>

---

From: Greg Wilkins <[email-masked]>
Date: Thu, 2 Apr 2015 13:53:14 +1100

Mark,

Do we also list h2c and h2c-14 etc. ?

Also, I couldn't help my OC self and sorted the table.

cheers

On 2 April 2015 at 13:26, Mark Nottingham <[email-masked]> wrote:

> Right.
>
> The most common values will be “h2” and “h2-14” (because 14 is the last
> implementation draft we nominated, and is what most implementations use
> today AFAICT).
>
> Cheers,
>
>

-- 
Greg Wilkins <[email-masked]>  @  Webtide - *an Intalio subsidiary*
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Apr 2015 16:02:42 +1100

> On 2 Apr 2015, at 1:53 pm, Greg Wilkins <[email-masked]> wrote:
> 
> Mark,
> 

Of course.

> Also, I couldn't help my OC self and sorted the table.

You are forgiven :)

> Greg Wilkins <[email-masked]>  @  Webtide - an Intalio subsidiary