Subject: how do we achieve 305 Use proxy in http

From: Aravindan G <[email-masked]>
Date: Wed, 27 May 2015 11:34:16 +0000

Hi All,

My requirement is as follows:

I am developing a proxy to gate mobile web browsing.The browser proxy would be set to my proxy and hence all requests would land on my proxy. But for some requests i would want the request to be redirected to another proxy .I thought 305 Use proxy would be ideal to handle this scenario. When tested with browsers it was not working. Then realised that http://greenbytes.de/tech/webdav/rfc7231.html#status.305 <http://greenbytes.de/tech/webdav/rfc7231.html#status.305> it is deprecated in rfc 7231. If it is deprecated how do we achieve this functionality for HTTP Requests?

Any help on this would be appreciated

Regards

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 May 2015 10:04:14 +1000

Hello,

It  was deprecated because it was never widely supported, and also had security issues.

Regards,

> On 27 May 2015, at 9:34 pm, Aravindan G <[email-masked]> wrote:
> 
> Hi All,
> 
>  
> I am developing a proxy to gate mobile web browsing.The browser proxy would be set to my proxy and hence all requests would land on my proxy. But for some requests i would want the request to be redirected to another proxy .I thought 305 Use proxy would be ideal to handle this scenario. When tested with browsers it was not working. Then realised that http://greenbytes.de/tech/webdav/rfc7231.html#status.305 it is deprecated in rfc 7231. If it is deprecated how do we achieve this functionality for HTTP Requests?
> 
>  

--
Mark Nottingham   https://www.mnot.net/