Subject: Time Precision

From: Sawood Alam <[email-masked]>
Date: Mon, 11 May 2015 10:16:44 -0400

Hi,

I am new to this mailing list. I was wondering if anything has changed
about the precision of the time in HTTP/2.0? As far as I know, HTTP/1.1
only allows time precision up to a second granularity.

Best,

--
Sawood Alam
Department of Computer Science
Old Dominion University
Norfolk VA 23529

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Mon, 11 May 2015 14:23:12 +0000

--------
In message <CALOnmf-XSZk=[email-masked]>

>only allows time precision up to a second granularity.

Nope, not only does HTTP/2.0 still use second granularity, it still
lugs timestamps around in ASCII format.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Sawood Alam <[email-masked]>
Date: Mon, 11 May 2015 10:33:35 -0400

On Mon, May 11, 2015 at 10:23 AM, Poul-Henning Kamp <[email-masked]>
wrote:

> --------
> In message <CALOnmf-XSZk=
> [email-masked]>
> , Sawood Alam writes:
>

Thanks for the quick response. Is there any discussion publicly available
on this matter, why it was decided no to be changed? I guess the reason is
probably backward compatibility, but I would like to know more about it.

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Mon, 11 May 2015 15:16:04 +0000

--------
In message <[email-masked]>

>probably backward compatibility, but I would like to know more about it.

Improvements were proposed but not adopted.

---

From: Sawood Alam <[email-masked]>
Date: Mon, 11 May 2015 11:25:11 -0400

On Mon, May 11, 2015 at 11:16 AM, Poul-Henning Kamp <[email-masked]>
wrote:

> --------
> In message <
> [email-masked]>
> , Sawood Alam writes:
>

Thanks!

---

From: Greg Wilkins <[email-masked]>
Date: Tue, 12 May 2015 10:46:16 +1000

> probably backward compatibility, but I would like to know more about it.

It was not so much backwards compatibility as enforced forward
compatibility. The WG was chartered to only support HTTP/1 semantics over a
new wire protocol that was aimed at solving a moderately narrow (and poorly
defined) set of protocol abuses and performance issues.

For better or worse, fixing or enhancing the semantics of the protocol was
out of scope.

cheers

-- 
Greg Wilkins <[email-masked] <[email-masked]>>  - *an Intalio.com
subsidiary*
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Tue, 12 May 2015 06:21:55 +0000

--------
In message <CAH_y2NFnn=[email-masked]>

>For better or worse, fixing or enhancing the semantics of the protocol was

... because that's the charter the WG wrote for itself.