Subject: SRV in HTTP/2

From: Max Bruce <[email-masked]>
Date: Sat, 20 Jun 2015 23:48:59 -0700

Will there be any formal & proper support for SRV records in HTTP/2? They
offer better load balancing, priority systems, and portability(in terms of
where you point a domain) than the standard A record. It would be very nice
for that to be an optional feature.

-- 
Thanks,
Max Bruce
www.avuna.org

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 21 Jun 2015 20:25:16 +1000

Hi Max,

We discussed this, but decided not to support SRV in HTTP/2 - mostly because HTTP/2 needs to be backwards-compatible with the existing Web, which doesn't use SRV. In discussion, it also became pretty clear that if we were to use an additional record type for HTTP, SRV may not suit, because we need to do things like protocol version negotiation. 

There were also concerns about latency and interoperability (especially considering how many DNS requests a page load can make, and the unfortunate limitations of some DNS gateways/proxies).

Cheers,

> On 21 Jun 2015, at 4:48 pm, Max Bruce <[email-masked]> wrote:
> 
> Will there be any formal & proper support for SRV records in HTTP/2? They offer better load balancing, priority systems, and portability(in terms of where you point a domain) than the standard A record. It would be very nice for that to be an optional feature.
> 
> -- 
> Thanks, 
> Max Bruce
> www.avuna.org

--
Mark Nottingham   https://www.mnot.net/