Subject: #75: 421 Status with Alt-Svc Header

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Jun 2015 11:06:13 +1000

<https://github.com/httpwg/http-extensions/issues/75>

The spec current says:

"""
A 421 (Misdirected Request) response may carry an Alt-Svc header field.
"""

I think Mike is suggesting a change to something like:

"""
A 421 (Misdirected Request) response MUST NOT carry an Alt-Svc header field, and clients MUST ignore any Alt-Svc header field in one.
"""

Another approach would be to caution implementations that loops are possible if an Alt-Svc on a 421 is followed, and to exercise caution (including loop detection with fallback to origin).

Thoughts?

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin Thomson <[email-masked]>
Date: Mon, 15 Jun 2015 19:22:19 -0700

> A 421 (Misdirected Request) response MUST NOT carry an Alt-Svc header field, and clients MUST ignore any Alt-Svc header field in one.

That seems reasonable: after all, 421 forswears authority.

---

From: Patrick McManus <[email-masked]>
Date: Wed, 17 Jun 2015 10:23:02 -0400

> That seems reasonable: after all, 421 forswears authority.

yeah - that's a good summary.