Subject: #72: Conflicts between Alt-Svc and ALPN

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Jun 2015 11:38:21 +1000

<https://github.com/httpwg/http-extensions/issues/72>

This issue is about what happens when the information you get in Alt-Svc and ALPN at runtime conflict.

The proposal is to add text to the effect that the alternative isn't usable if it doesn't negotiate the advertised protocol.

Any more discussion?

--
Mark Nottingham   https://www.mnot.net/

---

From: Patrick McManus <[email-masked]>
Date: Mon, 8 Jun 2015 08:54:48 -0400

this is the only sensible thing.. let's just not say must-close or
something, the connection might be useful for a different request :)

-P

On Sun, Jun 7, 2015 at 9:38 PM, Mark Nottingham <[email-masked]> wrote:

> The proposal is to add text to the effect that the alternative isn't
> usable if it doesn't negotiate the advertised protocol.
>
> Any more discussion?
>
>
> --

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Jun 2015 09:53:06 +1000

Marking as editor-ready.

Thanks,

> On 8 Jun 2015, at 10:54 pm, Patrick McManus <[email-masked]> wrote:
> 
> this is the only sensible thing.. let's just not say must-close or something, the connection might be useful for a different request :)
> 
> -P
>

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 11 Jun 2015 08:44:51 -0700

> something, the connection might be useful for a different request :)

​Totally agree. IIRC, Chome does exactly this.​