Subject: #74: Alternates of Alternates

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Jun 2015 11:40:55 +1000

<https://github.com/httpwg/http-extensions/issues/74>

This issue is asking whether the intent is to allow an alternative service to successfully advertise a further alternative.

I note that our spec already says:

> If a client becomes aware of multiple alternative services, it MAY
>    choose the most suitable according to its own criteria (again,
>    keeping security properties in mind).  For example, an origin might
>    advertise multiple alternative services to notify clients of support
>    for multiple versions of HTTP; or, an alternative service might
>    itself advertise an alternative.

<https://tools.ietf.org/html/draft-ietf-httpbis-alt-svc-07#section-2.4>

Do we need any more discussion here, or can we close the issue?

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Jun 2015 10:57:17 +1000

Suggestion: below the quoted text:

"Because each alternative is considered fully authoritative for the origin, they can themselves advertise alternative services - including alternatives that outlive the original advertisement from the origin."

> On 8 Jun 2015, at 11:40 am, Mark Nottingham <[email-masked]> wrote:
>