Subject: Re: Spencer Dawkins' No Objection on draft-ietf-httpbis-tunnel-protocol-04: (with COMMENT)

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jun 2015 09:09:50 -0700

On 10 June 2015 at 08:58, Spencer Dawkins <[email-masked]> wrote:
> through one or more proxies.

You connect to proxy 1 using TCP.  You optionally add TLS. You ask
proxy 1 to connect to proxy 2 over TCP.  You optionally add TLS.  You
ask proxy 2 to connect to proxy 3...

> Is any description needed?

I don't think so, but others might disagree.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 11 Jun 2015 05:43:19 +0000

Hi, Martin,

On Wed, Jun 10, 2015 at 11:09 AM, Martin Thomson <[email-masked] <mailto:[email-masked]>> wrote:

That was roughly my level of understanding while guessing, but I didn't know how to "ask proxy 1 to connect to proxy 2 over TCP". 
 
> Is any description needed?

If that's an idiom that everyone except TSV ADs already knows, no. Is it? 

:-)

Alternatively, if that's an idiom for those skilled in the art, I'm not sure why "one or more" needs to be mentioned at all. With just the one mention, it feels like "you can do this, and how you'd do this is left as an exercise for the reader" ...

Spencer

Spencer

---

From: Martin Thomson <[email-masked]>
Date: Thu, 11 Jun 2015 09:45:36 -0700

On 10 June 2015 at 22:42, Spencer Dawkins at IETF
<[email-masked]> wrote:
> That was roughly my level of understanding while guessing, but I didn't know
> how to "ask proxy 1 to connect to proxy 2 over TCP".

Oh, that's probably because that's assumed knowledge.  That is what
CONNECT is for.

See:
http://http2.github.io/http2-spec/#CONNECT
https://svn.tools.ietf.org/svn/wg/httpbis/specs/rfc7231.html#CONNECT