Subject: HTTP[1,2] and TCP

From: Mark Nottingham <[email-masked]>
Date: Mon, 24 Aug 2015 15:55:09 +1000

While there's certainly an interesting discussion to be had about UDP-based HTTP, for the near future, we're going to be using TCP.

After hearing a few people express interest about establishing best practices for using HTTP over TCP, experimenting, etc., I've started a wiki page:
  https://github.com/httpwg/wiki/wiki/TCP

As you can see, it's not much now, but feel free to edit/add (it's a wiki), or discuss here.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Wenbo Zhu <[email-masked]>
Date: Mon, 24 Aug 2015 14:00:09 -0700

I

On Sun, Aug 23, 2015 at 10:55 PM, Mark Nottingham <[email-masked]> wrote:

> While there's certainly an interesting discussion to be had about
> UDP-based HTTP, for the near future, we're going to be using TCP.
>
> After hearing a few people express interest about establishing best
> practices for using HTTP over TCP, experimenting, etc., I've started a wiki
> page:
1) half-close
2) keep-alive (not connection: keep-alive)
3) full-duplex (body) ...
4) abort

Happy to edit some of them if in scope ...

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Aug 2015 09:42:36 +1000

Please do.

Cheers,

> On 25 Aug 2015, at 7:00 am, Wenbo Zhu <[email-masked]> wrote:
> 
> I
>