Subject: Re: SCIM thought experiment of draft-snell-search-method-00

From: Mark Nottingham <[email-masked]>
Date: Thu, 6 Aug 2015 09:05:08 +1000

Hi Phil,

Reading that document:

"""
In contrast, using HTTP POST has the disadvantage of overloading POST to perform another function other than creating new SCIM resources.
"""

POST's semantics aren't "create a resource" — they're "process this data" with the possible side effect of creating a resource.

POST can easily dispatch on request characteristics (e.g,. request body media type) to determine what the appropriate action is; there is no requirement that POST map to only one set of semantics per URL.

Did you consider using a different request media type?

Regards,

> On 21 Jul 2015, at 10:42 pm, Phil Hunt <[email-masked]> wrote:
> 
> Link as requested by @mnot for the SCIM thought experiment on the user of the HTTP Search draft.
> 
> https://tools.ietf.org/html/draft-hunt-scim-search-00
> 
> Phil
> 
> @independentid
> www.independentid.com
> [email-masked]
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Michael Sweet <[email-masked]>
Date: Wed, 05 Aug 2015 19:32:16 -0400

> On Aug 5, 2015, at 7:05 PM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Phil,
> 
> Reading that document:
> 
> """

This is exactly how IPP works - each POST request contains an IPP request message complete with operation code and attributes (parameters).  Each response contains an IPP response message with an IPP status code and more attributes.  Some operations create objects, others cancel/delete them, etc.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Phil Hunt <[email-masked]>
Date: Wed, 5 Aug 2015 16:44:55 -0700

Mark,

Thanks for taking a look. 

Yes you are correct about POST. But the downside for a profile like SCIM is having multiple very different protocol operations using the same method. (Which is what SCIM 2 currently ended up doing)

Mime-type is another issue. We defined a mime type for scim that covers the entire spec. Solving the problem changing the operation type with mime type is another way that can work but it now complicated scim mimes (from just one). It also feels like "tunnelling". 

Scim 2 ended up using a schemas attribute with an iana registered urn to do the signalling.

Scim won't necessarily look at this search method right away. I wanted to give the httpbis WG an idea of how search could simplify a restful spec by keeping operation definition simple/consistent and mine type focused on xml vs json rather then tunneling a new protocol method. 

Thanks,

Phil

> On Aug 5, 2015, at 16:05, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Phil,
> 
> Reading that document:
> 
> """