Subject: [Technical Errata Reported] RFC7233 (4472)

From: RFC Errata System <[email-masked]>
Date: Sun, 13 Sep 2015 12:30:32 -0700 (PDT)

The following errata report has been submitted for RFC7233,
"Hypertext Transfer Protocol (HTTP/1.1): Range Requests".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7233&eid=4472

--------------------------------------
Type: Technical
Reported by: Florian Best <[email-masked]>

Section: 2.1

Original Text
-------------
   o  The first and last bytes only (bytes 0 and 9999):

        bytes=0-0,-1

Corrected Text
--------------
   o  The first and last bytes only (bytes 0 and 9999):

        bytes=0-1,-1

Notes
-----
If the first byte is requested the offset must be 1.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7233 (draft-ietf-httpbis-p5-range-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Range Requests
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., Y. Lafon, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Florian Best <[email-masked]>
Date: Sun, 13 Sep 2015 21:58:51 +0200

I tested this against a httpd and my report seems invalid.
The sentence "the byte positions specified are inclusive" seem to
explain it (but not very clear imho!).