Subject: Http/2 Traffic generator

From: Vimala Tadepalli <[email-masked]>
Date: Tue, 27 Oct 2015 15:59:32 -0700

Hi,

I am not sure if this is the right group to send this request but I want to
know if there is any Http/2 traffic generator which can be used to validate
different test scenarios?

Thanks
Vimala

---

From: Cory Benfield <[email-masked]>
Date: Wed, 28 Oct 2015 09:05:20 +0900

The h2load tool from nghttp2 can certainly generate some HTTP/2 traffic. Right now I don’t know how general it is though.

Cory

> On 28 Oct 2015, at 07:59, Vimala Tadepalli <[email-masked]> wrote:
> 
> Hi,
> 
> I am not sure if this is the right group to send this request but I want to know if there is any Http/2 traffic generator which can be used to validate different test scenarios?
> 
> Thanks
> Vimala

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 28 Oct 2015 09:17:02 +0000

h2load can generate HTTP/1.1 and HTTP/2 traffic (and SPDY if built appropriately) . 

Traffic patterns are either:

* bulk requests for a single resource
* bulk requests for a list of resources
* timed requests, represented as a list of time offset/resource pairs. This list can be written by hand or generated by basic processing of a HAR capture from a UA (e.g. browser network capture).

Requests can be issued from multiple clients. Clients can either be created all at the start of a test run or created at varying rates - allowing for different ramp up gradients.

Documentation is available at https://nghttp2.org/documentation/h2load.1.html

Lucas

> -----Original Message-----
> From: Cory Benfield [mailto:[email-masked]]
> Sent: 28 October 2015 00:05
> To: Vimala Tadepalli <[email-masked]>
> Cc: HTTP Working Group <[email-masked]>
> Subject: Re: Http/2 Traffic generator
> 
> The h2load tool from nghttp2 can certainly generate some HTTP/2 traffic.
> Right now I don’t know how general it is though.
> 
> Cory
>

---

From: Vimala Tadepalli <[email-masked]>
Date: Wed, 28 Oct 2015 16:56:32 -0700

Thanks everyone.
Will try h2load.

On Wed, Oct 28, 2015 at 2:17 AM, Lucas Pardue <[email-masked]>
wrote:

> * timed requests, represented as a list of time offset/resource pairs.
> This list can be written by hand or generated by basic processing of a HAR
> capture from a UA (e.g. browser network capture).
>
> Requests can be issued from multiple clients. Clients can either be
> created all at the start of a test run or created at varying rates -
> allowing for different ramp up gradients.
>
> Documentation is available at
> https://nghttp2.org/documentation/h2load.1.html
>
> Lucas
>