Subject: Call for Adoption: draft-reschke-rfc5987bis, was: Call for Adoption: draft-reschke-rfc54987bis

From: Julian Reschke <[email-masked]>
Date: Thu, 1 Oct 2015 14:00:37 +0200

On 2015-10-01 08:33, Poul-Henning Kamp wrote:
> --------
> In message <[email-masked]>, Mark Nottingham wri
> tes:
>
>> We're belatedly adopting this; Julian asked for a breather while he
>> finished other work, and now he's ready to commence.
>
> I think adopting the draft is a good idea.
>
> But I find some bits of the low level mechanics proposed troublesome.
>
> For instance it worries me a lot to use '*' as magic marker in
> fields which are historically thrown around fast and loose in all
> sorts of programming environments where it may or may not be a
> meta-character.
>
> Can we find a less overloaded preferably non-meta character ?

We could. But then we'd define something new, instead of just updating a 
specification of something that has been used for something like 15 
years already.

> ...
> But going even further:  I have a hard time coming up with a credible
> (ie: non-demented) scenario for having multiple different charsets
> in the same header.
> ...

I have a feeling of deja vu. We discussed this already.

Again: this is not new.

We can and should new ways to address this (and the JSON-in-field-values 
spec is one proposal). But this is not the spec to do this.

> ...

Best regards, Julian

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Thu, 01 Oct 2015 12:06:08 +0000

--------
In message <[email-masked]>, Julian Reschke writes:

>[...]

So why bother updating a 15 year old spec, why not focus on the
JSON-in-field-values stuff and move forward ?

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 1 Oct 2015 14:15:03 +0200

> JSON-in-field-values stuff and move forward ?

Because I'd like to have accurate documentation of a format that is in 
use and isn't going to go away.

Best regards, Julian

---

From: Amos Jeffries <[email-masked]>
Date: Fri, 2 Oct 2015 05:49:17 +1300

> (ie: non-demented) scenario for having multiple different charsets

I can. List headers that are appended to by multiple hops. eg Forwarded
and such like. Each hop might have a different charset string to append.
Which may be pre-defined or enoded, so not easily changed to fit with a
header-wide charset imposed by an earlier hop.

Amos