Subject: Re: Call for Adoption: draft-fielding-http-key

From: Amos Jeffries <[email-masked]>
Date: Fri, 2 Oct 2015 05:53:13 +1300

On 1/10/2015 6:22 p.m., Mark Nottingham wrote:
> We discussed this document in Dallas:
>   <http://tools.ietf.org/html/draft-fielding-http-key>
> ... as well as on and off since then.
> 
> Based on the feedback received and after discussion with our Area Director, I believe that we should adopt this document as a WG product, with a target of Proposed Standard. 
> 
> Since I'm an author on the document, I've asked Martin Thomson to be Document Shepherd, to help judge consensus both of the CfA and during the document's LC, should we adopt it. He has graciously agreed.
> 
> Please comment on-list; we’ll make a decision about adoption at the end of next week. The result of this CfA will also help us determine how to go forward with the Client Hints document.
> 
> Regards,
> 
> --
> Mark Nottingham   https://www.mnot.net/
> 
> 

I am in favour of adopting it.

Amos

---

From: Julian Reschke <[email-masked]>
Date: Tue, 6 Oct 2015 08:05:25 +0200

On 2015-10-01 07:22, Mark Nottingham wrote:
> ...

I support adoption.

One interesting aspect of this document is that it sort-of asserts that 
there's a standard parameter-based syntax in header fields, which I 
believe would not to be fleshed out. Alternatively/Additionally, it 
gives us yet another good reason to discuss a new standard syntax for 
new header fields.

Best regards, Julian

---

From: Yoav Weiss <[email-masked]>
Date: Tue, 6 Oct 2015 08:55:21 +0200

I support adoption.

`Key` would be very helpful for Client-Hints and for content negotiation
and adaptation in general, enabling origins and CDNs to adapt the content
to the user's situation (as reflected in Client-Hints or in similar headers
added by Service Workers) while maintaining its cachability in the
browser's cache and in supporting intermediaries (while maintaining a
`Vary` based fallback for non-supporting caches).

On Thu, Oct 1, 2015 at 7:22 AM, Mark Nottingham <[email-masked]> wrote:

> Based on the feedback received and after discussion with our Area
> Director, I believe that we should adopt this document as a WG product,
> with a target of Proposed Standard.
>
> Since I'm an author on the document, I've asked Martin Thomson to be
> Document Shepherd, to help judge consensus both of the CfA and during the
> document's LC, should we adopt it. He has graciously agreed.
>
> Please comment on-list; we’ll make a decision about adoption at the end of
> next week. The result of this CfA will also help us determine how to go
> forward with the Client Hints document.
>
> Regards,
>
> --

---

From: Leif Hedstrom <[email-masked]>
Date: Tue, 6 Oct 2015 15:17:58 +0800

> On Oct 1, 2015, at 1:22 PM, Mark Nottingham <[email-masked]> wrote:
> 

I’m very much in favor of adoption. +1.

Cheers,

—- leif

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 6 Oct 2015 13:42:07 +0200

On Thu, Oct 01, 2015 at 03:22:40PM +1000, Mark Nottingham wrote:
> Based on the feedback received and after discussion with our Area Director, I
> believe that we should adopt this document as a WG product, with a target of
> Proposed Standard. 
> 
> Since I'm an author on the document, I've asked Martin Thomson to be Document
> Shepherd, to help judge consensus both of the CfA and during the document's
> LC, should we adopt it. He has graciously agreed.
> 
> Please comment on-list; we???ll make a decision about adoption at the end of

It's quite interesting, I'm already seeing the benefits it can provide
compared to Vary. For example it could be more permissive regarding the
Accept-Encoding header field (eg: "Key: accept-encoding; match=gzip").

I definitely think it should be adopted!

Willy

---

From: Ilya Grigorik <[email-masked]>
Date: Tue, 6 Oct 2015 07:26:08 -0700

> `Vary` based fallback for non-supporting caches).

+1 to all of the above. Would love to see it adopted.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 19 Oct 2015 16:08:21 +1100

I've chatted to Martin about this, and he agrees that we have consensus to adopt. I'll try to get the doc submitted by the cutoff. 

Cheers,

> On 1 Oct 2015, at 3:22 pm, Mark Nottingham <[email-masked]> wrote:
>