Subject: RE: Alt-Svc WG Last Call comment https://github.com/httpwg/http-extensions/issues/121

From: Lucas Pardue <[email-masked]>
Date: Wed, 2 Dec 2015 09:22:30 +0000

Hi Julien,

Thanks for considering this issue and the others I have raised, the resolutions have all been good with just this one to finish off.

> I agree this is odd, and it's a result of our resolution for
> <https://github.com/httpwg/http-extensions/issues/36>, in which we
> realized that tracking though Alt-Used is much less interesting than tracking
> through the host names used for alternative services.
> 
> As such, the simplest possible fix is to remove the sentence.
> 
> The alternative would be to re-introduce a discussion of the tracking risk
> caused by Alt-Used into Section 9.4.
> 

I've not seen any discussion about your suggestions, which leans me towards the simple fix. However, saying that, it does seem a shame to discard information that someone may value in the future.  I'll be happy to leave the solution choice to your discretion.

Kind Regards
Lucas

---

From: Julian Reschke <[email-masked]>
Date: Tue, 8 Dec 2015 08:53:23 +0100

On 2015-11-28 18:52, Julian Reschke wrote:
> In <https://github.com/httpwg/http-extensions/issues/121>, Lucas Pardue
> observes:
>
>> Section 5 foreshadows a discussion about privacy
>>
>>     As the Alt-Used header field might be used by the server for
>> tracking the client, a client MAY choose not to include it in its
>> requests for protecting its privacy (see Section 9.4).
>>
>> However, Section 9.4 doesn't contain any mention of Alt-Used. Maybe
>> all the information contained in the document is enough but this just
>> struck me as a little odd.
>
> realized that tracking though Alt-Used is much less interesting than
> tracking through the host names used for alternative services.
>
> The alternative would be to re-introduce a discussion of the tracking
> risk caused by Alt-Used into Section 9.4.
>
> Best regards, Julian

Mark agreed 
(<https://github.com/httpwg/http-extensions/issues/121#issuecomment-162360413>), 
and as there was no other feedback, I have removed the sentence.

Best regards, Julian