Subject: Alissa Cooper's Yes on draft-ietf-httpbis-legally-restricted-status-04: (with COMMENT)

From: "Alissa Cooper" <[email-masked]>
Date: Sun, 13 Dec 2015 10:47:36 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-httpbis-legally-restricted-status-04: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-httpbis-legally-restricted-status/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I realize that the way this document uses the term "legal demand" has
been discussed at some length, but I'm concerned that the way that it is
used may limit the applicability of the status code, so I wanted to
mention that here.

The term "legal" has at least two meanings, one being "related to the
law" and the other being "authorized by law." I think it would be a shame
if use of this status code could be interpreted as a concession on the
part of a server operator that any particular demand was authorized by
law. Sometimes a server operator may feel the need to comply with a
request even if it does not believe the request is authorized by law
(e.g., while litigation is pending, or out of fear of adverse
consequences for its employees). Operators shouldn't be put in the
position where they have to be concerned that using the status code could
later be used as evidence that they believed a particular request was
authorized by law, particularly if there is a chance that they will be
sued for having blocked the resource.

The tricky part is that it takes more words to convey this concept than
the document currently uses. My suggestion would be to replace "legal
demand" with "demand based on a claim of legal violation" in the
abstract, section 1, and the first paragraph of section 3, and replace
all other instances of "legal demand" with "demand." This is a little
clunky but it's the best idea I could come up with.

---

From: Ted Hardie <[email-masked]>
Date: Mon, 14 Dec 2015 12:13:59 -0800

> clunky but it's the best idea I could come up with.

​I would be very hesitant to use "claim of legal violation", because it
might be read as agreeing that a violation had occurred.  You could alter
this further to clarify that this status code is used when returning the
relevant resource might result in a violation of laws, but I think that's
simply going to make matters worse.  I think the current language will be
understood in context, and it is better to keep than re-wordsmith now..

Just my two cents,

Ted

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Dec 2015 21:11:59 +0000

I'm still reading docs for this week, but 

On Mon, Dec 14, 2015 at 2:13 PM, Ted Hardie <[email-masked] <mailto:[email-masked]>> wrote:
On Sun, Dec 13, 2015 at 10:47 AM, Alissa Cooper <[email-masked] <mailto:[email-masked]>> wrote:
Alissa Cooper has entered the following ballot position for

​I would be very hesitant to use "claim of legal violation", because it might be read as agreeing that a violation had occurred.  You could alter this further to clarify that this status code is used when returning the relevant resource might result in a violation of laws, but I think that's simply going to make matters worse.  I think the current language will be understood in context, and it is better to keep than re-wordsmith now..

So, if Winston Churchill was still living, he might be saying "this status code is the worst possible, except for all the others"? [1] 

I may use that myself, one of these days.
 
Just my two cents,

Ted

[1] http://www.goodreads.com/quotes/267224-democracy-is-the-worst-form-of-government-except-for-all <http://www.goodreads.com/quotes/267224-democracy-is-the-worst-form-of-government-except-for-all>