Subject: Brief History of Web Sessions (95/96)

From: "Dave Wain" <[email-masked]>
Date: Tue, 22 Dec 2015 21:51:51 -0000

Guys, a bit of history: I was the first to get web sessions
to work (even though HTTP/1.0 wasn't good enough:)

I invented two methods:
a) http://www.poltara.co.uk/cgi-bin/deity?-XXXXXX-YYYYYY-ZZZZ
b) not yet disclosed.

The first method worked because argv[0]=="deity" and argv[1]==
"-XXXXXX-YYYYYY-ZZZZ" on both HTTPD and IIS with both the GET
and PUT methods.

The second method is not disclosed because only I know it.

THESE PREDATED ALL OTHER SOLUTIONS BECAUSE IT DIDN'T
REQUIRE HIDDEN FIELDS AND COOKIES:)

The original login pages are recorded at www.archive.org.

Dave Wain 

Note: This message is private and confidential and hence
must be received without interception or distortion by the
intended recipients only. Permission to use the information
explicitly must come from the sender (and recipients).

My personal web site and alternate contact details are at:
http://homepage.ntlworld.com/dave.wain/.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 Dec 2015 00:13:57 +0000

Dave, I presume that you're trying to either ask questions or provide or solicit feedback on a proposal.  But frankly, I'm not entirely clear which or what.

By starting a new e-mail thread with each comment, you're fragmenting the discussion.  From my standpoint, you've now sent several e-mails that are assertions of facts or opinions.  For example, the below e-mail, in which you tell us that you created something twenty years ago.  I read your e-mail, think "how nice for your résumé," and move on.

If you want to engage meaningfully, it might be useful to state explicitly what you're trying to accomplish.  If you're trying to provide a series of inputs on a topic, it would be useful to have that conversation in a single e-mail thread, so all the relevant e-mails are easily grouped together by everyone's mail reader of choice.

-----Original Message-----
From: Dave Wain [mailto:[email-masked]] 
Sent: Tuesday, December 22, 2015 1:52 PM
To: [email-masked]
Subject: Brief History of Web Sessions (95/96)

Guys, a bit of history: I was the first to get web sessions to work (even though HTTP/1.0 wasn't good enough:)

I invented two methods:

The first method worked because argv[0]=="deity" and argv[1]== "-XXXXXX-YYYYYY-ZZZZ" on both HTTPD and IIS with both the GET and PUT methods.

THESE PREDATED ALL OTHER SOLUTIONS BECAUSE IT DIDN'T REQUIRE HIDDEN FIELDS AND COOKIES:)

Dave Wain 

Note: This message is private and confidential and hence must be received without interception or distortion by the intended recipients only. Permission to use the information explicitly must come from the sender (and recipients).