Subject: Alt-Svc WGLC

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2015 12:23:27 +0100

Hi there,

thanks for the feedback so far.

With the latest changes for issues 
<https://github.com/httpwg/http-extensions/issues/125> and 
<https://github.com/httpwg/http-extensions/issues/126> (see also 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-alt-svc-latest-from-previous.diff.html>), 
I believe we're almost ready for a new draft and potentially IETF Last Call.

The remaining open points are:

1) In 
<https://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0375.html>, Hervé 
asked for an example of an ALTSVC frame. I note that the HTTP/2 spec 
doesn't have any examples of frames either, so I'm inclined not to add it.

2) In 
<https://github.com/hruellan/http-extensions/commit/fabd0943cde7e8af07f20b74acc2e48ac16e5f3e>, 
Hervé proposes a change that IMHO is not editorial as it affects a 
normative requirement. Feedback appreciated.

3) Mike Bishop proposed a change in 
<https://github.com/httpwg/http-extensions/pull/101> which I was not 
happy with. Instead, I made the change 
<https://github.com/httpwg/http-extensions/commit/acc3ae3c4290323069501d55ea8cdb5bacdbc6e8> 
(which is already in the WGLC draft FWIW). Is anybody not ok with this 
resolution?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 15 Dec 2015 12:16:52 +1100

On 14 Dec 2015, at 10:23 pm, Julian Reschke <[email-masked]> wrote:
> With the latest changes for issues <https://github.com/httpwg/http-extensions/issues/125> and <https://github.com/httpwg/http-extensions/issues/126> (see also <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-alt-svc-latest-from-previous.diff.html>), I believe we're almost ready for a new draft and potentially IETF Last Call.

LGTM.

> 1) In <https://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0375.html>, Hervé asked for an example of an ALTSVC frame. I note that the HTTP/2 spec doesn't have any examples of frames either, so I'm inclined not to add it.

+0.5.

> 2) In <https://github.com/hruellan/http-extensions/commit/fabd0943cde7e8af07f20b74acc2e48ac16e5f3e>, Hervé proposes a change that IMHO is not editorial as it affects a normative requirement. Feedback appreciated.

I'm OK with this.

> 3) Mike Bishop proposed a change in <https://github.com/httpwg/http-extensions/pull/101> which I was not happy with. Instead, I made the change <https://github.com/httpwg/http-extensions/commit/acc3ae3c4290323069501d55ea8cdb5bacdbc6e8> (which is already in the WGLC draft FWIW). Is anybody not ok with this resolution?

I think it's fine as is.

Just my .02,

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 15 Dec 2015 13:44:43 +0100

On 2015-12-14 12:23, Julian Reschke wrote:
> ...

Submitted -10, see changes in 
<https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-alt-svc-10>.

Best regards, Julian

---

From: Hervé Ruellan <[email-masked]>
Date: Tue, 15 Dec 2015 16:35:14 +0100

> doesn't have any examples of frames either, so I'm inclined not to add it.

OK, I can live without the example.

> normative requirement. Feedback appreciated.

Yes, this affects a normative requirement. However my proposed addition 
is already in the spec, in the third paragraph of "9.2 Changing Hosts", 
which is referring to 2.1. I find it better to have the whole 
description in 2.1.

> (which is already in the WGLC draft FWIW). Is anybody not ok with this

Cheers,

Hervé

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Dec 2015 10:14:21 +0100