Subject: GOAWAY after GOAWAY

From: Stefan Eissing <[email-masked]>
Date: Thu, 7 Jan 2016 19:39:12 +0100

Question arising during implementation: 

A hypothetical http server receives a GOAWAY from a client with no streams open. Should it attempt to send a GOAWAY back or can it safely close the connection?

rfc 7540. 6.8 seems to say that endpoints SHOULD always send a GOAWAY. But it seems not useful in such a case. Probably I am overlooking something?

-Stefan

---

From: Mike Bishop <[email-masked]>
Date: Thu, 7 Jan 2016 19:01:40 +0000

Yes, it SHOULD send the GOAWAY, which implies that it can also reasonably close the connection without sending it.  It's not a MUST, because sending it is always optional and sometimes serves no real purpose.  You've identified one of the latter.

-----Original Message-----
From: Stefan Eissing [mailto:[email-masked]] 
Sent: Thursday, January 7, 2016 10:39 AM
To: HTTP Working Group <[email-masked]>
Subject: GOAWAY after GOAWAY

-Stefan