Subject: Question about error code 451 and internet censorship

From: Philippe-Joseph Salazar <[email-masked]>
Date: Fri, 19 Feb 2016 07:10:55 +0000

Dear Madam/Sir,

 I am an academic researcher, currently preparing a book on the Islamic State
 for publication at Yale UP.

I have the following question: when a site is blocked due to censorship by
 a non-dictatorial state (ie not one of those that IETF lists in relevant
 documents, and I am thinking here of French state of emergency censorship), what error code is supposed to come up? 
Or, can you kindly direct me to
documents on your site that may help me find out what current policy or good
practice is in regard of sites censored by Western agencies?

Much appreciated,

 With best regards

PhJ Salazar

_________________________________________________________________________________

Philippe-Joseph Salazar
Distinguished Professor & Director
Centre for Rhetoric Studies
University of Cape Town, South Africa
+27 82 9021207
http://www.rhetoricafrica.org/index.asp <http://www.rhetoricafrica.org/index.asp> 
http://www.africanrhetoric.org <http://www.africanrhetoric.org/>

http://www.lesinfluences.fr/-Comment-raisonnent-ils-.html <http://www.lesinfluences.fr/-Comment-raisonnent-ils-.html>

http://www.lemieux-editeur.fr/Paroles-armees-revue-de-presse.html <http://www.lemieux-editeur.fr/Paroles-armees-revue-de-presse.html>

___________________________________________________________________________________________

---

From: "A.K. Sharma" <[email-masked]>
Date: Fri, 19 Feb 2016 16:17:11 +0530

http://thewire.in/2016/01/29/the-internet-has-a-new-standard-for-censorship-20386/

https://en.wikipedia.org/wiki/HTTP_451

This might be useful..

BR,
Amit

On Fri, Feb 19, 2016 at 12:40 PM, Philippe-Joseph Salazar <
[email-masked]> wrote:

>  documents, and I am thinking here of French state of emergency
> censorship), what error code is supposed to come up?
> *Philippe-Joseph Salazar Distinguished Professor & Director Centre for
> Rhetoric Studies University of Cape Town, South Africa +27 82 9021207
> <%2B27%2082%209021207> *
>
> *http://www.rhetoricafrica.org/index.asp
> <http://www.rhetoricafrica.org/index.asp> http://www.africanrhetoric.org
> <http://www.africanrhetoric.org/> *
>
>
>
> *http://www.lesinfluences.fr/-Comment-raisonnent-ils-.html
> <http://www.lesinfluences.fr/-Comment-raisonnent-ils-.html> *
>
>
>
> *http://www.lemieux-editeur.fr/Paroles-armees-revue-de-presse.html
> <http://www.lemieux-editeur.fr/Paroles-armees-revue-de-presse.html> *
>
>
> *___________________________________________________________________________________________
> *
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 19 Feb 2016 11:53:59 +0100

On Fri, Feb 19, 2016 at 07:10:55AM +0000,
 Philippe-Joseph Salazar <[email-masked]> wrote 
 a message of 612 lines which said:

>  I am an academic researcher, currently preparing a book on the
>  Islamic State for publication at Yale UP.

Hello. Apart from the specific case of HTTP status code 451, I'm not
sure it is the best place to ask. May be the IRTF research group HRPC
(Human Rights and Protocol Considerations)
<https://www.irtf.org/mailman/listinfo/hrpc>

> I have the following question: when a site is blocked due to
> censorship by a non-dictatorial state (ie not one of those that IETF
> lists in relevant documents, and I am thinking here of French state
> of emergency censorship), what error code is supposed to come up?

The IETF does not mandate how to censor :-) Various countries
(dictatorial or not) use different techniques. In France, the most
common one is forcing DNS resolvers to lie (see a technical survey of
DNS lying in Europe in
<https://labs.ripe.net/Members/stephane_bortzmeyer/dns-censorship-dns-lies-seen-by-atlas-probes/>)
and therefore to redirect to an official Web site (see it at
<http://interieur2.eu.org/>). This official server does not return a
451 but a plain 200 (funny, if you use wget, you'll get a 403, unless
you use --user-agent).

> Or, can you kindly direct me to documents on your site that may help
> me find out what current policy or good practice is in regard of
> sites censored by Western agencies?

I'm not aware of a comprehensive survey. There is an attempt
<https://datatracker.ietf.org/doc/draft-hall-censorship-tech/> but it
seems to move slowly. There are some very good country-specific
surveys such as for Greece
<https://www.usenix.org/conference/foci15/workshop-program/presentation/ververis>