Subject: Re: AD review of draft-ietf-httpbis-alt-svc-10

From: Julian Reschke <[email-masked]>
Date: Tue, 2 Feb 2016 22:58:32 +0100

On 2016-01-18 05:12, Mark Nottingham wrote:
> SGTM.

-> 
<https://github.com/httpwg/http-extensions/commit/c34dc83c7212da0b39b5606dceb325567c429bfc>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 3 Feb 2016 14:12:53 +0100

On 2016-01-15 04:27, Mark Nottingham wrote:
> In some side discussions, I've come across other people who are unhappy with this state of affairs, so I don't think you're alone. I'll leave it up to them to decide how to participate here.
>
> To be explicit -- we are opening up a potential same machine attack (specifically, someone on a shared HTTP server who has the ability to both add response headers -- such as with .htaccess or a CGI script -- and listen to another port (possibly, ANY port) on the same box can then hijack traffic intended for other users.
>
> The motivation for doing so is to enable the HTTP Opportunistic Security specification, which offers weak protection against pervasive monitors, but is vulnerable to active attackers, and doesn't improve Web security in other (and important) ways that HTTPS does. We have only one implementation of that specification in a browser, and no sign that it will be adopted by others.
>
> Is this a reasonable tradeoff? We are planning to publish this is Experimental, so the question might also be "is this a responsible experiment to run?"
>
> Cheers,

I opened <https://github.com/httpwg/http-extensions/issues/139> to track 
this.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 4 Feb 2016 11:45:31 +1100

Merged.

> On 4 Feb 2016, at 12:12 am, Julian Reschke <[email-masked]> wrote:
> 
> I opened <https://github.com/httpwg/http-extensions/issues/139> to track this.
> 
> Best regards, Julian
> 

--
Mark Nottingham   https://www.mnot.net/