Subject: [Editorial Errata Reported] RFC7234 (4674)

From: RFC Errata System <[email-masked]>
Date: Thu, 21 Apr 2016 06:04:09 -0700 (PDT)

The following errata report has been submitted for RFC7234,
"Hypertext Transfer Protocol (HTTP/1.1): Caching".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7234&eid=4674

--------------------------------------
Type: Editorial
Reported by: Vasiliy Faronov <[email-masked]>

Section: 5.4

Original Text
-------------
   When sending a no-cache request, a client ought to include both the
   pragma and cache-control directives, unless Cache-Control: no-cache
   is purposefully omitted to target other Cache-Control response
   directives at HTTP/1.1 caches.

Corrected Text
--------------
   When sending a no-cache request, a client ought to include both the
   pragma and cache-control directives, unless Cache-Control: no-cache
   is purposefully omitted to target other Cache-Control request
   directives at HTTP/1.1 caches.

Notes
-----
"other Cache-Control response directives" was probably intended to be "other Cache-Control request directives," because a request cannot have response directives.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7234 (draft-ietf-httpbis-p6-cache-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Caching
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Apr 2016 11:58:04 +1000

Accept - I think that's correct.

Cheers,

> On 21 Apr 2016, at 11:04 PM, RFC Errata System <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/