Subject: Re: Call for Adoption: draft-reschke-http-jfv

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Jun 2016 10:04:23 +1000

We've sat on this CfV for a while, mostly because we had other work in flight, some of it more urgent.

However, I'm seeing an increasing number of specs outside the WG depend on this spec, which both validates the approach, and increases the urgency of shipping it.

So, let's go ahead and adopt it. Julian, can you add it to the repo, please?

Cheers,

> On 11 Mar 2016, at 5:02 PM, Mark Nottingham <[email-masked]> wrote:
> 
> <https://tools.ietf.org/html/draft-reschke-http-jfv>
> 
> We've talked about this draft several times, and it appears there's decent interest in it. We also have external groups (e.g., W3C WebAppSec) starting to experiment with this format for headers.
> 
> My personal observation is that because of their open syntax, minting new HTTP headers is difficult to do correctly, even with the advice we gave in RFC7231. Providing a framework like this one can help guide authors, as well as ease the burden of reviewers. 
> 
> Julian has confirmed that he is willing to continue editing, and our AD is aware of this work. The only thing I'll add is that people shouldn't get too hung up on the exact syntax currently proposed; based on our discussions, it might change significantly.
> 
> There's already been support for it demonstrated at the meetings we've talked about it. Any additional thoughts?
> 
> --
> Mark Nottingham   https://www.mnot.net/
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 23 Jun 2016 21:12:22 +0200

> So, let's go ahead and adopt it. Julian, can you add it to the repo, please?

Done. Should I also submit a -00 draft?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 24 Jun 2016 09:47:24 +1000

Please.

> On 24 Jun 2016, at 5:12 AM, Julian Reschke <[email-masked]> wrote:
>