Subject: FW: New Version Notification for draft-bishop-httpbis-extended-settings-00.txt

From: Mike Bishop <[email-masked]>
Date: Mon, 13 Jun 2016 19:56:51 +0000

During our internal conversations about the certificates draft, the question that keeps coming up is why we can't just reuse the existing IANA registries for signing methods and such instead of defining a custom bitmask of supported algorithms.  It would make new crypto developments not require a document at the HTTP layer, it would make it easier to share parsing code between layers (and thus put maintenance in the hands of people who specialize in security code), and just generally looks cleaner than a bitmap.

But SETTINGS carries 32 bits per setting.  To do that, we'd have to add one more frame to the certificates draft (say, a CERTIFICATE_SETTINGS).  Or we need a SETTINGS frame that doesn't tie us to 32 bits, which seems strictly better as it can be reused in the future.  This draft defines the second option as an EXTENDED_SETTINGS frame, borrowing a lot from the RFC 7540 SETTINGS text.  (The ACK methodology is a little bit different, in that it allows the sender to choose whether an ACK is needed, and allows the recipient to declare understood/not-understood in the response.)

Feedback welcome, particularly around whether this would have utility for other folks. This is currently on a separate branch in the same repo as the certificate draft.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, June 13, 2016 12:42 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-extended-settings-00.txt

A new version of I-D, draft-bishop-httpbis-extended-settings-00.txt
has been successfully submitted by Mike Bishop and posted to the IETF repository.

Name:		draft-bishop-httpbis-extended-settings
Revision:	00
Title:		HTTP/2 Extended SETTINGS Extension
Document date:	2016-06-13
Group:		Individual Submission
Pages:		8
URL:            https://www.ietf.org/internet-drafts/draft-bishop-httpbis-extended-settings-00.txt
Status:         https://datatracker.ietf.org/doc/draft-bishop-httpbis-extended-settings/
Htmlized:       https://tools.ietf.org/html/draft-bishop-httpbis-extended-settings-00

Abstract:
   HTTP/2 defines the SETTINGS frame to contain a single 32-bit value
   per setting.  While this is sufficient to convey everything used in
   the core HTTP/2 specification, some protocols will require more
   complex values, such as arrays of code-points or strings.

   For such protocols, this extension defines a parallel to the SETTINGS
   frame, EXTENDED_SETTINGS, where the value of a setting is not a
   32-bit value, but a variable-length opaque data blob whose
   interpretation is subject entirely to the definition of the protocol
   using it.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 15 Jun 2016 14:34:10 +1000

Added to:
  https://github.com/httpwg/wiki/wiki/WatchList

Cheers,

> On 14 Jun 2016, at 5:56 AM, Mike Bishop <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Dee Holtsclaw <[email-masked]>
Date: Thu, 16 Jun 2016 17:09:55 -0400

Picking nits, but shouldn't section 6's first paragraph read as follows:

   This draft establishes one new registry and *adds* three entries across
   two existing registries.

Existing text:

   This draft establishes one new registry and add three entries across
   two existing registries.

Otherwise it seems to be reasonable and complete to me. Nice work IMHO.

<SNIP>

---

From: Mike Bishop <[email-masked]>
Date: Sun, 19 Jun 2016 21:09:57 +0000

Thanks for the catch – fixed.

From: Dee Holtsclaw [mailto:[email-masked]]
Sent: Thursday, June 16, 2016 4:10 PM
To: Mark Nottingham <[email-masked]>
Cc: Mike Bishop <[email-masked]>; HTTP Working Group <[email-masked]>
Subject: Re: New Version Notification for draft-bishop-httpbis-extended-settings-00.txt

   This draft establishes one new registry and adds three entries across

   two existing registries.

Existing text:

   two existing registries.